?
Solved

Windows 98 computer gets "No permission to access resource" when trying to access Windows XP Home computer's shared printer

Posted on 2004-08-03
16
Medium Priority
?
3,677 Views
Last Modified: 2008-01-09
I have a home lan with two Windows XP Home machines and several Windows 98 machines.  I would like to print to an HP LaserJet 1200 printer connected to one of the Windows XP machines.  I have made this printer shared and the other Windows XP machine can print to it fine.

When I try to add the printer on a Windows 98 machine, I get a message "not permission to access resource".

I have Zone Alarm Pro and Norton System Works running on the Windows XP machine but I have looked at every setting on those programs that I can think of and don't see anything that looks like it should be blocking things.  I have even added the IP addresses to Zone Alarm's Trusted Zone entries for two of the Windows 98 machines I am trying to get to use the printer.

I am pretty sure I had one of these Windows 98 machines printing to this LaserJet one time but I think that was before I re-loaded Windows XP on the machine in question and added Zone Alarm.

Any suggestions on why I am not able to get to the printer from these Window 98 machines?
0
Comment
Question by:mgump9
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +5
16 Comments
 
LVL 8

Expert Comment

by:Marakush
ID: 11709922
Try creating a username on both machines... you don't need to give it a password or anything... Then log into the Win98 machine with the username then try map the printer...

Marakush
0
 
LVL 10

Expert Comment

by:ngravatt
ID: 11710219

check the permisisions on your shared printer.  Right-click on the printer (while on the windows XP machine that it is connected to) and look at the permissions and security tabs.  Add a user called 'everybody' and give them full permissions.  This should allow the other computers to print.
0
 
LVL 1

Expert Comment

by:umbreho
ID: 11710422
Search and delete *.pwl files on the Win 98 machine.  Reboot, when you are prompted for user name, make it and the password the same as the Win XP the printer is shared from.
0
Get MySQL database support online, now!

At Percona’s web store you can order your MySQL database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card.

 

Author Comment

by:mgump9
ID: 11710487
ngravatt:

I don't get any Permission or Security tab when I select the Properties for the LaserJet 1200.  All I get are:

- General
- Sharing
- Ports
- Advanced
- Device Settings

Am I looking in the right place?
0
 
LVL 2

Expert Comment

by:orion411
ID: 11710518
Are you using Windows XP Home edition? If so I believe that turns off the Security tab.
0
 

Author Comment

by:mgump9
ID: 11710544
Marakush:

I did create a user on the Windows XP machine that is the same name on the Windows 98 logon screen.  I have gone back and forth between using Windows Logon and Client for Microsoft Network for the Windows 98 machine.  I am not clear on which one of those two options I should use or if it even matters.
0
 

Author Comment

by:mgump9
ID: 11710551
orion411:

Yes, it is Windows XP Home.  Is there a way to turn on the Security tab?
0
 
LVL 2

Accepted Solution

by:
orion411 earned 500 total points
ID: 11710566
Buy Windows XP Professional.
0
 
LVL 1

Assisted Solution

by:canner
canner earned 500 total points
ID: 11711862
HI verify that you can resources on the xp machine from windows 98

use the dos box

enter
net use K: \\XPHOME_machine_name\share

where xphome_machine_name is the name of you computer
and share the name of the share on the xphome machine

you should not be prompted for a password or username.

then try
net use lpt1 \\XPHOME_machine_name\printer_share

where printer_share is the name of the printer on the xphome machine

this should work you can print to lpt1 now

net use view

should give you the shares
 


0
 
LVL 1

Expert Comment

by:canner
ID: 11711869
sorry it was
net view

in the dos box to view shares
0
 
LVL 10

Expert Comment

by:ngravatt
ID: 11720359
look at the sharing tab, there should be a permissions button on that tab.
0
 
LVL 4

Assisted Solution

by:shad0_cheng
shad0_cheng earned 500 total points
ID: 11721375
Make sure the built in Firewall is off~ on your XP Home machine

Disable the XP firewall..
  From Control Panel, open Network Connections.
  Right-click Local Area Network from Control Panel's Network Connections and choose Properties
  Click the Advanced tab and deselect (remove the checkbox from) "Protect my computer..."
  Click OK and close out of Network Connections & Control Panel

Also, do the following
1. I went to Control-Panel-> Folder Options(?) -> View (?) and deactivated "use simple file sharing""
2. Under TCP-IP options->advanced->WINS I turned on "NETBIOS over TCP-IP".

Info extracted from another Expert-Exchange post
0
 
LVL 3

Assisted Solution

by:Fairco
Fairco earned 500 total points
ID: 11728259
Try enabling the Guest account in Control Panel. Theoritically enabling this account is only required to enable console logon for the guest user, but not required for accessing network resources anonymously. In practice I found that sometimes enabling this account is required for anonymous access.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question