Solved

Apache 1.3.27 virtual hosts

Posted on 2004-08-04
5
302 Views
Last Modified: 2013-12-16
Hello,

I have a server running Mandrake 9.1 with Apache 1.3.27 and I want to setup virtual hosting.  First things first...
I have setup the Vhosts.conf files to show:

#This is needed for Frontpage support
Port 80
ServerRoot /etc/httpd
ResourceConfig /dev/null
AccessConfig /dev/null

NameVirtualHost 192.168.0.2

<VirtualHost 192.168.0.2>
ServerName tesorocorp.com
ServerAlias www.tesorocorp.com
DocumentRoot /home/tesoro/public_html
ScriptAlias /cgi-bin /home/tesoro/cgi-bin
</VirtualHost>

<VirtualHost 192.168.0.2>
ServerName tesoroplans.com
ServerAlias www.tesoroplans.com
DocumentRoot /var/www/html
ScriptAlias /cgi-bin /home/tesoro/public_html
</VirtualHost>


Both websites are being displayed, however, the www.tesorocorp.com won't display the logos on the page.  Funny thing is that the logo that won't show is located at:

http://www.tesorocorp.com/images/clip_art/Logos/TesoroLogo.jpg 

The webserver gives me the "Document not found" error.  However, if I use the address

http://www.tesorocorp.com/~tesoro/ images/clip_art/Logos/TesoroLogo.jpg

The logo is displayed.  It is like the server isn't going deep enough into the directories to pull the files.  Any ideas?

Many thanks!

Johnathon B. Allread  
0
Comment
Question by:jballread
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 11715651
What does the href for the images in the misbehaving page look like?
0
 

Author Comment

by:jballread
ID: 11716191
Should it matter?  If the server won't display the image when you go to:

http://www.tesorocorp.com/images/clip_art/Logos/TesoroLogo.jpg


but will when going to:

http://www.tesorocorp.com/~tesoro/images/clip_art/Logos/TesoroLogo.jpg

Then it should be an Apache setting regardless of how the html file is setup.  Am I right?

Thanks!

Johnathon


0
 
LVL 40

Expert Comment

by:jlevie
ID: 11717019
That test does eliminate the hfref as the culprit. It wasn't clear to me that you'd tested it that way or were simply saying that was what it should have been.

What does the error_log say about the failure? It could be a permissions problem or something else.
0
 

Author Comment

by:jballread
ID: 11718333
jlevie, thanks for your responses.  I will split you some points when I get my next problem solved.  I did find the problem.  Someone added a global alias for a directory called "images" which was throwing everything off.  The problem I have now is that I want to add front page extensions to the new virtual website I just added to this Linux server.  I have FP extensions installed and setup for one website, but I cannot recall what I did to set it up.  I am sure it has to do with the utility owsadm.exe, but I do not recall the switches.  Any help?  

Thanks!
0
 
LVL 40

Accepted Solution

by:
jlevie earned 300 total points
ID: 11722225
Yeah, a server alias for /images would confuse things.

The only times I've been forced to use FP on a web server I've found that using IE on a windows box is the best way of adding/managing sites. I tried using owsadm but wasn't ever able to get it to work properly.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
can i read my emails on lamp ftp 4 64
Apache LDAP Authentication 20 70
Check for Linux process in script 7 84
Disabling security updates Ubuntu 3 62
Introduction Knockoutjs (Knockout) is a JavaScript framework (Model View ViewModel or MVVM framework).   The main ideology behind Knockout is to control from JavaScript how a page looks whilst creating an engaging user experience in the least …
Introduction Since I wrote the original article about Handling Date and Time in PHP and MySQL several years ago, it seemed like now was a good time to update it for object-oriented PHP.  This article does that, replacing as much as possible the pr…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …

731 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question