Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1042
  • Last Modified:

Mapped Drives don't reconnect until you click on them

I have several mapped drives in my Windows 2000 server domain. I use a network program called @vantage Fax that is mapped to the M: drive. When you click on the icon for the program it says that the program cannot be found. When you open up My Computer the mapped drive has a red X through it, but when you double click on it the drive opens and the red X is gone. After that if I go back and start the program it works fine.

Thanks,
TKOA
0
tkoa
Asked:
tkoa
  • 6
  • 4
  • 2
  • +1
1 Solution
 
sirbountyCommented:
Try connecting that drive this way:

Start->Run->CMD
NET USE M: \\Server\Share /Persistent:Yes
0
 
lmklamCommented:
try to experiment this.
instead of mapping M: with the server name, try to map it with the server's ip address.  Then restart your client computer to check whether the next time happen to be the same.  If it does solve the problem, then it is very likely related to name resolving problem.  Depending on your network setup, it can be DNS, WINS, or even netbios.  Try it first to see.

lmklam
0
 
tkoaAuthor Commented:
Can "NET USE M: \\Server\Share /Persistent:Yes" be used in my login script?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sirbountyCommented:
Yes.
0
 
tkoaAuthor Commented:
No it didn't work. I forgot to say that I use a program called Kixtart 2001 for login scripts, so instead of "Net Use" I just use "Use" but it still didn't work. I also tried
using:

USE M: /DELETE
USE M: \\Iris\advantage /Persistent:Yes

But it still didn't work. It maps the drive fine, but no programs can use it until I double click the drive first.

0
 
tkoaAuthor Commented:
I just wanted to add this.

The drives that are mapped that are on the main server don't have the red X, its only the one's on different servers. ie. the fax server.

Thanks,
TKOA
0
 
tkoaAuthor Commented:
I also tried using the server's ip address instead of the server's name and still no go.

Thanks,
TKOA
0
 
sirbountyCommented:
Yes, we use kix as well...though we also incorporate ifmember and run seperate batch file jobs...

http://support.microsoft.com/?id=297684 lists your problem, with a resolution of:

>>To resolve this behavior, change the default time-out period on the shared network computer. To do this, use one of the following methods.

NOTE: You cannot change the default time-out period for Microsoft Windows 95-based computers and Microsoft Windows 98-based computers that have shared resources.
Registry Editor
NOTE: You cannot use this method to turn off the autodisconnect feature of the Server service. You can only use this method to change the default time-out period for the autodisconnect feature. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use Registry Editor to increase the default time-out period. To do this, follow these steps, and then quit Registry Editor:
Click Start, click Run, type regedit (Windows 2000 or Windows Server 2003) or type regedt32 (Windows NT 4.0), and then click OK.
Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify. If the autodisconnect value does not exist, follow these steps:
On the Edit menu, point to New, and then click REG_DWORD.
Type autodisconnect, and then press ENTER.
Click Hexadecimal.
In the Value data box, type ffffffff, and then click OK.
Command Line
NOTE: If you use this method, you may turn off the autotuning feature for the Server service.

To change the default time-out period for the autodisconnect feature of the Server service, open a command prompt, type the following line, and then press ENTER
net config server /autodisconnect:number

where number is the number of minutes that you want the server to wait before it disconnects a mapped network drive. The maximum value for this command is 65,535.

NOTE: If you set the autodisconnect value to 0 (zero), the autodisconnect feature is not turned off, and the Server service disconnects mapped network drives after only a few seconds of idle time.

To turn off the autodisconnect feature, open a command prompt, type the following line, and then press ENTER:
net config server /autodisconnect:-1
<<
0
 
tkoaAuthor Commented:
Still not working. I tried setting the autodisconnect on the main server, the fax server, and the workstation, but still no go.
0
 
sirbountyCommented:
Stupid question maybe, but did you reboot afterwards?
0
 
fatpCommented:
Do you have any reply when you ping the servers?
0
 
tkoaAuthor Commented:
Yes I did reboot afterwards and yes I can ping the server. When I click on the drive it connects fine, its just that we have to click on the drive first before we can run any program on that server.

Thanks
0
 
fatpCommented:
We are having the same probleme in our buisness....but to resolve this we made a simple batch file that copie a fin every 10 min into the target server....this is not a solution but at least it will reduce the numbers of call related to this problems.....

I'm sorry I cannot help you =|
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now