Solved

BackupExec Hangs/Crashes Domino Server

Posted on 2004-08-04
8
808 Views
Last Modified: 2013-12-18
Hello folks...

I'm running Domino 6.5 on Win2K Server. It's been running great for months.

I recently installed Veritas BackupExec for Windows Server 9.1. I also installed the Agent for Lotus Domino Databases in order to do online backups of Domino.

What I am experiencing is that during the backup, the backup job seems to hang and then eventually fail. The Domino server is still responding at first, but then when the backup job finally fails, the Domino server seems to fail as well.
The failure is occuring at different points - ie. it's not always the same database. The total size of all the Domino dbs is 40GB. Last night it got 98% of the way done, and then stopped. The job was still active, but all network activity stopped, and the byte count stopped incrementing. On the Domino server, the beremote.exe showed 0% CPU (it was higher when the backup was running). Eventually the backup job failed, but it waited several hours before doing that.

One initial problem I had was a memory leak that caused the domino services (nserver, nupdate, nhttp, etc) to grow and grow until the server stopped responding. The backup seemed to make this problem worse, but I believe I've fixed that by adding two lines to the notes.ini on the server: ContrainedSHM=1 and ConstrainedSHMSizeMB=550. This restricts the Domino server workspace to 550MB of RAM (the server has 1GB).
For reference on these issues see here:
http://www-10.lotus.com/ldd/nd6forum.nsf/55c38d716d632d9b8525689b005ba1c0/1db73bb3d91c918c45256ced003a99b7?OpenDocument
http://www-1.ibm.com/support/docview.wss?uid=swg21095911

So now the Domino server isn't spontaneously hanging during a backup due to memory problems, but the backup jobs are still failing for seemingly other reasons.

The Veritas error being created is this:
Completed status: Failed
Final error: 0xa000fe30 - A communications failure has occurred.
Final error category: Server Errors

I've searched the Veritas site and found some seemingly-related articles, but nothing has fixed this yet.

Any ideas or solutions would be great.

0
Comment
Question by:JammyPak
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 4

Accepted Solution

by:
DeanHarris1 earned 250 total points
ID: 11717462
Never seen this before but i did have a problem recently with 9.1 and modified the setup re the below doc and problem was resolved

http://seer.support.veritas.com/docs/252932.htm
0
 
LVL 16

Author Comment

by:JammyPak
ID: 11718639
Thanks...but I'm not sure I understand what that registry key is actually doing...

Enable Offline Backup = 1

To me 'offline backup' makes me think that the Domino server is shutdown. What I want to do is backup the databases while the Domino server is running. Do you remember what the problem was that you were having?
0
 

Assisted Solution

by:aszumilo
aszumilo earned 250 total points
ID: 11720214
Not sure if Domino requires it or not, but on our SQL server boxes we run Open File Manager.  Possibly the issue could be related to the backup trying to access a database that is in use by another process?  Thereby causing it to fail?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 16

Author Comment

by:JammyPak
ID: 11720757
thanks aszumilo, but no...at least it's not *supposed* to need that from what I've read. The Domino agent should be all I need. I do have a copy of the Open File Agent, so maybe I'll test it out.
0
 
LVL 16

Author Comment

by:JammyPak
ID: 11773644
Update:
The actual backup seems to be completing now...all I did was reboot the Veritas server. <sheesh>

Anyway, Domino is still hanging after every backup...the nserver.exe CPU% goes up to around 30% and stays there after the backup finishes. Shortly later (within 3 hrs) everyone starts getting 'server is not responding' messages and I have to reboot.

I've opened up a case with Lotus on this, so we'll see what happens.
0
 
LVL 63

Expert Comment

by:Zvonko
ID: 12819708
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I will leave the following recommendation for this question in the Cleanup topic area:
    Delete with points refunded

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Zvonko
EE Cleanup Volunteer
0
 
LVL 16

Author Comment

by:JammyPak
ID: 12821328
I opened cases with Lotus and Veritas, but never got things working properly...anyway, it's not relevant now, because the email configuration has been changed. Thanks for the help.
0
 
LVL 63

Expert Comment

by:Zvonko
ID: 12821836
Thanks for coming back to your question.
What is your recommendation for this question closing disposition? Delete? Close with refund? Or accept some comments as solution?
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question