BackupExec Hangs/Crashes Domino Server

Hello folks...

I'm running Domino 6.5 on Win2K Server. It's been running great for months.

I recently installed Veritas BackupExec for Windows Server 9.1. I also installed the Agent for Lotus Domino Databases in order to do online backups of Domino.

What I am experiencing is that during the backup, the backup job seems to hang and then eventually fail. The Domino server is still responding at first, but then when the backup job finally fails, the Domino server seems to fail as well.
The failure is occuring at different points - ie. it's not always the same database. The total size of all the Domino dbs is 40GB. Last night it got 98% of the way done, and then stopped. The job was still active, but all network activity stopped, and the byte count stopped incrementing. On the Domino server, the beremote.exe showed 0% CPU (it was higher when the backup was running). Eventually the backup job failed, but it waited several hours before doing that.

One initial problem I had was a memory leak that caused the domino services (nserver, nupdate, nhttp, etc) to grow and grow until the server stopped responding. The backup seemed to make this problem worse, but I believe I've fixed that by adding two lines to the notes.ini on the server: ContrainedSHM=1 and ConstrainedSHMSizeMB=550. This restricts the Domino server workspace to 550MB of RAM (the server has 1GB).
For reference on these issues see here:
http://www-10.lotus.com/ldd/nd6forum.nsf/55c38d716d632d9b8525689b005ba1c0/1db73bb3d91c918c45256ced003a99b7?OpenDocument
http://www-1.ibm.com/support/docview.wss?uid=swg21095911

So now the Domino server isn't spontaneously hanging during a backup due to memory problems, but the backup jobs are still failing for seemingly other reasons.

The Veritas error being created is this:
Completed status: Failed
Final error: 0xa000fe30 - A communications failure has occurred.
Final error category: Server Errors

I've searched the Veritas site and found some seemingly-related articles, but nothing has fixed this yet.

Any ideas or solutions would be great.

LVL 16
JammyPakAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DeanHarris1Commented:
Never seen this before but i did have a problem recently with 9.1 and modified the setup re the below doc and problem was resolved

http://seer.support.veritas.com/docs/252932.htm
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JammyPakAuthor Commented:
Thanks...but I'm not sure I understand what that registry key is actually doing...

Enable Offline Backup = 1

To me 'offline backup' makes me think that the Domino server is shutdown. What I want to do is backup the databases while the Domino server is running. Do you remember what the problem was that you were having?
0
aszumiloCommented:
Not sure if Domino requires it or not, but on our SQL server boxes we run Open File Manager.  Possibly the issue could be related to the backup trying to access a database that is in use by another process?  Thereby causing it to fail?
0
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

JammyPakAuthor Commented:
thanks aszumilo, but no...at least it's not *supposed* to need that from what I've read. The Domino agent should be all I need. I do have a copy of the Open File Agent, so maybe I'll test it out.
0
JammyPakAuthor Commented:
Update:
The actual backup seems to be completing now...all I did was reboot the Veritas server. <sheesh>

Anyway, Domino is still hanging after every backup...the nserver.exe CPU% goes up to around 30% and stays there after the backup finishes. Shortly later (within 3 hrs) everyone starts getting 'server is not responding' messages and I have to reboot.

I've opened up a case with Lotus on this, so we'll see what happens.
0
ZvonkoSystems architectCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I will leave the following recommendation for this question in the Cleanup topic area:
    Delete with points refunded

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Zvonko
EE Cleanup Volunteer
0
JammyPakAuthor Commented:
I opened cases with Lotus and Veritas, but never got things working properly...anyway, it's not relevant now, because the email configuration has been changed. Thanks for the help.
0
ZvonkoSystems architectCommented:
Thanks for coming back to your question.
What is your recommendation for this question closing disposition? Delete? Close with refund? Or accept some comments as solution?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lotus IBM

From novice to tech pro — start learning today.