Improve company productivity with a Business Account.Sign Up

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1432
  • Last Modified:

DNS error


I recently had a problem with my computer running windows 2000pro concerning pop ups. Trying to solve that, one suggested that I use this tool: LSPfix  on  'rnr20.dll' which I did. I also used tried to repair internet explorer using One of those two steps caused the computer not to be able to resolve names, for example comes out as DNS error while if I do nslookup, it is able to contact yahoo.

1 Solution
You have probably unwittingly downloaded something nasty.

This link (largely courtesy of COBOLDinosaur) contains everything you need to know about spyware, scumware, adware, hijacked home pages etc and the tools you need to get rid of them:


Hello nmahmo =)

search ur hard drive for a file called, HOSTS
open it in notepad
does it have the entries for websites like yahoo and other sites ??

Can u Download HijackThis(new version), run it and Post the Log File here:
If you are able to do a nslookup then your DNS is correct, so the issue is with Internet Explorer. You can openeing Internet Explorer and go to TOOLS|Internet Options|Connections, and click on SETUP. Walk through the wizard and after it completes, close Internet Explorer and reboot. See if problem is solved.
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

wait wait..... u said " one suggested that I use this tool: LSPfix  on  'rnr20.dll' which I did "

so u removed that dll files, right ??
if YES then this can be the problem,,,,, this dll file is provided by ur ISP.... and removing this can broken the access from ur ISP =|

Try running this Winsock Repair:

this is for WinXp, but shud work for Win2000 also !!!!
I don't think it broke his connection whis his isp as he can still use nslookup.  Tricky one man, just try an ipconfig /flushdns, then try again.
Shehar... could very well be correct, does you provider require that you run a setup or install, and use a password etc., this is usually the case with DSL such as Verizon etc, and some dial ups. If that is the case, as Shehar..... suggested fix the file, and then rerun the setup program your provider gave you. Let us know how you are coming along please.
nmahmoAuthor Commented:
The problem was on both explorer and netscape so resetting up explorer wouldn't work.
I thought LSP removed this file but when I searched for it I found it in the right place.
ifconfig/flushdns didn't work.
What worked was the Winsock Repair, so thank you Sheharyaar
great ^_^
Good fix. SheheryaarSaahil
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now