Solved

Suse VSFTPD Setup

Posted on 2004-08-04
7
3,007 Views
Last Modified: 2007-11-27
Hey everyone,

First off I am a nebie to linux and only installed it so I can learn at it.

I am running Suse linux 9.0 with KDE 3.2

I want to enable the ftp server

I was able to install vsftpd and run it from a tutorial guide i found online.

When I add a user to the ftp server for access and assign it a directory, when i login from the local machine everything is fine and the directory i choose shows. When I use my windows computer and type ftp://192.168.1.105 in internet explorer and login the choosen directory appears and everything is fine.

However when I use a ftp client, and login it says the directory choosen can not be found or displayed show the root directory is shown

and then it shows the root folder of my linux box. this is not good nor secure

for the command ive been using useradd admin -d /srv/www/httpdocs

can someone please help me as to why this is happening. Once again I am a newbie to linux so detailed instructions would be needed here.

I am also asking if somsone would tell me how I can delete vsftpd and restall it all over again and start from the begining, and also help as to how to add users to the ftp server to lock them into their own home directory without giving them any way of escaping out and accessing other folders.

Thank you
Kevin
0
Comment
Question by:krazieintent
  • 3
  • 2
7 Comments
 
LVL 2

Expert Comment

by:Adagium
ID: 11723237
I'm not a SuSE wiz, but it's a RPM distro; so just go to YaST and remove the package using it's browser (software - add/remove packages?). Then go to the same place and install it again. Anyway, it's probably not the case here, unless you have messed with the vsftp conf file.

The option to lock your users at their ftp home dir using vsftpd is the following:
chroot_local_user=YES

Just open your /etc/vsftpd.conf and uncomment this line (removing the '#' in front of it), or write it if it's not there.

VsFTPD is a very powerful ftp server, read more about it in the man page (man vsftpd, man vsftpd.conf).
0
 
LVL 3

Author Comment

by:krazieintent
ID: 11741434
Thanks a lot adagium that worked, and now the proper directories come up for each user, but I cant upload anyfiles.

I dont know how to set permissions to allow file transer, can you help me set that up please?

thanks

Kevin
0
 
LVL 2

Expert Comment

by:Adagium
ID: 11745443
Unless you're just toying with the ftp server, I recommend you have a serious look at the man pages related to it; a dangerous configuration might put your system on risk.

From the default vsftpd.conf file:

# General Settings
# Uncomment this to enable any form of FTP write command.
#write_enable=YES

Do that, and remove the '#' from the line write_enable=YES to enable write mode on your ftp.

If you want that the user anonymous to be able to upload also, look for the following:
# Uncomment this to allow the anonymous FTP user to upload files.
#anon_upload_enable=YES

Do the same that above and remove the '#' from the anon_upload_enable=YES. Note that it'll only work if the global write_enable flag is uncommented.
0
 
LVL 3

Author Comment

by:krazieintent
ID: 11788550
all of those settings are set but still can not upload.

when connecting from a windows computer

the error is

200 switching to binary mode
200 PORT command successful. Consider PASV
553 could not create file

keep in mind i can download fine

any ideas?
0
 
LVL 2

Accepted Solution

by:
Adagium earned 500 total points
ID: 11790340
So, you're sure that the line is
write_enable=YES
instead of
#write_enable=YES
hum?

If so, create a 'upload' directory under the ftp main dir and run a "chmod 777 upload". If you still can't upload files on it, then I'm not really sure how to get it working...
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Automating a script for user accounts LINUX 14 68
PC upgrade to Linux Mint 7 65
AWS CLI - Instances, Volumes & Tagging 2 73
Choosing CentOS 16 50
rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now