Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Windows 2000 Server's CPU Usage sitting at 100%...

Posted on 2004-08-04
14
Medium Priority
?
205 Views
Last Modified: 2010-04-14
Hello,

I run a Windows 2000 Server machine, and just this week it all of a sudden has been running EXTREMELY sluggishly while making regular computer tasks rather impossible to complete!!

I immediately checked its Task Manager to verify Performance and Processes, and sure enough the computer is sitting at CPU Usage:  100%.  I have taken screen prints of the Performance and Processes screens and posted them at the following URLs for reference.  In the Processes screen I presorted the list with the 'Mem Usage' column descending to determine what process is hogging the most memory:

http://www.dslextreme.com/users/kevinlyons/taskManagerPerformance.jpg
http://www.dslextreme.com/users/kevinlyons/taskManagerProcesses.jpg

The only thing I know that has changed in the system in the past few days is installing the latest hotfixes/service patches/packs from Microsoft for the month of July '04 for Windows 2000, Internet Explorer, and Outlook Express.  Perhaps one or more of these might be a cause of the problem?

If anyone can help me to figure out what is happening I would be most grateful!

Thanks much,

Kevin
0
Comment
Question by:lkkl
  • 4
  • 3
  • 3
  • +3
14 Comments
 

Author Comment

by:lkkl
ID: 11720719
Hello,

Additionally, to help in the diagnosis, I've run a complete spybot spyware check and norton anti-virus check (up-to-date virus definitions) on the system.  Both completed successfully with no hint of any spyware or a virus, trojan, worm, or the like.

Thanks much,

Kevin
0
 
LVL 5

Expert Comment

by:dgroscost
ID: 11720758
Turn off Indexing Services service.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 11720759
You need to find out what processes are eating up your CPU cycles..  Dnload Process Explorer from Sysinternals and use it for discovery purposes:

Process Explorer v8.41
Find out what files, registry keys and other objects processes have open, which DLLs they have loaded, and more. This uniquely powerful utility will even show you who owns each process.

http://www.sysinternals.com/ntw2k/freeware/procexp.shtml
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 7

Expert Comment

by:GATOR420
ID: 11721761
dgroscost should be correct that it has to do with the Indexing Service. Try stopping the service through computer management.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 11722234
The indexing service does take up CPU cycles, but this condition does not necessarily imply that this service is causing your problem....  I have it running on all my servers, and I find no issue with it......  I do turn it off on my XP clients though, as it is not necessary for fast file retrieval on workstations.

FE
0
 
LVL 8

Accepted Solution

by:
ckumar42 earned 2000 total points
ID: 11723054
As your screenshots show cidaemon.exe taking up much of the cpu, turn of indexing and see how the server goes:
You can disable it by the following
Start -> Search  ->  Change preferences   ->  With Indexing service (for faster local searches)   ->   click "no, do not enable indexing service"

0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 11724289
How can you see that screenshot?  I could not make it out..  :)  

If that is the process that is taking up your cycles, then these experts are correct, as it is the process responsible for indexing..

FE
0
 
LVL 6

Expert Comment

by:DanniF
ID: 11725911
Hi,

Your problem is Hotfix 835732 (Sasser fix). I had this happen to me with a 2000 pro machine at the office and found that it was the DAT driver that was causing the problem.

This problem is recognized by Microsoft and you can find details about it here:

http://support.microsoft.com/default.aspx?kbid=841382

The Microsoft article does not address properly how to uninstall the Hotfix (without it taking you 2 days).

Here is what worked for me:

1. Boot into Safe mode

2. In Taskmanager, give the Explorer process REALTIME priority

4. Run ADD/Remove Programs

5. In Taskmanager, give the MSHTA.exe process REALTIME priority (this is Add/Remove Programs)

6. Remove "Windows 2000 Hotfix  - KB835732"

7. In Taskmanager, give the SPUNINST.exe process REALTIME priority

8. After the uninstall has finished and you click Finish to restart it will take very long
for the computer to restart and I eventually just turned it off and back on and everything was back to normal.

This leaves you with finding which of the drivers or services is causing your problem.

Hope this helps,

Daniel F.
0
 
LVL 6

Expert Comment

by:DanniF
ID: 11725984
Fired my guns a bit early there.... I didn't notice that cidaemon.exe is taking up process time, and, because I didn't see it, nor the system process I thought that must be it.

Anyways, any news on disabling the indexing service? Is cidaemon hogging resources non-stop or is it distributed between processes?

Regards,

Daniel F.
0
 
LVL 6

Expert Comment

by:DanniF
ID: 11726047
Just in case you don't know here's how you disable the indexing service:

Start-Search-Change preferences-With Indexing service (for faster local searches)-and click "no, do not enable indexing service"

Daniel F.
0
 

Author Comment

by:lkkl
ID: 11728206
All:

Thanks for getting back to me with the great suggestions!

I have made the changes to disable the indexing service, but even prior to doing so, all of a sudden the normal CPU usage performance has returned...  I then re-enabled the indexing, and all appears okay with regard to performance.

If the sluggishness occurs again I will keep the indexing service disabled!

Thanks again,

Kevin
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 11729891
Great...  lets hope it holds..!!  (Indexing is nice to have running on a server, if it works properly...)

FE
0
 

Author Comment

by:lkkl
ID: 12325504
All:

ckumar42's detailed explanation (by turning off the indexing service to the server) appears to have worked as expected!

Thanks much,

Kevin
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Take a look at these 6 Outlook Email management tools which can augment the working and performance of Microsoft Outlook to give you a more rewarding emailing experience.
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
This lesson discusses how to use a Mainform + Subforms in Microsoft Access to find and enter data for payments on orders. The sample data comes from a custom shop that builds and sells movable storage structures that are delivered to your property. …

926 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question