Solved

hall.dll missing - cannot boot from disc to get into recovery console

Posted on 2004-08-04
22
24,740 Views
Last Modified: 2012-05-05
I came home to find the following error message:

Windows could not start because the following file is missing or corrupt:
Windows root>\system32\hal.dll.
Please re-install a copy of the above file.

I've read and tried all the links pertinent to fixing this problem.

1) I cannot boot from disc - I get a disc boot error when I try
2) I have already rearranged the boot order in BIOS to every possible combination. CD-ROM and Floppy before HDD-0 does not work.
3) All I really want to do is re-install XP. I have two harddrives, a 60 gig and a 120 gig. I have a CD-rom and a DVD-rom drive. How can I get my computer to boot from disc?

Thanks for your help,
carloco69
0
Comment
Question by:carloco69
  • 7
  • 5
  • 2
  • +7
22 Comments
 

Expert Comment

by:spasheridan
Comment Utility
Well, you should be able to boot from CD no problem, as long as you have a modern motherboard.

Looking at your post you seem to be trying to boot from disk.. what disk?  Do you have you're XP cd?

I would try to boot from CD.  Put you're WinXP cd in the cd rom and boot from it.  Make sure that CD ROM is set as the 1st boot device and when the xp installer loads try the repair utility.  This is a much nicer fix than reinstalling windows because a reinstall of the OS means a reinstall of all your applications.

If you don't have a CD.... you might try this... I have my doubts that it will work though.

Hit f8 as you boot (from hard disk) and see if any of the options such as safe mode or the like work.  If yes, maybe you can try and replace the file from a reliable source... say

http://www.dll-files.com/dllindex/dll-files.shtml?hal

You could also try creating a DOS boot disk and burning the hal.dll file to a cd.  Then you might be able to boot from the floppy disk and copy the damaged file from the cd.

Hope that helps!
0
 

Author Comment

by:carloco69
Comment Utility
Thanks for the suggestions.

I have the XP cd, butit won't boot - i've already tried setting up the CD ROM as the 1st boot device. I'e also tried hitting the f8 key as I boot but it won't start in safe mode either. it keeps giving me the missing dll file error.

the problem with creating a dos boot disc and burning the hal.dll file to a cd is that it won't boot from CD - there's a disc boot error for some reason. is there anything else i can do?

it's detecting both my drives and floppy and cd rom just fine - it just won't boot from the cd rom.

i don't care about losing data or programs - i have everything backed up. so all i really need to do is find someway to re-install xp from the installation disc which means finding out how to get the computer to boot from the CD.

any other suggestions?
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
If your system was formatted with FAT32, you can just boot to a Win98  floppy and then copy the hal.dll from your XP cd over to your hard drive.  'copy D:\1386\system32\hal.dll c:\windows\system32\hal.dll'

If NTFS, then dnload the XP boot floppys, and go to the Recovery Console...  If you can now access your cdrom, then copy the file over from there.  If not, you can copy the hal.dll to a floppy, and copy it over...

XP Home boot floppy:  http://www.microsoft.com/downloads/details.aspx?FamilyID=e8fe6868-6e4f-471c-b455-bd5afee126d8&displaylang=en

XP Pro boot floppy:  http://www.microsoft.com/downloads/details.aspx?FamilyID=55820edb-5039-4955-bcb7-4fed408ea73f&displaylang=en

And, if you want to reinstall, then use the boot setup floppys to get to the setup screen, then try installing from the cdrom..

FE
0
 

Author Comment

by:carloco69
Comment Utility
heh. this is all great, but the main problem still remains:

the disc boot error. my computer is having a problem booting from ANYTHING! it won't bot from the floppy or from the cd rom. so these suggestions would be great but i really have to figure out why it's not booting from cd.

any other suggestions?
0
 

Author Comment

by:carloco69
Comment Utility
basically any solutions that involve booting from cd won't work. i need to find out WHY it WON'T boot from CD.

i'm desperate.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
And you cannot boot from your floppy either?  Is so, then the problem lies in your bios, I believe.  You might try clearing the CMOS.  Easiest way to do this is to take the battery out of your motherboard for a few minutes, then put it back in.   (these look like a quarter)...  Try again, and let us know..
0
 

Author Comment

by:carloco69
Comment Utility
I just took the battery out of the motherboard (while the computer was off) - but I don't think it did anything to the CMOS. Any other suggestions?
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
What kind of computer are we talking about here?  Namebrand?
0
 

Author Comment

by:carloco69
Comment Utility
hmmmm, now it says floppy disc fail (40) in addition to the other hal.dll error
0
 

Author Comment

by:carloco69
Comment Utility
it's a computer i got from a friend - pentium 4 2.26ghz processor. via motherboard.

is it strange to get the VIA motherboard logo on startup? i've never gotten that before.

same problems still there. floppy disc fail (40), hal.dll error, and it also won't read the mouse connected to my usb (says there's a ps2 mouse error.

any suggestions?
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Expert Comment

by:spasheridan
Comment Utility
woah.  Sounds a bit strange.

where do you get this mouse error??  If you can't load windows then the mouse shouldn't load.

You need to be able to load SOME os on the PC to make it work.  Since the HDD OS is busted, you need to load the OS from some other media.  The 2 standards are CD and Floppy, so let's work it that way.

try this

1) Go into the bios.  Disable the via mobo logo on boot.  disable quick boot.  Modern PCs boot fast, this will give you a chance to see everything on the screen and some time to react to what shows up.

2) Set boot order CD-Rom, Floppy, HDD.  Check to see WHICH CD it's telling you it can boot from.  If push comes to shove, unploug the power to the DVD ROM so you only have a single CD device to boot from.

3) Insert the XP CD, reboot.  You should see some CD ROM read activity as it attempts to read the CD for booting.  THen it should ask you on the screen to hit any button to boot from CD.  Does this happen?  If it doesn't, unplug the power to the CD ROM and power up the DVD.  Try booting from that device.  Also, try and boot ANOTHER pc from that WinXP CD.  The CD could be bad.  IF it works on another PC but not yours, then there is probably an issue with the MOBO or your CD ROMS.

4) If that doesn't work, try booting to a floppy with CD-ROM support.  Test the floppy on another PC to make sure it is actually a boot disk.  Again, on boot, if you have a disk in the floppy drive there should be disk activity on the floppy drive (the light goes on).  If it does work then you may be able to copy the file directly.

PS - clearing the CMOS / restoring factory defaults.  Check the manufactures website for a schematic and manual.  Usualy availble in pdf format.  On the MOBO there are usually a pair of "nipples".  Little metal circles the size of a small screw with raised indentations on the top.  You can short those 2 things with a paperclip to reset the CMOS.
0
 

Author Comment

by:carloco69
Comment Utility
augh, ok the problems are:

1) I went into the BIOS and disabled the via mobo logo and quick boot. I set the boot order to CD-Rom, Floppy, HDD - Nothing. Same error. (hal.dll)
2) I unplugged the power to the DVD ROM so I only had a single cd device to boot from - Nothing. Same error.
3) I unplugged the power to the CD-ROM so I had only the other device to boot from - Nothing. Same error.
4) I booted the WinXP CD from another PC. It works fine.
5) The only other floppy I have with CD-ROM support is one that plugs in via USB - and my computer right now is apparently not reading anything from USB.

any other suggestions?
0
 
LVL 91

Expert Comment

by:nobus
Comment Utility
I think you will have to check what's ok and what not, so try testing your CD and DVD and floppy on another system. Check the cabling of the floppy, as this can give you that error.
Then, when exactly comes the hal.dll error up? after you see a black screen where you see the devices? does it tell where it wants to boot from?
In 2) and 3) did you have any activity on the CD or DVD? Was  the XP cd in the drive?

I hope this gets you further

nobus
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
This is certainly looking like a hardware issue to me, and since it seems to be system wide, that points to the motherboard.  I would suggest flashing and updating the bios, but since you cannot use the floppy drice, o'well..   Can you pull the hard drive out and slave it to another system, then replace the hal.dll from there?
0
 
LVL 2

Expert Comment

by:Gobi_Lux
Comment Utility
I had that problem to on a computer.
Unfortunately I think this file is specific for every System, so I had to reinstall the whole system!

The only thing you could try, is to connect your HDD to another PC and search for the hal.dll on the disk, if you find it you could copy it back to it proper position.


Gobi
0
 
LVL 2

Expert Comment

by:The_Maverick
Comment Utility
I think you might need to slow down a bit.

First up, I suspect the FDD error you're now getting is probably just a loose cable connector - check the cable at both ends and I bet you'll find one end has been partically pulled out.

Second, I suspect you'll find that the missing file isn't the problem per sec - it's more often a symptom of something more major (like a failing HDD or a corrupted file system) - the file you mention is one of the first loaded - probably just the first of many errors, but you won't see the rest because the system stops at that point. If you can attach the HDD to another PC as a slave drive and give it a full scan you might learn more.

Third, Make sure your CDROM is set as the master device on 2nd IDE channel - make sure you read the screen when you try to boot (you may have to press a key at the right time to boot off the CD) - some CDROMS won't support booting (it's possible you've upgraded the PC with a new motherboard, but kept an older style CDROM?) - if all else fails and you're sure that your CMOS settings are correct then try all combinations of putting the CDROM as master/slave on primary and secondays channels - it's possible you've got a dud CDROM IDE cable or a problem with the port on the motherboard - failing that it might be a good time to visit the repair shop!

Good luck!
0
 
LVL 4

Expert Comment

by:tmireles
Comment Utility
The hall.dll is not related to the problem booting up from the CDROM as this is a windows file and if you are booting to the CDROM then you would not see this happening.

Secondly Maverick is right some CDROMs do not support boot up.  Try putting in another CDROM from another machine and see if this works.  

Also you should be seeing when the computer want to boot from the CDROM to press any key to boot from the CDROM are you pressing a key.  

Lastly I have only seen this on new Gateway and a few dell laptops they want you to hit some special key on the keyboard to change the boot order.  I have seen the esc and the F10 key used.  It then allows you to select the boot priority.  It did not matter what the bios was set to unless you did this.  So when the computer first boots up is there a message that says something like set boot priority press xxx?  If it is going to fast on the boot then you might want to try and use the pause key on the keyboard so that you can read everything in there.  The just press any key to continue.
0
 
LVL 4

Expert Comment

by:ashishdaga
Comment Utility
  REFERENCE NUMBER: CH000490
Missing Windows hal.dll file:


--------------------------------------------------------------------------------

Issue:

Missing Windows hal.dll file.

Additional information:

Additional information about the definition for HAL can be found on our HAL dictionary definition page.

Cause:

The missing or cannot find hal.dll, \windows\system32\hal.dll, or \winnt\system32\hal.dll error message may be experienced on a Microsoft Windows 2000 or Microsoft Windows XP system when the boot.ini becomes corrupted or when a user is attempting to dual boot a computer.

Solution:

Verify that the computer boot.ini is present and not corrupted

Verify the boot.ini file is found on the computer by using a boot diskette or use your Windows CD to get to the MS-DOS "C:\>" prompt.
From this prompt edit the boot.ini, verify that it is pointing to the correct operating system, and that no anomalies are found within the file. Additional information about editing the boot.ini as well as additional information about its available options can be found on document CH000492. Below is a listing of what to verify
If only one operating system is on the computer verify that the boot.ini only has one operating system listed. In some situations an alternate configuration line may be added for the same operating system, leaving the improper line.
Verify that the "default=" line as well as the operating system line are the same and that they are pointing to the correct operating system.
Verify that the computer has the hal.dll file

From the MS-DOS "C:\>" prompt quickly determine if your computer has the "hal.dll" file by typing "dir hal.dll /s" at the prompt. If the computer returns a "File not found" message, the hal.dll has been deleted.

To recover this file boot the Windows operating system CD and choose the option to "restore", "repair", or "recover". This option will prompt you for the Windows installation to use, the administrators password and will allow you to restore the proper file. At the MS-DOS prompt type the following command:

expand x:\i386\hal.dl_ y:\windows\system32\hal.dll

In the above example "x" would be the letter of your CD-ROM drive and "y" the letter of the drive your operating system is installed on. If you need to determine the drive letters of your devices type "map".

Additional information about the expand command can be found on our expand help page.

Reinstall the operating system

If the boot.ini is found on the computer and does not appear to be corrupted and/or if the hal.dll file is missing it is recommended that you reinstall your Windows operating system.

 
http://www.computerhope.com/issues/ch000490.htm
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
He cannot boot from either the cd or the floppy....  That is the problem we are working on now...

BTW:  Carlo..  anything to report on this?

0
 

Accepted Solution

by:
modulo earned 0 total points
Comment Utility
PAQed with no points refunded (of 500)

modulo
Community Support Moderator
0
 

Expert Comment

by:ahsan9211
Comment Utility
If you get an error regarding a missing or corrupt hal.dll file,
it might simply be the BOOT.INI file on the root of the C: drive that is misconfigured

    1. Insert and boot from your WindowsXP CD.
    2. At the first R=Repair option, press the R key
    3. Press the number that corresponds to the correct location for the installation of Windows you want to repair. Typically this will be #1
    4. Type bootcfg /list to show the current entries in the BOOT.INI file
    5. Type bootcfg /rebuild to repair it
    6. Take out the CD ROM and type exit

    hope this will help..

Ahsan
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
#Citrix #POC #XenDesktop #vCenter #VMware #ESX
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now