• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1134
  • Last Modified:

oracle 8i driver for JDBC on sun solaris 8 sparc Platform

Hi guys,
i have a sun ultra 10 sparc platform with solaris 2.8(SUNOS 5.8) and oracle 8i(8.1.7) installed.
we need oracle driver for  JDBC that is compatible with this version.
we've searched the web and couldnt find something useful...also we downloaded some drivers but without any success...
any help will be appreciated.
 
0
ramoo
Asked:
ramoo
  • 4
  • 3
  • 2
  • +1
1 Solution
 
grim_toasterCommented:
You should be able to use the standard classes12.zip, which can be downloaded from the following link for 8.1.7 (although I believe you can use the more recent drivers):
http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc817.html

-->also we downloaded some drivers but without any success
What problems were you having?  Exceptions?
0
 
alikoankCommented:
you can download all kind of oracle-related stuff from Oracle Technology Network

http://otn.oracle.com
0
 
ramumorlaCommented:
Oracle JDBC driver comes with Oracle, the file is classes12.zip for Oracle 8i
   and ojdbc14.jar for Oracle 9i (and JDK 1.4). You can also download the drivers
   from oracle.com (On Oracle's Download page, click on the Oracle JDBC Drivers link
   and select the proper version to download).

   Please note that, for oracle 8.16 or ealier, you must download a updated version
   of classes12.zip; and the ojdbc14.jar driver works only for JDK1.4 or later.
   Here is a possible Exception by using an out-dated clases12.zip dirver:

   java.sql.SQLException: ORA-01009: missing mandatory parameter

   If you use classes12.zip on Oracle 8i databases and Tomcat, you might need rename
   classes12.zip to classes12.jar, since Tomcat may not classload a zip file.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
ramumorlaCommented:
0
 
ramumorlaCommented:
0
 
ramooAuthor Commented:
OK friends the drivers are ok i think maybe i'm doing something wrong.here is what i have in more details.any ideas or clues about what i'm doing wrong?

============
system properties
============
Oracle 8i(8.1.7)
Solaris 8 sparc platform(sun ultra 10)
java VM 1.2
-----------------------------
I have this zip file "classes12.zip" which is the collection of classes as Oracle Drivers.
I puted it at location /usr/orcldrv
Then using csh shell and defining Environment by setenv command as :
waveiew# setenv CLASSPATH /usr/orcldrv/classes12.zip
This is the related code of establishing the connection with oracle DB  :
---------------------------------------------------------------------------------

      // This is the fragment code of declaration of necessary variables

      String driverName="oracle.jdbc.driver.OracleDriver";
      String ServerName="127.0.0.1";
      String portNumber="1521";
      String sID="OMCDB";
      String url = "jdbc::oracle:thin:@"+ServerName+":"+portNumber+":"+sID;

      Connection con;
      Statement stmt, ratesStmt;


      // Now connecting to Oracle Driver

            try {
                  //Class.forName("com.microsoft.jdbc.sqlserver.SQLServerDriver");
                  Class.forName(driverName);
            } catch(java.lang.ClassNotFoundException e) {
                  System.err.print("ClassNotFoundException: ");
                  System.err.println(e.getMessage());
            }
            try{
                  con = DriverManager.getConnection(url,"pola", "pola");
            }catch(SQLException ex) {
                  System.out.println("Godar");
                  ex.printStackTrace();}
---------------------------------------------------------------------------------


And this is the exception thrown when running the program :

-----------------------------
ClassNotFoundException : oracle.jdbc.driver.OracleDriver
java.sql.SQLException : No suitable driver
      at java.lang.Throwable.fillInStackTrace(Native Method)
      at java.lang.Throwable.fillInStackTrace(Compiled code)
      at java.lang.Throwable.<init>(Compiled Code)
      at java.lang.Exception.<init>(SQLException.java:64)
      at java.sql.DriverManager.getConnection(Compiled Code)
      at java.sql.DriverManager.getConnection(DriverManager.java:137)
      ...(my code positions makes excepion )
-----------------------------

I then used javac,javah,jdb for the same purpose, and the same exception was thrown.
After it I converted the .zip file to .jar file, and the same problem.

0
 
grim_toasterCommented:
How are you running the program?  You should specify:

java -cp /usr/orcldrv/classes12.zip ClassName
0
 
ramooAuthor Commented:
Friends,
I'm getting the same error after doing last note,
error:
exception in thread "main" java.lang.NoclassDefFoundError:oracleSql.class.

the class name that i specified is oracleSql.class.
looks that it doesnt recognizes the folder classes12.zip or classes12.jar or cannot read those folders.


0
 
grim_toasterCommented:
The class is incorrectly referenced, it should be "OracleSql" not "oracleSql".
0
 
grim_toasterCommented:
The original question was answered in the first post (by me), I have no idea how to provide you the link to it though!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now