?
Solved

My Linux Box is Not Up Since DHCP was Disabled

Posted on 2004-08-05
11
Medium Priority
?
229 Views
Last Modified: 2010-04-20
hello
I got all my windows computers working fine with DHCP disabled
but now my linux box is not up anymore when I scan all the
computers in the LAN I only see the windows and my mac
I got the help from here, to setup windows tcp/ip configuration
http://www.experts-exchange.com/Networking/Q_21080938.html
but I dont know how to do it on Fedora with Ensim pro 4
thanks.
0
Comment
Question by:Xtry
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
11 Comments
 
LVL 20

Expert Comment

by:Gns
ID: 11726225
Are we to take it that you've initially set your linux box to use DHCP too, and that you now want to reconfig to static IPs? If so, you should run
redhat-config-network
as root to change it (redhat-config-network-tui if on the textmode console).

Or what was your question?

Can you ping the linux machine from the windows machines?

-- Glenn
0
 

Author Comment

by:Xtry
ID: 11726274
when I ping the linux machine I dont get any Response!
0
 
LVL 20

Expert Comment

by:Gns
ID: 11726342
Ah, so either network isn't "up", there is a major error in the network config (for it or on the router) or there is something more HW-ish the matter (bad/marginal cabling or somesuch)...
If you log in to the linux machine, open a terminal (assuming you use GUI logins) and do
su
... to become root and do
ifconfig
... Is the eth0 interface there at all? Configured? Does the configuration look... OK?

-- Glenn
0
WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

 

Author Comment

by:Xtry
ID: 11734704
I need to set the IP in eth0, can you tell me how to do it
0
 
LVL 20

Expert Comment

by:Gns
ID: 11735209
Did you try running "redhat-config-network" as noted above?
It should be fairly easy to configure there... If you have the "eth0" interface to choose, do so, then press Edit, choose to set it statically ... and fill in the blanks:-).

If you like, you can edit the config file(s) directly... But using the tool (either the -tui or GUI version) is very simple.

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 11735255
On a "redhatish" system the files are /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-eth0

In the first you need set the IP address of the gateway and hostname... Something like
HOSTNAME=apmx03.ap1.se
NETWORKING=yes
GATEWAY=192.168.1.1

In the latter you have the actual interface settings, somewhat like:
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.104
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
MII_NOT_SUPPORTED=no

Make sure the IP address is unique.

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 11735272
Oh, and after editing the files to suit you, do
ifdown eth0
ifup eth0
loggen on as root (which you'll need be anyway, to be able to edit the files:-).

Not difficult, but using the tool might be construed as being simpler still;-).

-- Glenn
0
 

Author Comment

by:Xtry
ID: 11735593
well I did everything you told me now I cant login since I did "ifdown eth0"
0
 

Expert Comment

by:KraLord
ID: 11740321
hello there xtry,

you need to set an ip to the box try doing this
ifconfig eth0 inet 192.168.1.102 netmask 255.255.255.0 broadcast 192.168.1.255 up
then shutdown -r now
0
 
LVL 20

Accepted Solution

by:
Gns earned 2000 total points
ID: 11748522
If you we're logging in remotely, true... Otherwise... no;-).

I'm sorry I didn't say "only do this locally"... Thought it was obvious:-).

If it is your GUI login screen acting up w/o network up, just <Ctrl>-<Alt>-<F1> and log in to a textmode console... and continue with the "ifup eth0"...

What KraLord say is generally true, fo r settingit once, BUT that will not survive a reboot.... and it doesn't really fit with the "redhatish" tools.... Those scripts will (eventually) run exactly that type of ifconfig command.... and will manage automatic start/stop etc through the initscript(s) (which basically do ifup/ifdown).

Just hang in there:-)

-- Glenn
0
 
LVL 20

Expert Comment

by:Gns
ID: 11748544
Oh, missed the shutdown -r now KraLord.... With nothing but what you've said, that will effectively "erase" the ifcinfig... making your advice kind of.... wrong:)

-- Glenn
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month10 days, 21 hours left to enroll

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question