Solved

Allow access to inetpub on my PC

Posted on 2004-08-05
16
644 Views
Last Modified: 2010-05-18
Hello Experts,
I have set my WIN2000Pro machine up with IIS and started developing an ASP web site with Dreamweaver for our Intranet.
I need to let another developer work on this site also.  When she tries to set it up in Dreamweaver, it is unable to find the site.
So far I have done the following:
-Shared the inetpub folder on my machine and granted her full access.
-Mapped the drive on her computer.
-I have set the IIS server up for Authenicated Access
I have also went out to my browser and typed in http://mycomputername/login.asp to try and
access the site, and it prompts me for a username and password.
I am fairly new to setting up IIS so I think that is where the problem is.
Thanks for any help
Chad
0
Comment
Question by:ChadMarsh
  • 7
  • 4
  • 3
  • +1
16 Comments
 

Expert Comment

by:billy_boy
ID: 11726483
what do you get when you type http://localhost/ in your browser?
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11726520
I get a file directory that contains all the files in my wwwroot folder
0
 
LVL 3

Expert Comment

by:thecode101
ID: 11726945
Did you setup Dreamweaver to connect to remote host via FTP or via Local/Network?
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11726963
We were using Local/Network
0
 
LVL 3

Expert Comment

by:thecode101
ID: 11727042
When she opens up the inetpub folder on her computer is she able to see the files?
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11727094
Yes she can see them.  She can even edit and save them within dreamweaver.  She just can't preview.  When she goes to preview it asks her for a username and password.  When she types in her network u and p the page denys her.
0
 
LVL 3

Expert Comment

by:thecode101
ID: 11727166
So, without using Dreamweavers preview, if she goes to the address of the server in a browser does it also ask for a user name and password?
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11727253
Yes. I can preview it OK with Dreamweaver, but if I try to directly access it from my browser, I also get propted for username and password
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 3

Expert Comment

by:thecode101
ID: 11727525
Try changing IIS authentication to anonymous access and see if that works.
0
 

Expert Comment

by:billy_boy
ID: 11727646
just tick the checkbox 'Integrated Windows Authentication' under default website> properties>Directory Security>edit>Authenticated access....should do the job!
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11728408
I tried changing to anonymous and is doesn't prompt for a password, but still displays a page error.  This is not an option for me since I am capturing the USER_LOGON server variable.

I have Intgrated Windows Authentication check also.
0
 
LVL 7

Expert Comment

by:suramsureshbabu
ID: 11728664
hi

can you just try to do the following

1) open IIS manager
2) expand your server name
3) go to websites and expand
4) it generally contains default web site
5) right click goto properties
6) goto home directory tab - here we have to point it to the folder where we are placing the files and this directory should contain  the initial file that has to show up
7) go to documents tab - check if default.asp is present in the list if not add it. we can use any page as the opening page we have to just specfy here
8) check if the website is stopped if so start it by right clicking or by clicking the button at the top
9) check the TCP port the default is 80
10) now try accessing it from the same system by giving http://127.0.0.1 or http://localhost

it might work.

try it out and reply back if it gives any errors

suresh :)
0
 
LVL 7

Expert Comment

by:suramsureshbabu
ID: 11728706
in the home directory tab

select the "read" and "write" check boxes and unselect the "directory browsing" so that when you open the webpage teh list of files is not displayed

suresh :)
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11729029
I did you steps.  I can access it if I use http://localhost/login.asp which is my start page.  If I try just local host I get a
an error that says
Directory Listing Denied
This Virtual Directory does not allow contents to be listed.
Also the other developer still is unable to access the site.
0
 
LVL 7

Accepted Solution

by:
suramsureshbabu earned 250 total points
ID: 11729120
goto home directory tab - here we have to give the "localpath" point it to the folder where we are placing the files and this directory should contain  the initial file that has to show up ie "login.asp"

go to documents tab - tick the enable default contents page if it is not there

Add "login.asp" to the list if not add it.

we can use any page as the opening page we have to just specfy here

for the other developer to access the site he has to type in the ipaddress of your system

suresh :)
0
 
LVL 2

Author Comment

by:ChadMarsh
ID: 11729674
Thanks  I think we got it.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Popularity Can Be Measured Sometimes we deal with questions of popularity, and we need a way to collect opinions from our clients.  This article shows a simple teaching example of how we might elect a favorite color by letting our clients vote for …
Although it can be difficult to imagine, someday your child will have a career of his or her own. He or she will likely start a family, buy a home and start having their own children. So, while being a kid is still extremely important, it’s also …
The viewer will learn how to dynamically set the form action using jQuery.
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now