Solved

Cisco Input and CRC errors - how much is too much?

Posted on 2004-08-05
21
3,956 Views
Last Modified: 2009-01-21
I have a Cisco 3600 in New York - connected to 2 remote sites - one in New Jersey over 2 multilinked point to point T1's to a 2600 and one in Florida to a 2600 over a single point to point T1 - I have not noticed any real performance issues or packet loss when doing various ping tests - but I cleared my counters about 3 hours ago - on the NJ 2600 I see about 400 input errors and 164 CRC errors on 1 of my T1 interfaces - in florida I see 54 input and 20 CRC errors - from the corresponding interfaces on the 3600 in NYC I see 87 input and 23 CRC going to NJ and for Florida I see 18 input and 7 CRC errors - this is all over about 3 hours or so - the NJ site moves much more data than the Florida site.

My question is...should I see any errors at all?  And, if a certain amount of errors is normal - how can I figure out what the normal level of errors should be, based on amount of data I am moving?
0
Comment
Question by:mrsmileyns
  • 11
  • 10
21 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11727871
You shouldn't be getting errors like that, check your cabling at the New York site and contact your provider to see if the line looks good from their perspective.
0
 

Author Comment

by:mrsmileyns
ID: 11728086
do you think all the levels of errors I have described mean there is a definite problem?  or just the NY to NJ circuits?  all 3 of these T1's - the two in NJ and the one for Fl are all different ISP's

where i see the errors in my NJ router is on a specific T1 interface, not on the multilink interface - any ideas on that?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11728529
You shouldn't be getting any CRC errors, especially not 164 in 3 hours.  Post a "show controllers t1"
0
 

Author Comment

by:mrsmileyns
ID: 11728704
this is from my NJ 2600 - it is the one that I see the most errors in - it is multilinked with 2 T1's back to the NYC 3600


#sho controllers t1
T1 0/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20011015, FPGA: 11
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  Data in current interval (590 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
T1 0/1 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20011015, FPGA: 11
  Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
  Data in current interval (591 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
0
 

Author Comment

by:mrsmileyns
ID: 11728743
this is from my NYC 3600

#sho controllers t1
T1 4/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  Description: T1-1 to Red Bank
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010805, FPGA: 15
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
   Current port master clock: recovered from controller 4/2
  Data in current interval (645 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     192 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     192 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     6441 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     6441 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
T1 4/2 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  Description: T1-2 to Red Bank
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010805, FPGA: 15
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
   Current port master clock: recovered from controller 4/2
  Data in current interval (647 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
T1 4/3 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  Description: T1 to Boca
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20010805, FPGA: 15
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
   Current port master clock: recovered from controller 4/2
  Data in current interval (648 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     67 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     67 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     2259 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     2259 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 250 total points
ID: 11729114
The "slip secs" on the NYC T1 controllers indicate a clocking problem.  Make sure you have your clocking configured correctly.  Is this a new installation?  Have you been getting these errors since they were installed?
0
 

Author Comment

by:mrsmileyns
ID: 11729139
It is not a new install - has been running several months - like I said - performance seems OK - I hadn't really checked this in this much detail until today - and what I saw suggested a problem that may get progressively worse and I would like to head it off - I am fairly savy...but not sure what you mean by a clocking problem - if you can tell me, what do you mean, and how do I "make it right?"
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11729335
Can you post your configuration minus passwords along with "show interface serialx".
0
 

Author Comment

by:mrsmileyns
ID: 11729394
sure - i will do that - before i do here are my questions as I found some info in the interim - tell me if i am right or wrong - for a point to point t1 a clock needs to be set at each end in some way, correct?  is this done at the controller level or the interface level?  also, if i have 2 multilinked do i set the clock on both interfaces or simply the multilink? here is my config:

version 12.2
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SKYNYC3600
!

!
ip subnet-zero
!
!
!
!
controller T1 4/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description T1-1 to Red Bank
!
controller T1 4/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
!
controller T1 4/2
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description T1-2 to Red Bank
!
controller T1 4/3
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24 speed 64
 description T1 to Boca
!
!
!
interface Multilink1
 ip address 192.168.254.13 255.255.255.252
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface FastEthernet0/0
 description Sky NYC LAN
 ip address 192.168.1.211 255.255.255.0
 speed 100
 full-duplex
 no cdp enable
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 no cdp enable
!
interface Serial4/0:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1
!
interface Serial4/1:0
 no ip address
 encapsulation ppp
!
interface Serial4/2:0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1
!
interface Serial4/3:0
 ip address 192.168.253.5 255.255.255.252
 encapsulation ppp
 no fair-queue
!
router eigrp 100
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.10.0
 network 192.168.20.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.249
ip route 192.168.2.0 255.255.255.0 192.168.1.249
ip route 192.168.3.0 255.255.255.0 192.168.1.249
ip route 192.168.4.0 255.255.255.0 192.168.1.249
ip route 192.168.5.0 255.255.255.0 192.168.1.249
ip route 192.168.6.0 255.255.255.0 192.168.1.249
ip route 192.168.7.0 255.255.255.0 192.168.1.249
ip route 192.168.8.0 255.255.255.0 192.168.1.249
ip route 192.168.9.0 255.255.255.0 192.168.1.249
ip route 192.168.10.0 255.255.255.0 192.168.254.2
ip route 192.168.10.0 255.255.255.0 192.168.254.6
ip route 192.168.10.0 255.255.255.0 192.168.254.10
ip route 192.168.20.0 255.255.255.0 192.168.253.6
ip http server
no ip pim bidir-enable
!
logging trap debugging
logging 192.168.1.214
snmp-server community windy1 RW
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
ogin
!
end

SKYNYC3600#
0
 

Author Comment

by:mrsmileyns
ID: 11729504
I just noticed - on my NJ 2600 - the interface that is not getting any errors - has clock source internal specified in the controller config - while the other T1 on the multilink - in its controller config - does not have that specified - does the clocking need to be set at both ends?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 43

Expert Comment

by:JFrederick29
ID: 11729743
The clock source is set on the controller, not the interface.  These are point-to-point leased lines right?  If so, set one end to "clock source internal" and the other to "clock source line".

So, try on the NJ router:

controller t1 0/0
clock source internal
0
 

Author Comment

by:mrsmileyns
ID: 11729768
yes - point to point leased - does it need to be set at both ends on both routers?  so both T1 controllers in NJ should say clock source internal

and both controllers that go to NJ from NYC should say clock source line?

after we do this i have a question about my florida router as it is a little different...but lets do this first  :)  thanks
0
 

Author Comment

by:mrsmileyns
ID: 11729779
also - does specifying the clock like this affect service?  will it temporarily take the T1 down?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11729797
Yes, both ends of the line, every controller on the routers.  Yes, both controllers in NJ should say clock source internal and both controllers in NYC should say clock source line.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11729833
You will probably want to experiment after hours as with any change made to the router, problems could arise.  I would wait until after hours to test this.  Also, can you manage the NJ router out of band (modem to AUX) port in case you lose connectivity?  Not saying you will but just to save you a trip to NJ :)  

Once you change the clock source, clear the counters and see if they start incrementing again.
0
 

Author Comment

by:mrsmileyns
ID: 11729847
ok - last thing for now - this is the config for my florida router - as you can see it is a little different as far as the controller is concerned - but it also does not appear to have clock source specified - do i need to, and how do i do that under this config:

Current configuration : 1259 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SKYBR2600
!.
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 description Sky Boca LAN
 ip address 192.168.20.1 255.255.255.0
 speed 100
 full-duplex
!
interface Serial0/0
 description Connected to Cisco 3660
 ip address 192.168.253.6 255.255.255.252
 encapsulation ppp
 service-module t1 remote-alarm-enable
!
interface FastEthernet0/1
 ip address 192.168.4.254 255.255.255.0
 duplex auto
 speed auto
!
interface Async2
 no ip address
!
router eigrp 100
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.10.0
 network 192.168.20.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.253.5
ip route 0.0.0.0 0.0.0.0 192.168.20.5 100
ip http server
no ip pim bidir-enable
!
!
logging trap debugging
logging 192.168.1.214
snmp-server community public RO
snmp-server community windy1 RO
!
line con 0
 exec-timeout 0 0
 
 modem InOut
 transport input all
 transport output pad v120 telnet rlogin udptn
 autoselect arap
 stopbits 1
 speed 115200
line aux 0
line vty 0 4
 password
 login
!
!
end
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11729952
Use the command:

service-module t1 clock source internal

To set it back to line:

service-module t1 clock source line
0
 

Author Comment

by:mrsmileyns
ID: 11729978
i see - so same deal for the florida router - internal at the remote location and line on the 3600 in NY for that specific controller, correct?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11730261
Yeah give that a try and see if it clears up the errors.
0
 

Author Comment

by:mrsmileyns
ID: 11730886
that did it - its all fixed - just spent time pinging all over the place with huge packets - cannot even force any errors and the minimal packet loss i had is gone too - thank you for all the help - this is great - last question - when i set the clock source to internal from the remote locations it shows up in the config - but when i set the source to line from the core 3600 it does not show in the config - but is shows in the show controllers info as line - i guess it just doesn't show in the config? is that normal?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11744433
"Clock source internal" shows in the confguration because it is not the default configuration.  "Clock source line" doesn't show in the config because it is the default.  Glad to hear its working!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Cisco layer 3 ring topology 1 52
Network Config 9 55
Sonicwall routing between VPNs 5 26
EIGRP Full Mesh 2 33
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now