[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13007
  • Last Modified:

MACSRV 12061 - Session from user was timed out and disconnected by the server

This is really a Macintosh / Windows Server 2003 problem.

Basically, some Mac clients randomly get timed out from my Win 2003 server. I am running Active Directory on the Windows machine and Appletalk for pre osx clients.
I get a handful of these timmed out connections most every day.
I have heard from other groups that this problem has existed since NT.
If anyone has any suggestions on this I’d appreciate hearing them.

Thanks,

Chris

Event Type:      Error
Event Source:      MACSRV
Event Category:      None
Event ID:      12061
Date:            7/28/2004
Time:            2:25:04 AM
User:            N/A
Computer:      SVCS01
Description:
Session from user "Dispatch" was timed out and disconnected by the server. The IP address of the Macintosh workstation is in the data.

0
dnadeveloper
Asked:
dnadeveloper
  • 5
  • 2
  • 2
  • +4
1 Solution
 
weedCommented:
Is the problem only on OS 9 machines or both OS 9 and OS X?
0
 
dnadeveloperAuthor Commented:
It seems to only happen on OS 9 machines. They connect with AppleTalk and use the Microsoft UAM's.
0
 
weedCommented:
Is there any possibility of getting them to OS X?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
dnadeveloperAuthor Commented:
We would like to do that but the money just isn’t in the budget right now to get all the software upgrades we would need.  From what I’ve been told, Quark is in the process of coming up with a Unicode release of Quark express and we would probably wait for that release before making any major changes.
(As an FYI, generally speaking, I don’t work on Macs so I may be wrong on the Quark issues.)
Even with OSX though, I didn’t get good results without Admit Mac.
0
 
Master_ControlCommented:
This error message comes up under my Windows 2000 Environment with AD and our workstations are running OS X 10.3 Panther.

To upgrade to OS X 10.3 (Panther), this is what I recommend you going to. The issue with Quark 4.11 is Fonts, You can switch to 6.0, but then you run into the compatibility issues with outside vendors/clients/whoever.

So assuming you are staying with 4.11.

- Install OS 9, and then upgrade to OS X 10.3, you will need to run Quark 4.11 in classic mode.
- Use FontBook in Panther to manage the fonts.  Install each font for Classic mode first, then for yourself
- Install Adobe Type Manager in Classic mode.  Perform a custom install.  Load all items except the fonts.  This applies to the 4.6 update.  After installation, go to general preferences and enable screen smoothing of fonts.

I hope this helps you out.
0
 
Estter1oCommented:
Solutions I tried about 1,5 years ago:

Change the time-out settings:
run
net config server /autodisconnect:-1


(Because Macintosh Clients can go into sleepmode whilst a network share is open on the
Macintosh desktop, it might be better to disable autodisconnect.)

If possible, prevent your Mac's from going into sleepmode altogether. It won't completely cure the problem but it can significantly reduce it.

-----------------------

Searching the topic of Macs dropping off while trying to copy large files from the server to their desktop, Google found me this:

Check out the ethernet update for OS 9.2x. This is a known issue and the patch can be found at Apple's site. This problem arises with W2k, Novell, and Linux/Netatalk servers.
The Apple Ethernet Update 2.0 consists of version 2.4.3 of the Apple Ethernet extension. This improves AppleShare connections in high-traffic network environments. When you use certain Mac OS 9 applications while connected to AppleShare volumes, disconnections can occur. The Apple Ethernet Extension 2.4.3 prevents these disconnections from occurring.

http://docs.info.apple.com/article.html?artnum=120066

--------------------------------------

Make sure your server's ethernet is not set to auto negotiate speeds.

--------------------------------------

Try a static IP address on your Mac computer instead of using DHCP. See if you notice a differnet behaviour.

-------------------------------------

This is probably old news but perhaps.......
0
 
dnadeveloperAuthor Commented:
Not old news. I will try these ideas and get back to the group after they have had time to prove out one way or another.

Thanks
0
 
kcostasCommented:
I've been experiencing this same problem for quite some time now. I've found dozens of others posting regarding the same issue. I did not seem to have this issue when my server was running 2000 but has occured ever since the migration to 2003. All of my clients are running 10.3, I've set the autodisconnect to -1, I've changed the physical networking parameters and still no success. I'm running out of ideas to fix this problem. I am going to try a workaround though and install AdmitMac (http://www.admitmac.com/) to see if it will bypass the disconnect (or actually just make it transparent when it happens.)
0
 
andyowwCommented:
It's a registry hack needing to be done on each Windows server the macs connect to.


Change LAN Auto-disconnect Timeout (Windows NT/2000/XP):

Windows can be configured to automatically disconnect idle LAN sessions.  These are a set number of minutes.

Open your registry and find the key below.  Modify the value, or create a new string value, called 'Autodisconnect' and set it to equal the time in minutes before a session is disconnected.

Restart Windows for the change to take effect.

(Note: Set the value to 0xffffffff to disable the disconnection function.)

  (Default) REG_SZ (value not set)  
  Autodisconnect REG_DWORD 0xffffffff (4294967295)  
 
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer
 
Registry Settings:
System Key: [HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Value Name: Autodisconnect
Data Type: REG_DWORD (DWORD Value)
Value Data: 0 to 4,294,967,295 (0xffffffff) in minutes
 
Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.
0
 
dnadeveloperAuthor Commented:
This didn't do it for me.
You can hit this key through the GUI with Administrative tools, Domain (Controller) Security Policy.
I set it for both the domain and the domain controller and I'm still getting users who time out.
Sure looked like it though...
0
 
kcostasCommented:
Yup....I had tried that one a while ago as well. No luck. To date there are only two known workarounds....

1) Purchase Thursby Software's ADmitMac (www.thursby.com) and use the CIFS protocol to communicate to the server (this does work 100%) or
2) Purchase ExtremeZIP and put real AFP services on your Windows server.

The first solution is relatively reasonable. Thursby charges approx. $100 per client. The ExtremeZIP starts at about 5K...ouch.

Hope this helps.
0
 
gritzalisCommented:
I have the same problem

My Mac's are are mixer of OS9 and OSX. I tried disabling power management on the NIC's but problem still occurs

Any help would be appreciated ....
0
 
dnadeveloperAuthor Commented:
I don't know about programming for the macs but has anyone tried to write an apple script or something that would ping the server every minute or so? Maybe that would keep the connection alive.
Maybe I'll look into apple scripting.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 5
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now