User folder permissions

Hopefully there is something I can do here to fix this. Currently I have about 500 students - users - in Active Directory, and each one of them has their own network directoryon the Windows 2000 server. The directory is mapped through their profile to the F: drive. Well, when the accounts were created, it also created their home directory, but the security settings were set to give access to "everyone" and not to just the student "user" who the directory belongs to. I need to find out if there is a way I can globally set the permissions on these student's folders so that only the student the folder is assigned to will have access to it. Along with the system administrator, of course. We have a problem during the school year of students going into other student's folders and deleting papers, coping papers, etc. when the permissions aren't set, and I need to get this fixed.
Thanks in advance for the help!
Eric Portenier
eporteniAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jdeclueConnect With a Mentor Commented:
When you look at the permissions, is the users account there as well? if it is then try removing Everyone, add Domain Admins at the root and propogate the changes, if the user is not there... then you can either manually change the rights to each folder, or use a scipt... ther are other alternatives... including some that would be quicker but it would take too much too explain...

Maybe some one else has a quicker solution.

J
0
 
BigC666Commented:
howdy,
sorry, don't think that's there any to push what you want to do, just have to right click the individual folders, select properties, security add the user to the list and then deny the everybody account.

hope that this helps
0
 
magus123Commented:
jdeclue has the right idea , remove the everyone group from the top folder or
where the  home directory starts from and remove the everyone group
from thier , then enable the inherit tab to propogate the changes.
make sure the administrator or etc is in the folder permissions before
removing everyone group. also if a authenticated group exist too
you have to remove that one too.

after that test it and see if it works by loggin on to a temp account
create for the purpose if you can roam around into other peoples
home directory. i would also while i am their consider checking
other valnurbilities. and if  those computers have internet.
check for adware/malware  \too.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Rob StoneCommented:
Don't deny access to the everyone group!! That will block off everyones access. Just remove the everyone group.
0
 
RanidaeConnect With a Mentor Commented:
I've used xcacls and a VBScript or Batch File to modify the permissions on all my student home directories.  
as part of a vbscript,  the following sets permissions on userdirectories to:

Administrators - Full Control
student - modify
teachers - modify

Use this inside an array that calls up every users home directory and presto!

Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Run "xcacls.exe " & homedirpath & UserName & " " & "/G" & " " & UserName & ":C" & " " & "Administrators:F" & " " & "Teachers:C" & " " & "/Y"

xcacls is included in the windows 2000 resource kit.  You may find it easier to do via a batch file.
0
 
jdeclueCommented:
I gave the answer and Ranidae offered a better way of doing it.... split

J
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.