Solved

I cannot access shared files and folders or browse computers in my workgroup

Posted on 2004-08-05
12
7,578 Views
Last Modified: 2008-01-09
I need help! This ones driving me nuts, I just set up a netgear wireless router...my pc is connected by ethernet and i have 2 other laptops connected wirelessly. one laptop and the pc (both with xp proffessional) can see each other on the workgroup i created but the other laptop (on xp home) can't access or see the workgroup at all...i get a 'don't have permission to access this workgroup' message. why!??!?
0
Comment
Question by:sanjay1983
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 25

Expert Comment

by:Ron Malmstead
ID: 11730709
Make sure your built-in "windows xp firewall service" is disabled on the wireless interface.. or any other firewall software you may have installed ...e.g. mcafee firewall.
0
 
LVL 1

Accepted Solution

by:
tejas1 earned 250 total points
ID: 11730790
This a Common problem with this type of mixed O/S xp prof and home. the reason is Xp home edition does not have facility to log u on the any doman  ie. Ther is not option to join domain It can only participate in an workgroup enviornment. Configure your Xp home edition with necessary protocols TCP/IP and netbuie because u need name resolution to your ip adress with XP prof.Futher more Add the XP home computer name in permission settings not security settings and assign the necessary rights.

Y can check wethe u can acess the hidden share like C$ and admin$ shares that are shared for administrative purposed.
0
 
LVL 9

Expert Comment

by:drev001
ID: 11730799
Enable the guest account on the pc(s) with the shares you're trying to access
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 1

Expert Comment

by:doneck8
ID: 11730800
You may also want to make sure that Netbios is enabled in the Wins tab of the Advanced setting of TCP/IP.
0
 

Author Comment

by:sanjay1983
ID: 11731121
sorry tejas but im a real newbie to all this, you're gonna have to explain what it is you suggest i do...?
0
 

Expert Comment

by:javaretard999
ID: 11731245
Tejas1 is right.  Mixing OS prof and home will give you this problem.
0
 
LVL 1

Expert Comment

by:bprimm
ID: 11732128
Does the XPH machine have access to the internet?
If so be sure that guest accounts are enabled by typing lusrmgr.msc in the run box, select users and be sure guest is enabled.
0
 
LVL 5

Assisted Solution

by:makana
makana earned 250 total points
ID: 11733192
Thanks to lrmoore for his excellent Solution.
--------------------------------------------------
Have you enabled netbios on XP?

 check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP (Pro only) machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines

http://www.wown.com/j_helmig/wxpwin9x.htm
----------------
All machines are in the same workgroup
----------------

Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.

Step 2: Start the Computer Browser Service
Click Start, right-click My Computer, and then click Manage.
In the console tree, expand Services and Applications.
Click Services.
In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
Close the Computer Management window.

References:
http://support.microsoft.com/default.aspx?scid=kb;en-us;318030
http://support.microsoft.com/default.aspx?scid=kb;en-us;314366
http://support.microsoft.com/default.aspx?scid=kb;en-us;315267
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
http://www.michna.com/kb/WxNetwork.htm


Install NETBEUI only if you have no other choice:
http://support.microsoft.com/?kbid=301041

Makana
0
 
LVL 1

Expert Comment

by:tejas1
ID: 11741392
Enabling netbios/net buie /ipxspx can get u going not forgetting enabling sharing
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question