Solved

Routing between VLANS and Static IP interfaces

Posted on 2004-08-05
7
1,423 Views
Last Modified: 2012-08-13
I have a CCNA, but have never touched a Cisco 3750 switch with Layer three routing before:

Here's what I want to do:

I have four VLANS and one physical IP port configured as per the attached config.
Vlan1 192.168.8.1 255.255.255.0
Vlan2 172.26.6.1 255.255.254.0
Vlan3 172.27.6.1 255.255.254.0
Vlan4 172.30.6.1 255.255.254.0
Physical IP 10.1.1.30
 
I need to route between all networks, and access a WAN link via an external router at 10.1.1.29.

I have RIP version 2 routing enabled.

The physical IP connects to an external WAN router at address 10.1.1.29/30.

Can I use the 3750 to do RIP routing between the four VLANs as well as the physical interface and the external router? I can only seem to get the Vlans to talk to each other....

Here's my router config:

!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DIST-MTL-SW
!
enable secret 5 xxxx
enable password xxxx
!
ip subnet-zero
ip routing
!
no ip domain-lookup
cluster enable MONTREAL 0
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
interface FastEthernet1/0/1
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/2
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/3
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/4
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/5
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/6
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/7
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/8
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/9
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/10
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/11
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/12
 switchport access vlan 4
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/13
 switchport access vlan 2
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/14
 switchport access vlan 2
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/15
 switchport access vlan 2
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/16
 switchport access vlan 2
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/17
 switchport access vlan 2
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/18
 switchport access vlan 3
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/19
 switchport access vlan 3
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/20
 switchport access vlan 3
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/21
 switchport access vlan 3
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/22
 switchport access vlan 3
 switchport mode access
 no ip address
 mdix auto
!
interface FastEthernet1/0/23
 switchport mode access
 no ip address
 mdix auto
 spanning-tree portfast trunk
!
interface FastEthernet1/0/24
 description Allstream WAN
 no switchport
 ip address 10.1.1.30 255.255.255.252
 mdix auto
!
interface GigabitEthernet1/0/1
 no ip address
!
interface GigabitEthernet1/0/2
 no ip address
!
interface Vlan1
 ip address 192.168.8.1 255.255.255.0
!
interface Vlan2
 ip address 172.26.6.1 255.255.254.0
!
interface Vlan3
 ip address 172.27.6.1 255.255.254.0
!
interface Vlan4
 ip address 172.30.6.1 255.255.254.0
!
router rip
 version 2
 network 10.0.0.0
 network 172.26.0.0
 network 172.27.0.0
 network 172.30.0.0
 network 192.168.8.0
 no auto-summary
!
ip default-gateway 10.1.1.29
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.29
ip http server
!
ip access-list extended CMP-NAT-ACL
 dynamic Cluster-HSRP deny   ip any any
 dynamic Cluster-NAT permit ip any any
!
snmp-server community public RO
snmp-server community public@es0 RO
!
line con 0
line vty 0 4
 password xxxxx
 login
line vty 5 15
 password xxxx
 login
!
end
0
Comment
Question by:thetekguy
7 Comments
 
LVL 11

Assisted Solution

by:PennGwyn
PennGwyn earned 50 total points
ID: 11731998
> Can I use the 3750 to do RIP routing between the four VLANs as well as the physical interface and the external router?

The thing I hate about the term "routing protocol" is that the protocol doesn't route!  It's used to share routing information with other routers.  So unless there are other routers on those VLANs that you're not telling us about, RIP has nothing to do with routing between them.  

As long as clients are configured to use the routers address on their VLAN as their gateway, the router will happily excahnge packets with the other VLANs -- which it knows about because it has interfaces on those VLANs, too.

> I can only seem to get the Vlans to talk to each other....

So I think what you want is to use RIP to tell the router at 10.1.1.29/30 about the VLANs, so that it will know that this router can deliver packets to them.  DO YOU KNOW THAT THAT ROUTER IS CONFIGURED TO LISTEN TO RIP V2 TRAFFIC?

In your RIP configuration, you haven't supplied subnet masks, and so the default masks (by class A/B/C) will be assumed.  This probably won't actually break, but may lead to sub-optimal performance....


0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
ID: 11732172
Yes.

Your config looks okay.

You don't need the "ip default-gateway" since you have ip routing enabled.

Is the router connected to f1/0/24 running RIP version 2? If not, then issue a "no version 2" at the RIP routing protocol.

Make sure all the PC's have the correct default gateway.

VLAN1 PC's will use 192.168.8.1 as their default gateway.
VLAN2 PC's will use 172.26.6.1 as their default gateway.
VLAN3 PC's will use 172.27.6.1 as their default gateway.
VLAN4 PC's will use 172.30.6.1 as their default gateway.

What doesn't work?

What do you mean when you say "I can only seem to get the Vlans to talk to each other...."?

-Don
0
 
LVL 28

Assisted Solution

by:mikebernhardt
mikebernhardt earned 200 total points
ID: 11738224
There are 2 versions of software for the 3750. One does basic routing between the VLANs and you can apply a static route out, which you also have. The other actually lets you run a routing protocol.

Since you have a static route, the problem may be how it communicates with the other router. You can try debug ip rip to see what's going on. If it's not sending rip updates (or the other side isn't listening for whatever reason) then the other side won't be able to get back to you.

Does the other end have rip v2 configured for 10.0.0.0?
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:thetekguy
ID: 11739149
Everything works now!

The 2750T is enterprise software, so thanks for confirming it can advertise routes between physical interfaces to external routers, and internal VLANS.

I removed the static routes, as well as the default gateway, as RIPV2 takes care of this.

I also did not realise that you can't ping a vlan default gateway if there is no PC connected to that particular VLAN. I had no PCs connected, and was using the switch via console to ping the vlan interfaces- with no success, so I thought routing was not working. When I did a show ip interface command, each VLAN showed "VLAN x is up, line protocol is down". Once I connected a PC to a switch port belonging to that vlan, the pings started working.

I think I'm used to the ability to ping an interface or subinterface, and did not realise it worked differently for VLANS.

RIPV2 is configured on both the external router and the internal router, and appears to be operating correctly.

One question:
when I configure RIP by typing

ip classless
router RIP
version 2
network www.xxx.yyy.zzz, it does not seem to support entering subnets, whereas I can at the vlan and fastethernet interface level.
Is this OK?

0
 

Author Comment

by:thetekguy
ID: 11739156
Sorry, meant to say 3750t is enterprise software....
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 11739545
RIP v2 supports classless routing, but the configuration is still classful. You configure 10.0.0.0 and it will send routes for all the subnets within that, rather than the entire class A.
0
 

Author Comment

by:thetekguy
ID: 11743409
Thanks.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cisco ubr7200 problem with  interface Wideband-Cable 1 47
2 routers, one cable modem 10 106
Cisco Router help 5 72
Cisco ASA 5512-X Active/Standby HA 4 27
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question