[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Internet Explorer does display .xhtml files as source, not as content.

Posted on 2004-08-05
15
Medium Priority
?
244 Views
Last Modified: 2013-12-16
Hi -

I am running Internet Explorer 6.0.2800.1106.  I am trying to display a .xhtml file but the source get displayed (example below)

  <?xml version="1.0" encoding="UTF-8" standalone="no" ?>
  <!DOCTYPE html (View Source for full doctype...)>
- <html xmlns="http://www.w3.org/1999/xhtml">
- <head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

When I rename the file as a .html file the the document is displayed fine.

Is there a setting in IE with which I can enable the display of .xhtml file? Perhaps in the security settings?

Thanks. Regards, Frank
0
Comment
Question by:fschirrmeister
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
  • 2
15 Comments
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 11744323
In windows explorer right click the xhtml file.  Then select open with.  The that will bring up an application list.  Select Internet Explorer, and chech the checkbox that says always open use for these files the click open.  Now xhtml is associated with IE

Cd&
0
 

Author Comment

by:fschirrmeister
ID: 11747497
This is not about file association (which was already correct). It opens the .xhtml file in IE but displays the .xhtml source, not the document as it is intended to view. As workaround I have installed FireFox and it works just fine there.

Any way to display .xhtml in IE?
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 11747674
It works fine for me in IE6, so there is either something in the actual file that IE does not like or there is a wrong setting somewhere.  I don't have a clue what the setting might be, but nothing else makes senses.  When IE dumps the source it is most often a screwed up file, but then Mozilla based browsers should trip over it as.

I can't duplicate the problem so I don't know how to fix it.

Cd&
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 31

Expert Comment

by:seanpowell
ID: 11747749
It looks like you're missing some information there...

Try this basic test file, saved as test.xhtml:


<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US">
<head>
<title></title>
<meta http-equiv="Content-Type" content="application/xhtml+xml; charset=utf-8" />
</head>
<body>
Hello, World    
</body>
</html>
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 11747783
Sean,

When I used the snippet posted even with the grossly invalid doctype IE renders.

Cd&
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 11747869
Well that's interesting - on my IE6 it just prints out the source code.
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 11747887
Also - just looked at my test page above - sorry, remove the xml prologue:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 11747889
What OS?

Cd&
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 11747896
XP Pro...
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 11747909
I thought so.  I'm using w2k.

Cd&
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 11748055
Really - w2k parses the file? I guess they got a little stricter with XP.
About time they got strict with something.

Sorry fschirrmeister for the side track - we're just exploring what's going on :-)
0
 

Author Comment

by:fschirrmeister
ID: 11757165
FWIW, if i use the "Hello World" testfile the original produces again the source. If I remove the xml prologue then it displays the Hello World just fine. I am running XP Pro TabletPC.
0
 
LVL 31

Accepted Solution

by:
seanpowell earned 375 total points
ID: 11757279
Yes - IE and the prologue are not good bed partners. It's also optional, and forces IE into into quirks mode, so I would just remove it.
0
 
LVL 53

Expert Comment

by:COBOLdinosaur
ID: 12191793
Sean I think.

Cd&
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
Dramatic changes are revolutionizing how we build and use technology. Every company is automating, digitizing, and modernizing operations. We need a better, more connected way to work together as teams so we can harness the insights from our system…
The purpose of this video is to demonstrate how to reset a WordPress password if you are locked out and cannot reset the password. A typical use would be if you cannot access the email to which WordPress would send the password recovery email to…
This Micro Tutorial will demonstrate how nuggets on the Web are formatted by using Chrome Developer Tools. These tools would not only view the site's CSS but it can also modify it and save the CSS to use on your own site.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question