IIS 5 Authentication Problem -- Servername\Username in logon prompt

Hi there.

We have an IIS 5-based intranet Web site running on a Windows 2000 Server domain member server. The Intranet virtual directory is configured for SSL, Basic Authentication (with a default domain specified) and Integrated Windows Authentication.

When users log in with the Domain name\Username syntax at the login box, they can login just fine. However, if the users try to login with only their domain user name, IIS shoots back the logon box pre-filled in with:


The server name is fully qualified. That is to say:


This strikes me as very, very weird.

I scoured the metabase by using the metabase editor. I found some traces to the referenced servername path in the SMTP properties and I nuked 'em because we aren't running SMTP on the IIS server. No help, though.

I also scoured the Registry for traces of the servername--nothing. I don't know why IIS thinks it should be pointing to the local computer instead of our domain controller. As I said earlier, if users manually type in Domainname\Username they can log in fine. However, as you network admins know, the less we have to instruct our users to do themselves manually, the better. :)

Thanks in advance,
Who is Participating?
alimuConnect With a Mentor Commented:
ok - the site will always prompt for authentication against the local SAM first.  User needs to enter username@domain or domain\user to authenticate successfully.
More info in this thread: http://www.derkeiler.com/Newsgroups/microsoft.public.inetserver.iis.security/2004-06/0192.html

This still doesn't explain why some of your users are getting prompts and others aren't.
Are your users all using IE - it's the only browser that supports Integrated logon.
Have you checked out account lockouts / whether user has changed their password that day / clearing out cache and restarting problem browser?
Next to where you allow basic authentication in IIS management console is a button you click to set the default domain for authentication - do you have a specific domain set there?
ISIS2004Author Commented:
Yeah--I've added the non-qualified name of our domain.


Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.


the defaulkt domain should be the windows domain (if it is different to the internet domain)

i.e. for "Domain name\Username", enter the "Domain name" part as default domain.

ISIS2004Author Commented:
Actually, not to split hairs here, but that is what we have done.

For example:

Web server: SERVER01.DOMAIN.COMPANY.COM where DOMAIN.COMPANY.COM is the name of our Active Directory domain

We used DOMAIN as the default domain name for Basic Authentication.

However, in the logon prompt for the SSL-secured page the users see


in the username field instead of


or simply



what about using windows integrated auth - disable plain text authentication, then the ie browser will just send the credentials used to log on to the local AD domain by default.

cheers,  Mike.
ISIS2004Author Commented:
Well, you know we tried enabling only the Windows Integrated Authentication (and disabling the Basic Authentication). However, the logon box still gave the servername\username deal in the logon box.

Should we have bounced the IIS server? I didn' t think it was necessary, but maybe we should have tried that...

no - you needn't bounce the server to apply those changes.

is the iis server associated with the windows domain at all?  try adding the server to the AD domain regime.

ISIS2004Author Commented:
Thanks, alimu. The bottom line is that I need to instruct my users to submit their credentials as domain\user or username@domain, as you said.

that's correct - if they're getting a logon box this is the case.
With integrated authentication they shouldn't get prompted for credentials unless they are in a different domain to the server.  If you've got a single domain for clients & web server, users still getting prompted would indicate an NTFS permission problem on the web server files or possibly a client side issue.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.