• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 329
  • Last Modified:

Setting up Router on Redhat Linux 8.0

Hi,

I need to setup a router on a newly installed Redhat Linux 8.0 server. I am very new to this concept.

I have installed the Linux OS on a DELL PC. There are 3 NICs on that machine. I need to setup the router with all these three NICs. I need not make it as a DHCP server. And also this has the fixed IP addresses for  the three NICs.

Can anybody please let me know how to do this? Is there anu document that gives the step by step procedure?

Thanks in advance
Regards
Murali
0
muralimohanb
Asked:
muralimohanb
  • 2
2 Solutions
 
jlevieCommented:
If the Linux box will simply be a router for three attached local networks it will suffice to simply enable ip forwarding ('echo 1 > /proc/sys/net/ipv4/ip_forward' or setting "net.ipv4.ip_forward = 1" in /etc/sysctl.conf).  Then configure the default gateway on each machine all of the attached networks to use the local IP (on that network) of the Linux box.

That's fine for a simple router for local networks, but if two of the networks are local and using private IP space and the third is the Internet you'll need to se up a NAT'ing firewall on the Linux box.
0
 
Red15Commented:
http://en.tldp.org/HOWTO/IP-Masquerade-HOWTO/

Here is the official HOWTO on how to set up full router capabilities regarding
to network masquerading.

Also to jlevie :
note that in RedHat I believe you have a "cleaner" way of setting ip_forward to 1:
Edit the /etc/sysconfig/network
There you will find a line :
"IP_FORWARD=no"

(Note config is from RedHat 9.0, your mileage may differ a bit)

Obivously setting this setting to yes toggles the automatic switching at boot time.
This way of setting the ip_forward flag is preferable since sysctl.conf may be executed
before the script RedHat has provided. So sysctl will enable ip_forward but then
RedHat will disable it again.

For more specifics about routing tables, just keep asking.
0
 
muralimohanbAuthor Commented:
Hi,

For dynamic routing we have installed gated.

Regards
Murali
0
 
Red15Commented:
So did it work now ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now