View Kanji in Visual Studio 6 Source Code Editor on Win2K

Hi,

I got some Japanese source code that I am working on in Visual Studio 6 on Win2K. The code contains some comments written in Japanese. However, the Visual Studio source code editor does not display the kanji correct, it's all a big mess that even effects soem parts of the code since the editor sometimes cannot interprete the end of a Japanese comment correctly.

Here is what I've tried so far:
- Installed Japanese language support for Win2K
- Switched the Windows locale to Japanese (this should affect only date and time settings, so it was a useless try)


Any ideas how to display the Japanese comments?

To avoid misunderstandings (just in case): I do NOT want to write a programm that supports Japanese. I want to VIEW source code that has some Japanese comments in it.
LVL 1
hirnsiebAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jkrConnect With a Mentor Commented:
Well, it *should* work 'out of the box' - see http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vccore98/html/_core_mbcs_support_in_visual_c.2b2b.asp ("MBCS Support in Visual C++"):

"When run on an MBCS-enabled version of the Windows 95 or Windows NT operating system, the Visual C++ development system, including the integrated source code editor, debugger, and command line tools, is completely MBCS-enabled. Visual C++ will accept double-byte characters wherever it is appropriate to do so. This includes path names and file names in dialog boxes, and text entries in the Visual C++ resource editor (for example, static text in the dialog editor and static text entries in the icon editor). In addition, the preprocessor recognizes some double-byte directives ? for example, file names in #include statements, and as arguments to the code_seg and data_seg pragmas. In the source code editor, double-byte characters in comments and string literals are accepted, although not in C/C++ language elements (such as variable names)."
0
 
YarnoSGCommented:
Have you tried opening up the code OUTSIDE the editor, say in NOTEPAD {Right-Click | Open With....}?

 -  since you have installed language support on your WIN2K this should work, and since you are trying to read the comments and not compile, you might be able to get what you need this way...
0
 
hirnsiebAuthor Commented:
Yes, I tried. But it looks excactly the same as in the Visual Studio editor.

I have been successfully working with Japanese on Windows XP and Visual Studio .NET. But on Win 2K and Visual Studio 6 I just can't get it working.

By the way, I also need to compile the code which also depends on the interpretation of the comments: in several cases the compiler/editor doesn't interprete the end of the comments correctly and some parts of the code get lost (they are interpeted as a comment)
0
 
YarnoSGCommented:
Have you just tried making a copy of the code and stripping out the comments?

Also, try a more robust text editor like WORD that lets you change languages and has more FONT support.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.