Solved

intranet reports stopping Crystal Reports v8

Posted on 2004-08-06
10
504 Views
Last Modified: 2008-02-01
Hello,

I have an intermittent problem with crystal reports v8. Once in a while when using the intranet to view reports from a database, the report viewer will just sit there with an egg timer instead of refreshing. Eventually we have to re-boot the server to get it going again which is a real pain. (NT4.0 sp6).
The error log shows "the page server you are trying to connect to is not accessible". The stack dump inludes "c:\program files\seagate software\wcs\webcompserver.exe". Reports that do not use the database link such as word documents etc work fine.

Ive been told that we do not have a maximum number of concurrent users. Any help on how to restart the beast without a server shutdown, or how to cure the problem would be greatly appreciated. Being a novice i'm stumped

Geoff
0
Comment
Question by:GEOFF
  • 3
  • 2
  • 2
  • +1
10 Comments
 
LVL 19

Expert Comment

by:GJParker
ID: 11733813
This could have something to do with the Pagefile size on the server, This document will explain more

http://support.businessobjects.com/library/kbase/articles/c2007401.asp

HTH

Gary
0
 

Author Comment

by:GEOFF
ID: 11733885
Checked out the pagefile size, unfortunatley the settings are correct 267MB recommended and 267MB are set.
0
 
LVL 19

Expert Comment

by:GJParker
ID: 11733945
Sorry I couldn't help, I've seen this mentioned on a few other forums but couldn't find any resolutions. May be one of the other experst may be able to help.

Rather than rebooting the server have you tried just stopping and starting the services.

Good Luck

Gary
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:GEOFF
ID: 11733967
tried stopping the services and the old faithfull access denied appeared.

Thanks for trying

Geoff
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 250 total points
ID: 11734771
0
 
LVL 42

Expert Comment

by:frodoman
ID: 11734787
Have you looked at the database to see if the problem lies there?  Perhaps you have a concurrent users issue on your db not on Crystal?  Perhaps a db service has frozen?  The crystal viewer could freeze up because it's waiting for a response from the db and the db itself is locked up.

If you're getting an access denied message when stopping the services then I'm guessing you're trying to do it w/out full admin rights?  You can try restarting the db services if it seems possible that the db may be the cause.  Otherwise you should be able to restart Crystal services w/out a problem (no guarentee it'll resolve your crash of course) with admin rights.

frodoman
0
 

Author Comment

by:GEOFF
ID: 11735455
The db source is a live informix db, and it had'nt frozen. I tried to stop the services logged on to the server as the Administrator with full rights. This is not my lucky day. Also although we use crystal v8.0 localy i think its v6 on the server even though the head of it says not. He has been known to be wrong before.
0
 
LVL 42

Assisted Solution

by:frodoman
frodoman earned 250 total points
ID: 11735900
That certainly could be a problem!  CR8 is supposed to work on WinNT4 ( http://support.businessobjects.com/library/kbase/articles/c2006833.asp ) but I don't think CR6 was ever officially tested - unfortunately I can't find any documentation to confirm that.

Can you check the version to determine for certain which you have?  Also, if both versions 6 & 8 are on the machine that too can lead to problems ( http://support.businessobjects.com/library/kbase/articles/c2002466.asp ) so removing the older one is recommended.

frodoman
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question