Solved

How would I enable ospf?

Posted on 2004-08-06
11
222 Views
Last Modified: 2010-04-17
How would I enable ospf?
0
Comment
Question by:Pentrix2
  • 5
  • 5
11 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 11734730
Can you be more specific and provide some details?
Like, enable ospf on what? A Cisco router? A Windows server? A different brand router?
0
 
LVL 9

Author Comment

by:Pentrix2
ID: 11734750
a cisco router, the corporate has a 1721 router, and i have 8 clients sites that have a 2610 router.  i want to let them talk through ospf, how do I do that?  right now for example my e0 is 192.168.85.1 and s0/0 is 63.146.240.210 which is my corporate router.  and one of my client sites are like e010.1.110.1 and s0/0 is 63.146.240.226.  how do i enable ospf on them?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 11734956
On your site, using your example:

router ospf 100
 network 63.146.240.210 0.0.0.0 area 0
 redistribute connected

On the remote site:
 
router ospf 100
 network 63.146.240.226 0.0.0.0 area 0
 redistribute connected

Notice that I'm using only your serial link IP address.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 9

Author Comment

by:Pentrix2
ID: 11735030
so with my other client sites that are as following:

clientC
s0/0 63.146.240.230

clientD
63.146.240.231

clientE
63.146.240.232

clientF
63.146.240.233


My corporate router will look like:

router ospf 100
network 63.146.240.210 0.0.0.0 area 0
network 63.146.240.230 0.0.0.0 area 0
network 63.146.240.231 0.0.0.0 area 0
network 63.146.240.232 0.0.0.0 area 0
network 63.146.240.233 0.0.0.0 area 0
redistribute connected

My clientC router
router ospf 100
network 63.146.240.230 0.0.0.0 area 0
redistribute connected

My clientD router
network 63.146.240.231 0.0.0.0 area 0
redistribute connected

My clientE router
network 63.146.240.232 0.0.0.0 area 0
redistribute connected

My clientF router
network 63.146.240.233 0.0.0.0 area 0
redistribute connected

Would it look like that?  but I saw with cisco that it's suppose to be like,      63.0.0.0 0.255.255.255 area 0, since this is a class A network.  Do I do it your way which is 63.146.240.226 0.0.0.0 area 0?
0
 
LVL 9

Author Comment

by:Pentrix2
ID: 11735062
And for each s0/0 on each router, do I need to make a command:


ip ospf authentication-key password
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11735359
Your corporate router only has to have its own serial ip.
You do not need the authentication. Worry about that, if you want to implement it, after you get everything talking.

The network statement only identifies the local links that will participate in the ospf process, and listen for neighbors and updates.
If you have multiple interfaces all in the same subnet, then use the appropriate subnet, not necessarily the classful. Since yours are all single IP's, then there is no value in using the classful "63.0.0.0 0.255.255.255". You may at some point grow and have new interfaces that you need to subnet and perhaps you don't want a particular interface to participate in ospf, or to participate in a different area. My way just gives you ultimate flexibility and control from the very start.
0
 
LVL 9

Author Comment

by:Pentrix2
ID: 11735456
Would I need to make any changes to my routing table?  And do you recommend to use authentication or I don't really need it?

My ISP is with Qwest, which I have to go through them to get to my other sites, do they need to be notify and make any changes to their routers to enable ospf on my serial lines?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11737221
If your serial connections are through an ISP, then most likely you will not be able to use your own dynamic routing protocol, ospf or other.

>Would I need to make any changes to my routing table?
Yes. The whole purpose of OSPF is to have dynamic routing tables..

What, exactly, are you trying to accmplish?
0
 
LVL 9

Author Comment

by:Pentrix2
ID: 11737553
Ohhh, so if the serial connections is through an ISP (like Qwest), then I can't have my own dynamic routing protocol, which means I can't use ospf.  Correct?


What kind of changes would I need to make on my routing table?


I need to create a dial backup, just in case if my serial fails, my dial backup kicks in using a usrobotics 56k modem to dial into my corporate router.  As to my understanding, without ospf then my dial backup plan won't work without it because it needs to be smart enough to learn new routes.  Correct?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11738022
Serial connections to an ISP will not allow you to run your own dynamic routing, correct. ISP's only use BGP to customer premesis. BGP will not help you in your case.

IF you were running a dynamic protocol, you would not have static routes, so you would remove them.

For a dial backup solution, a simple static route would usually be sufficient, perhaps with a higher cost specified.
Good backgrounder:
http://www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a0080087225.html

Detailed information on using floating static routes for dial backup. This example uses ISDN, but the principles are the same for analog dial:
http://www.cisco.com/en/US/tech/tk801/tk133/technologies_configuration_example09186a0080093f7e.shtml



0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11754002
If the S0/0 addresses of the remote sites really are as indicated, the ISP is providing a virtual network where all of these branch offices think they're on a single shared subnet.  If this virtual network will pass multicast traffic, then OSPF could work between them.  It might be an interesting experiment.

If that's not the case, though, you would be trying to provide, to the ISP, routing for your various local private networks; even if they are willing to accept OSPF from you (unlikely!), they should filter out such routes.

0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question