Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2791
  • Last Modified:

Can't find startup script

Background:  Windows 2003 Server Single DC Domain.  I once had a startup script called map_m.bat and was playing around with the GPO. I don't remember where I put it but, I believe it was long since gone.  I would always get an error in my event long that the script could not be found.   I could never find where I had this script configured.  I recently had a thought that there must be some reference to this script in the registry.  Sooooo I stupidly searched the registry for any reference to the map_m.bat file and I did find some entries.  I cleared the data from the entry leaving the key in place on each entry i found.  Now my startup is all screwed up.

Now when I reboot I get the error message below plus when this message is being displayed a desktop comes up for the default user.  The system stays in this state for about 10 min until the GPO script times out at which time a normal login screen will appear and everything else appears fine.

Of course my last systemstate backup is from January and I am afraid what might happen if I restore it.   The network is pretty static with only 4 users.  The only major change since January is I removed a second DC from the AD recently.

How can I best clean up this mess???     If I loose my other GP entries it would not be the end of the world.  I just want it to start up normal.

Here is the error: "Windows cannot find 'idlist,:232:3548,\\domainname.org\sysvol\domainname.org\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\Machine\Scripts\Startup\'.  Make sure you typed the name correctly, and then try again.  To search for a file, click the Start button, and then click Search."
0
avsc
Asked:
avsc
  • 3
  • 2
  • 2
  • +2
1 Solution
 
Rob_991Commented:
Have you looked within GP objects and checked

Computer Configuration
Windows Settings
Scripts Startup/Shutdown

Also....

User Configuration
Windows Settings
Scripts Login/Logoff

Make sure that inside these you are not calling the batch file.
0
 
Fatal_ExceptionCommented:
Yes, you should have just deleted the call for the script from your Group Policy..  Did you backup your registry before you deleted these entries?  

Although not exactly your problem, this may help guide you:

http://www.jsiinc.com/SUBP/tip7500/rh7557.htm
0
 
avscCEOAuthor Commented:
Yes, I checked the GP objects for the script and it was not there.  There is a newer script that I just added and it seems to be working.  A simple script to sync the workstation time with the server.

And, no I was stupid and did not create a current backup of the registry before I made the change.  I have a backup from January 2004.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
asafganotCommented:
On which computer did U edit the registry? a workstation or the DC?
On which computer do U get the message? a workstation or the DC?

Try going to:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\Scripts\Startup

You'll find registry keys named as numbers.
Expand each registry key and it's sub keys. look for a value named 'Script'. If it is empty, Delete the whole registry key with the same number (I'm talking about the primary "numbered" key, right under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\Scripts\Startup)

This time, Backup it all up before ;)

Good luck.
0
 
avscCEOAuthor Commented:
asfganot:  I edited and got the message on the DC.

I looked at HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System\Scripts\Startup and have a key Default which is empty and a sub folder of 0 which also had a default key which is empty.

NEXT?
0
 
asafganotCommented:
If you disable all group policies at the domain level and at domain controllers OU and then run gpupdate /force on oyour DC, Do you still get the message?

Also, Open a new GPO and link it to the domain controllers OU. Set the following policy on the GPO:
Computer Configuration --> Administrative Templates --> System --> Scripts --> Run Startup scripts asyncronously : ENABLED and
mak sure that Computer Configuration --> Administrative Templates --> System --> Scripts --> Run Startup scripts syncronously is set to disabled or not configured.

Then, run the GPUpdate /force again.
0
 
avscCEOAuthor Commented:
asfganot:  Thanks!  I ran the gpupdate /force and that seemed to do the trick.   Do changes to the gp need to be forced or will it happen automatically eventually?
0
 
AsafGCommented:
AVSV: (I changed my login name),
Normal Group Policy updateds occur only if the GPO has been updated.
The /force switch forces the GPO to be reapplied even if it was not updated.
0
 
AsafGCommented:
BTW, Don't forget to close the question.
:)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now