Export : Paginated Text Format - does not give correct number of Lines per Page & Correct Format

Hi, I am using CR8.5, VB6 & Crystal32.OCX. My clients want to print Invoices on good old DOT MATRIX PRINTERs using DOS (TEXT) Based Printing since that is extremely Fast comparing to Windows Graphic Mode Printing. I created a report - designing it becomes really tough - since exporting to TEXT does not print it on the same location as it is shown - so my first question is - is there any FONT thru which it prints the same way it shows on the screen when EXPORTED to Text and next problem is that number of lines per page are not same - i.e. for german standard fanfold stationery 8.5*12" (it should print 72 lines exactly per page), it does'nt - even if I mention crystal1.linesperpage=72.
Since it is a pre-printed invoice - there are some page header & some page footer sections which need to be suppressed using formulas, in windows printing they get suppressed when exported they get printed.
In fact - my Report Prints beautifully directly but when exported - the problems occur.

Or is there any other way out so that I can Print my Crystal Report's Output Using TEXT Mode Printing.

I have uploaded all the latest monthly Hot Fix from C.R. web site.

LVL 1
springtimesoftwareAsked:
Who is Participating?
 
mlmccConnect With a Mentor Commented:
Try suppression as either
NOT LastPage
or
Not LastRecord

mlmcc
0
 
bdreed35Commented:
First thing I would do is use a font like Courier New.  Each letter will take up exactly the same space in Crystal as it will when you exxport it to text.

You should be able to conditionally suppress sections in Crystal and have it carry over to the exported file.  Try posting more specifics as to how you are suppressing, and what kind of formula you are using.

One more thing, if I remember right, the lines per page is controlled during the export using the paginated text export.  I would try doing an export from within the Crystal Reports Designer, and you should see what I am talking about.  If you don't see it, there is a registry setting that will allow you to be prompted for the number of lines per page.  If you need the registry key, let me know and I will find it for you.
0
 
mlmccCommented:
You might look at this for printing help

http://support.businessobjects.com/communityCS/TechnicalPapers/scrprinterdependency.pdf.asp

I know Crystal doesn't work well with dot matrix printers.  One thing to do is use only fonts native to the printer and no graphics.

Here is another idea
http://support.businessobjects.com/library/kbase/articles/c2002089.asp

mlmcc
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
springtimesoftwareAuthor Commented:
Thanx for the help.

the formula for suppressing the section (pagefooter section) which i hv used is : pagenumber <> pagecount (i do not want the page footer section to be printed on last page), but while printing, report does not print footer on first page and does print footer on the last page.

i have given the lines - crystalreport1.linesperpage=72 even then it never exactly prints the same no. of lines, lines given in page footer section are not counted in the lines - why?

i will check up creating a report using generic text printer, using native fonts before i add my comment next time.

- is there any other simpler way out so that I can Print my Crystal Report's Output Using TEXT Mode Printing or r u aware of any other similar reporting tools which allow to design and print  text based reports


0
 
Kurt ReinhardtConnect With a Mentor Sr. Business Intelligence Consultant/ArchitectCommented:
In order to print to Paginated Text, there are several steps you should take:

1)  Set the font for all fields to Courier (not New or Western, just Courier).  Courier is a fixed-width font.  New and Western are not.  If you don't have this font available, then install a printer (it can be virtual, for the sake of paginating the document) that supports the font.  Like mlmcc said, try installing the printer to which the report will be printed.

2)  Paginated Text exporting only supports text.  It also doesn't support formatting.  Remove all bolds, underlines, italics, graphics, etc...

3)  Set the Characters Per Inch to 12.  When you export the report, you should be given this option.  If you aren't, then you need to check your registry for the following keys:

HKEY_CURRENT_USER\Software\Seagate Software\Crystal Reports\Export\TextExport\CharPerInch (REG_DWORD with a Hex value of C)
HKEY_CURRENT_USER\Software\Seagate Software\Crystal Reports\Export\TextExport\PromptAgain (REG_DWORD with a Hex value of 1)

4)  Remove all margins - they are irrelevent when exporting to paginated text

5)  Since the font is fixed width, you can resize the font to exactly the number of characters required per field.

6)  Suppress all extraneous sections.  Fit all other sections to remove spacing issues, which is most likely causing your problem with creeping.

Hope this helps,

Kurt
0
 
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
I would prefer split points.  mlmcc makes some valid comments, but I'm the only one that provided any significant detail to this issue.

~Kurt
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.