Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Routing settings

Posted on 2004-08-07
20
Medium Priority
?
215 Views
Last Modified: 2010-04-11
i've a cisco 1720 for a link between 2 places... its routing OK, we have a gateway to internet, so i need to give internet to the other place, this is the config

=================================
interface FastEthernet0
 ip address 135.100.1.254 255.255.255.0
 ip helper-address 135.100.1.1
 ip nat inside
 speed auto
 half-duplex

interface Serial0
 ip address 135.100.200.1 255.255.255.0

router eigrp 6000
 network 67.0.0.0
 auto-summary
 no eigrp log-neighbor-changes

ip classless
ip route 135.100.7.0 255.255.255.0 135.100.200.3
=================================

i added ip route 0.0.0.0 0.0.0.0 135.100.1.253 as 135.100.1.253 is the gateway's ip but it didn't work.
i added ip default-gateway 135.100.1.253 and the same.

what i need to set to route internet ip through this device?

Thanks in advance.


FM
0
Comment
Question by:fmonroy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 5
  • +1
20 Comments
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11745783
Please provide a drawing of the network. I am not clear on a couple of details
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11749851
sure... it's at http://img61.exs.cx/img61/8862/Routing.png

i need to route packets from Net B to the Internet
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11750335
Thanks for the drawing,
try adding 135.100.0.0 to your network statements

0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 3

Expert Comment

by:fatlad
ID: 11750486
Is the diagram for the whole network? I am not sure what your EIGRP process is routing here. Network B has no way of reaching the 135.100.1.253 (I think that is the router in N/w A, and the diagram has a small error). As Mark says, adding the 135.100.0.0 network to it would work, or if you want to do it all in a static route, add the line:  ip route 0.0.0.0 0.0.0.0 serial 0
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11750623
I think he has a static route between the 1720's  And yes the diagram is very imcomplete.
but i was able to finally figure it out.
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11754009
Packets from Net B are reaching Net A correctly;

I don't know what eigrp settings are for, some guys used this routers from old installation without cleaning settings; the only i need is to forward packets from B to the internet.

where should the "0.0.0.0 0.0.0.0 serial 0" route be set? Router in Net A or in Net B?
0
 
LVL 3

Expert Comment

by:fatlad
ID: 11754076
Net B.

If you are not using EIGRP, turn it off with "no router eigrp 6000"
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11754312
I have no idea what network 67.0.0.0 is, or where on your diagram.  I'd assume that the EIGRP is between your two routers, and so if you add netwrok 135.100.0.0, you should no longer need the static route.  Also add "default-information-originate" to the EIGRP config on the router that has the Internet connection and default route, so it will provide a default route to its neighbor.

0
 
LVL 5

Author Comment

by:fmonroy
ID: 11754847
OK, i will try your suggests, but we need to wait because password recover procedure needs to be done at Net B.

I will post any news.

Thanks to you all.
0
 
LVL 8

Assisted Solution

by:MarkDozier
MarkDozier earned 160 total points
ID: 11754881
Lets do this
On your drawing properly label each interface that is being used then post when you have it.
Post you complete config for both 1720's and label them coorectly as Net A or Net B. I think you need to do som house cleaning and documentation to avoid futyre issues.
Tell us how you are connecting to the internet. IS it with an interface on the 1720 of is there another devoce at the boundary?
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11768114
OK...

the new diagram is here: http://img56.exs.cx/img56/8862/Routing.png

what i need to do is to permit that a device at Net B (by example 135.100.7.150) can access internet through Net A.

Here is the configuration from both routers, A & B (C is a linksys gateway/router only with local and internet addresses)
======================================================
Router A
======================================================
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname XXX
!
no logging buffered
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret 5 XXX
enable password XXX
!
memory-size iomem 25
ip subnet-zero
no ip finger
ip name-server XXX
!
!
!
!
interface FastEthernet0
 ip address 135.100.1.254 255.255.255.0
 ip helper-address 135.100.1.1
 ip nat inside
 speed auto
 half-duplex
!
interface Serial0
 ip address 135.100.200.1 255.255.255.0
!
interface Serial1
 no ip address
!
interface Serial2
 no ip address
!
interface Serial3
 no ip address
!
ip classless
ip route 135.100.7.0 255.255.255.0 Serial0
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password XXX
 login
!
end
======================================================
Router B
======================================================
version 12.1
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname XXX
!
enable secret 5 XXX
enable password XXX
!
!
!
!
!
memory-size iomem 25
ip subnet-zero
ip name-server XXX
!
!
!
!
interface Serial0
 ip address 135.100.200.3 255.255.255.0
!
interface FastEthernet0
 ip address 135.100.7.254 255.255.255.0
 speed auto
 full-duplex
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password XXX
 login
!
end
======================================================

Thank you
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11769649
Where is and and what is acting as the DHCP server ?

0
 
LVL 3

Expert Comment

by:fatlad
ID: 11770493
Still slightly confused by the diagram, do the devices in net B have address in the 135.100.1.x or 135.100.7.x?
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11773672
MarkDozier: there is a server in Net A providing IP addresses using DHCP. At Net B computers have static IP addresses. i dont think that addressing is the problem.

fatlad: in Net B every computer (device) uses 135.100.7.x addresses.
0
 
LVL 3

Accepted Solution

by:
fatlad earned 160 total points
ID: 11774320
OK so lets start pinpoint where this problem is. Can you do the following and let me have the answers.

1. Can a client in Net B ping 135.100.7.254
2. Can a client in Net B ping 135.100.200.3
3. Can a client in Net B ping 135.100.200.1
4. Can a client in Net B ping 135.100.1.254
5. Can a client in Net B ping 135.100.1.253

6. Can you log on to router A and ping 135.100.200.3
7. Can you log on to router A and ping 135.100.7.254
8. Can you log on to router A and ping 135.100.1.253
9. Can you log on to router A and ping a client.
10. Can you log on to router B and ping 135.100.200.1
11. Can you log on to router B and ping 135.100.1.254
12. Can you log on to router B and ping 135.100.1.253

Then we can see exactly what the problem is. Don't worry we will get there in the end!
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11774678
1. Yes
2. Yes
3. Yes
4. Yes
5. Yes
6. Yes
7. Yes
8. Yes
9. Yes
10. Yes
11. Yes
12. No

Thank you
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11776604
Great!!! it's working now, i just added rip routing on networks involved and 0.0.0.0 route at A.

I'll just verify access.

Thank you very much.
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11778723
Good job. Way to go. I was going to post a config for you, but if it is working Congrats.
0
 
LVL 3

Expert Comment

by:fatlad
ID: 11781102
Excellent, well done!
0
 
LVL 5

Author Comment

by:fmonroy
ID: 11784172
Thank you all very much
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question