Solved

Good wireless connection, unable to ping router

Posted on 2004-08-07
6
23,341 Views
Last Modified: 2011-08-18
I recently purchased a Netgear WGT624 v2 wireless router to connect 3 PCs to a broadband modem. The first PC, a Dell desktop, is connected directly to the router - no problems. The second PC, an older Gateway desktop, is connected wirelessly using a USB Linksys Receiver - no problem here either. Which brings us to the Sony VIAO PCG-V505EX laptop, my problem child.
When I first hooked up the router, I used all defaults. Both the Gateway desktop and Sony laptop came right up wirelessly. I then changed the SSID and implemented WEP 128 bit security. The Gateway desktop came right up again. The laptop apparently connects to the router, but I cannot ping the router.
When I turn on the wireless receiver on the Sony laptop, it displays a message that it is connected to the router with an excellent signal (of course the laptop is right next to the router at the moment).
When I right-click the icon in the system tray and display the status, the general tab shows a status of ‘connected’ with a speed of ’54.0 mps’. When I click the ‘Support’ tab, all of the TCP/IP settings are ‘<Unavailable>’.
When I select ‘Repair Connection’, I get the following error message: ‘TCP/IP is not enabled for this connection. Cannot proceed’.
An early issue I had was that I had to manually set the IP address for the Sony laptop, since the IP address it was using was not in the correct range for the router. The router is using ‘198.162.0.1’. I set the Sony laptop to ‘192.168.0.145’. Having done that, the Sony laptop connects fine when I physically connect it to the router. But that didn’t fix the wireless connection.
The command ‘ipconfig’ on the Sony laptop yields the following:
IP Address:           192.168.0.145
Subnet Mask:        255.255.255.0
Default Gateway:  192.168.0.1
When I tried the command 'ipconfig /release', I got the following error message: ‘The operation failed as no adapter is in the state permissible for this operation’.
I have compared my wireless and network adaptor settings on the Sony laptop with those on the Gateway desktop. They appear to be identical.
I have Norton Internet Security installed on the laptop, but disabling it doesn’t help.
The XP firewall is not enabled
The laptop is running XP Home with all available updates applied.
Any assistance would be greatly appreciated.


0
Comment
Question by:shambalad
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 11

Expert Comment

by:infotrader
ID: 11777063
1.  It is fairly common for wifi computers NOT to hanlde 128-bit WEP too well.  Try changin it to 60-bit (10 character HEX) and see what happens.

2.  Also, on your wireless network card, try changing the SSID to "ANY" and see if it helps.

- Info
0
 
LVL 5

Accepted Solution

by:
eddkhamou earned 500 total points
ID: 11778882
Couple of things.  

Once you set the wireless connection as a static IP you cannot renew the connection with the repair or at the command screen.

I had the same problem with a sony laptop.  

Make sure that the authentication is turned off for the wireless connection.

1.  Click on the Wireless Connection Icon in the bottom right corner of the computer screen
2.  Click on Properties when the Card Status Dialog box opens
3.  Click on Advanced
4.  Under Internet Connection Firewall make sure the box is UN-checked
5.  Next, click on Wireless Connections
6.  Under Preferred Networks click on the network name that you are using
7.  Click on Properties
8.  Click on Authentication
9.  Make sure that the Enable 802.11x authentication checkbox is UN-checked

If that doesn't work try this.

1.  Try completely uninstalling the Norton Internet Security program.
2.  Run this program to repair the Winsock files

 http://www.spychecker.com/program/winsockxpfix.html

3.  Change the wireless connection properties back to DHCP.

Hope this helps

Ed
0
 

Expert Comment

by:aishvarma
ID: 11818092
There was an issue in My XP machine in the sense under services.msc click the Wireless Zero Configuration service. either restart it or stop the service and restart it again.  Usually the issue is resolved.
Also ensure that your Accesspoint is not configured for a DHCP server, in case you're using statically assigned IP's.

The wireless router that i had  a problem in that the IP you assign for the LAN ports, and the wireless ports needed to be from Different Subnets. i.e. If you assigned 192.168.1.x to the LAN ports to which you can physically connect your laptop or desktop, you cannot have your wireless laptop in the 192.168.1.x range wtihin the same network.

For a fully functional "Working " connection I only configure the Ethernet IP address and subnet and let the wireless part work on a DHCP with the defualt settings like 10.x.x.x range. Once everything is working, you can afford to fiddle around with the settings and the security.
Hope it helps.

Ash
0
Flexible connectivity for any environment

The KE6900 series can extend and deploy computers with high definition displays across multiple stations in a variety of applications that suit any environment. Expand computer use to stations across multiple rooms with dynamic access.

 
LVL 7

Author Comment

by:shambalad
ID: 11865522
First, please accept my apologies for not responding to the replies sooner. I was away for the last two weeks and was unable to work on this issue in the meantime. The good news is that I have been able to wirelessly connect to the internet and network with the other computers in the house. The downside is that, for the time being, I have had to disable WEP, but I am not in an urban setting and, as such, not as worried about interlopers on my wireless router. I will attend to it, but it is an acceptable exposure for me today.
Anyway, these are the steps I took.
I first disabled WEP. I removed the static IP from the laptop. The router was set for DHCP with no MAC reservations. I downloaded the latest driver for the wireless adaptor from the Sony website. At this point, there was still no change in the status of my connection.
I then deleted and reinstalled the wireless adaptor. This was an improvement, Now when the laptop appeared to connect and I clicked the icon in the system tray, I had the local and router IPs displayed on the status page. The Repair option was no longer ending in error either. However, I still couldn’t ping out from the laptop.
What appears to have turned the corner was running the Winsock repair utility. That got me connected to the internet. I also opened up my Norton firewalls to the same range as my router. That seemed to solve the home networking issue.
I do appreciate all of the input. But as best as I can tell, it was the WInsock repair that really solved my problem. I'm suspecting that the driver upgrade and adaptor reinstall were important pieces too. I believe that eddkhamou should receive the points for this question.
Thanks again.
Shambalad
0
 

Expert Comment

by:msid99
ID: 32908362
Unfortunately the above steps did not solve my issue. In my office my colleagues are able to access wireless through their respective laptops. I am using Compaq CQ60-405EE which comes with Windows Vista by default. I have loaded Windows XP professional and after lot of hardship got all the drivers installed. Now, the problem is with my wireless connectivity. The wireless connections show "Excellent" connection and I am able to see IP addressed assigned and the default gateway identified. The "Sent" packets are moving up but the "Received" packets are only 2 for long time. I am unable to ping the default gateway either. Obviously unable to browse as well.

Please help!!!
0
 
LVL 7

Author Comment

by:shambalad
ID: 32915458
msid99 -
This is an old question that was closed out years ago. I strongly encourage you to open up a new question to address your dilemma.
regards,
Todd
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Rukus Wifi - Users Disconnect 4 56
Ubiquity UNify UAP problem with link flapping 10 57
Put a name of this device 9 59
How to make my old USB printer wireless? 71 276
This article is split into background info to start and actual review at bottom: Some time ago I wanted to sell a system with both wired and wireless capability but at minimum expense.  Having visited my trusted online auction I was pleasantly su…
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
Suggested Courses

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question