Solved

Can't Receive Mail - New Domain and Exchange Setup

Posted on 2004-08-07
5
207 Views
Last Modified: 2010-04-13
I just brought up a brand new Windows 2000 Domain with Exchange 2000.

For whatever reason I can send mail, but not receive for outside the network.

I don't see any errors in the event viewer nor am I getting in NDRs.

Here is some info about the network:

Single DC with Exchange: 192.168.8.5 (server name is BEAVIS)
Internal Domain: jetselectric.com
External Domain is also www.jetselectric.com (However, we do not host the DNS for our public name)
Web host has a record created to forward all email to exchange.jetselectric.com
I have a MX record created on the DC with the host name exchange for beavis.jetselectric.com

Here is the running config from our 501 PIX:

: Saved
:
PIX Version 6.3(3)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password uXrsXO3xdRQ10kEs encrypted
passwd uXrsXO3xdRQ10kEs encrypted
hostname JETSFW
domain-name jetselectric.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit tcp any interface outside eq smtp
access-list 102 permit tcp any interface outside eq www
access-list 102 permit tcp any interface outside eq https
access-list 102 permit tcp any interface outside eq ftp
access-list 102 permit icmp any any
access-list inside_outbound_nat0_acl permit ip any 192.168.8.64 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 192.168.8.64 255.255.255.224
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 65.248.218.238 255.255.255.252
ip address inside 192.168.8.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool jets-pool 192.168.8.70-192.168.8.80
pdm location 192.168.8.5 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 192.168.8.5 smtp netmask 255.255.255
255 0 0
static (inside,outside) tcp interface www 192.168.8.5 www netmask 255.255.255.2
5 0 0
access-group 102 in interface outside
route outside 0.0.0.0 0.0.0.0 65.248.218.237 255
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.8.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup jets-vpn address-pool jets-pool
vpngroup jets-vpn dns-server 192.168.8.5 208.254.149.169
vpngroup jets-vpn wins-server 192.168.8.5 208.254.149.169
vpngroup jets-vpn default-domain jetselectric.com
vpngroup jets-vpn idle-time 1800
vpngroup jets-vpn password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.8.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:eb5c61151ab577fe04b34ab31800013b
: end

I can send mail fine. I can also send and receive internally.

Any ideas?

Thanks,

Justin
0
Comment
Question by:Justin Durrant
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:dgroscost
ID: 11745207
I don't see a public IP address in your static statements for BEAVIS.  And the MX record points to your PIX firewall.  Are you forwarding SMTP packets somehow?

Try adding a static (inside,outside) Public.Ip.Address.Here 192.168.8.5 netmask X.X.X.X 0 0

Then point your MX record for your internet domain for the public IP of Beavis.

Might need to add a conduit record also - conduit permit tcp host X.X.X.X eq smtp any (where x.x.x.x is internet addy of Beavis)
 
0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 11745236
Well Beavis doesn't have a public IP address. The MX record on BEAVIS has the name "exchange" and points to beavis.jetselectric.com.

0
 
LVL 5

Accepted Solution

by:
dgroscost earned 500 total points
ID: 11745249
Right, but from the internet, your jetselectric.com domain has an MX record that points to exchange for mail.

jetselectric.com        MX preference = 10, mail exchanger = exchange.jetselectric.com
exchange.jetselectric.com       internet address = 65.248.218.238

Now, 65.248.218.238 is your outside interface of your PIX firewall as it appears from your config listed:
ip address outside 65.248.218.238 255.255.255.252

So, unless your PIX is set up to forward port 25 traffic to BEAVIS (which I didn't see), you'll need to do something similar to what I provided above.

0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 11746398
The PIX is setup to forward port 25.. see:

static (inside,outside) tcp interface smtp 192.168.8.5 smtp netmask 255.255.255
255 0 0

0
 
LVL 23

Author Comment

by:Justin Durrant
ID: 11746694
Also.

I cannot ping exchange.jetselectric.com or 65.248.218.238 from within Jets.. Is this a problem?
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
This article outlines the struggles that Macs encounter in Windows-dominated workplace environments – and what Mac users can do to improve their network connectivity and remain productive.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question