• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4304
  • Last Modified:

I can't ping other machines in the network

I have a Windows XP machine connected to the network.
I configured a static IP address.  I can ping the same machine with ping loopback or 127.0.0.1 , but when I ping another machine in the network, it gives me the Request Time Out message. first I suspected the cable, but when  I put another machine in the same location I managed to ping all other machines in the network. So, I don't know why the other machine can't communicate in the network.

If there is any helpful answer, I will appreciate it.
Thanks,
0
Chuckbuchan
Asked:
Chuckbuchan
  • 5
  • 5
  • 3
  • +3
1 Solution
 
AshuraKnightCommented:
Did you also use static ip address when you try with other machine ?
0
 
stevenlewisCommented:
sounds like a firewall issue
what anti-virus program are you using? some come with a built in firewall
or do you have zone alarm or any other firewall? also check the built in firewall on XP
0
 
ChuckbuchanAuthor Commented:
for  AshuraKnight : Yes I use a static IP when I try another machine.

for tevenlewis :if i was a firewall issue why it does good for one machine and not the other.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
stevenlewisCommented:
the problem machine would be the one with the firewall on it
0
 
Debsyl99Commented:
I think Stevenlewis is suggesting that you try disable the firewall on the xp machine - From XP help:

To enable or disable Internet Connection Firewall
Open Network Connections
Click the Dial-up, LAN or High-Speed Internet connection that you want to protect, and then, under Network Tasks, click Change settings of this connection.
On the Advanced tab, under Internet Connection Firewall, select one of the following:
To enable Internet Connection Firewall (ICF), select the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.
To disable Internet Connection Firewall, clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.
Notes

To open Network Connections, click Start, click Control Panel, and then double-click Network Connections.
You must be logged on as an administrator or a member of the Administrators group in order to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.
If you clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box, the firewall on your computer is disabled, and your network is vulnerable to intrusions.
You should not enable Internet Connection Firewall on virtual private networking (VPN) connections or on client computers because ICF will interfere with file and printer sharing.
ICF cannot be enabled on the private connections of the Internet Connection Sharing host computer.
Internet Connection Sharing, Internet Connection Firewall, Discovery and Control, and Network Bridge are not available on Windows XP 64-Bit Edition.

Deb :))

P.S - If this works stevenlewis was right ;))
0
 
Debsyl99Commented:
Hi
XP comes with this annoying little feature that causes this problem for people on a regular basis - I have seen 2000 if not 1 problems about connectivity on EE that relate to this one thing, the internet connection firewall,

Deb :))

0
 
ChuckbuchanAuthor Commented:
I am going try this option tomorrow at work..and see what it will give...

by the way, am I supposed to check or uncheck that box, to get the machine communicating with the network?
0
 
Debsyl99Commented:
Hi

Sorry I didn't make that clear - Uncheck it - you don't want the internet connection firewall on,

Deb :))
0
 
stevenlewisCommented:
firewalls block pings (if set to do so)
therefore you don't want the firewall on
0
 
johnocooperCommented:
If both machines in question have static public addresses you are probably being stopped in the router which may not support NAT u-turns.  I have the same issue on my netwotk; I cannot ping my own public IP addresses because my Cayman router does not like NAT U-turns.

0
 
ChuckbuchanAuthor Commented:
I unchecked the internet connection firewall option.......and I stil can't ping any machine in the network(LAN)
0
 
johnocooperCommented:
Chuck, are you pinging a local or a public IP address?  
0
 
ChuckbuchanAuthor Commented:
I am ping a local address, but there is a request time out response... I can only ping the loopback
0
 
Debsyl99Commented:
First check network card is ok - light's are on, run diagnostics on it if possible, and check device manager for it's status. Other wise run ipconfig /all from command prompt on problem client and ok client and compare the results. Post them here if you like (edit for confidentiality)

Deb :))
0
 
ChuckbuchanAuthor Commented:
I got the solution..........and all that was is I put the machine manufacturer cd and it loaded drivers into the system...then I get the machine to communicate with the network.

I remember though...there was something wrong with the ethernet........it showed a yellow question mark on the device manager on the left side of Ethernet.
network adapter was good.


What is the difference between ethernet and network adapter?
0
 
Debsyl99Commented:
So checking the status of the device manager - yellow question mark indicates that usually the device isn't installed properly or some other fault - worked then, good. Ethernet adapter is exactly the same as network adapter - two different names for the same thing.
Ethernet
http://www.webopedia.com/TERM/E/Ethernet.html

Deb :))
0
 
I_TAYLORCommented:
Have you installed any internet sercurity software i.e ZoneAlarm because i had this problem in my work place and this was on the server and even if you unistall it remains on your computer to see if it has it still on the computer give it an aip address and sit at another machine and ping it with _t while the computer is starting up you should notice that for a brief moment you get a reply the back to request timed out try it it worked for me.
0
 
I_TAYLORCommented:
to uninstall this stoftware completey reinstall it then remove it complety using add remove programs
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 5
  • 5
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now