Solved

New computer build keeps crashing shortly after bootup..

Posted on 2004-08-08
13
495 Views
Last Modified: 2008-01-09
Hi there,

I built a computer a few months ago, and ever since then I have been having a some real difficulties with random reboots and windows bluescreens.  Often the computer will reboot shortly after startup with a 'BAD POOL CALLER' error.  Sometimes, when during the next boot it will take me to a microsoft website and inform me that a device driver caused the problem, and sometimes it will even tell me that my graphics driver caused the problem.  

Anyway, a bit about the system:

ASUS P4P800 Deluxe mobo
3 GHz pentium 4
1 SATA drive
1 DVD Rom drive
ATI 9800 XT Grpahics card

Also, I am having some problems with my interrupts.. for some reason, my graphics card and usb ports all want IRQ 16, and I cannot seem to change this setting.. The best I can do is disable a USB port if I can get that far after booting up, and then, when I reboot, the USB port is back on IRQ 16.  Also, I have a bunch of stuff sharing my IDE IRQ (18 see below) as well.  All this plug and play stuff is making it impossible for me to boot up without having multiple devices on the same IRQ's, which is a no-no, right?  

Here's what my IRQ situation looks like:

ISA 0 system timer
ISA 1 PS2 keyboard
ISA 3 com2
ISA 4 com1
ISA 5 MIDI
ISA 6 floppy
ISA 8 CMOS/real time clock
ISA 9 MIcrosoft ACPI_compliant system
ISA 12 PS2 mouse
ISA 13 Numeric data processor
PCI 16 RADEON 9800 XT
PCI 16 standard PCI to USB host controller
PCI 17 soundmax integrated digital audio
PCI 18 Standard Dual channel PCI IDE controller
PCI 18 Standard Dual channel PCI IDE controller
PCI 18 standard PCI to USB host controller
PCI 19 standard PCI to USB host controller
PCI 22 3com gigabit LOM (3C940)
PCI 23 Standard Enchanced PCI to USB Host controller

I've tried new graphics drivers till I'm blue in the face, and it isn't cutting the mustard.  I am offering a lot fo points on this one because this is a persistant problem and it is driving me INSANE.  Thanks in advance for any help!

-Jude
0
Comment
Question by:judekelley
  • 4
  • 3
  • 2
  • +2
13 Comments
 

Author Comment

by:judekelley
ID: 11749167
Sorry--I forgot to mention that I am running windows XP home edition..  If you need any more info about this system, don't hesitate to ask.

-Jude
0
 
LVL 69

Expert Comment

by:Callandor
ID: 11749551
I would not worry about the IRQ sharing - my video card (Radeon 9000) shares IRQ 16 with a USB host controller also.

Your 'BAD POOL CALLER' error is listed here
http://support.microsoft.com/default.aspx?scid=kb;EN-US;314492

but I think it's a matter of a bad video driver.  Which Catalyst version are you using?  Have you tried an earlier or later version?  Not all versions work for all setups, and I have successfully used 3.7 and 4.3.
0
 
LVL 4

Expert Comment

by:ashishdaga
ID: 11750246
Stop 0xC2 or BAD_POOL_CALLER
The Stop 0xC2 message indicates that a kernel-mode process or driver incorrectly attempted to perform memory operations in the following ways:

By allocating a memory pool size of zero bytes.
By allocating a memory pool that does not exist.
By attempting to free a memory pool that is already free.
By allocating or freeing a memory pool at an IRQL that was too high.
This Stop message is typically due to a faulty driver or software.

Interpreting the Message
Table C.5 describes the information provided by Stop 0xC2 messages. The value of the first parameter indicates the type of violation (see the Description column) and determines the meaning of the next three parameters.

Table C.5   Parameter Listing for Stop Message 0xC2

Parameter 1 Parameter 2 Parameter 3 Parameter 4 Description
0x00000000 This value is always 0 The pool type being allocated The pool tag being used The caller is requesting a zero byte pool allocation
0x00000001, 0x00000002, or 0x00000004 Pointer to pool header First part of pool header contents This value is always zero Pool header has been corrupted
0x00000006  Reserved Pointer to pool header Pool header contents Attempt to free a memory pool that was already freed
0x00000007 Reserved Pointer to pool header This value is always zero Attempt to free a memory pool that was already freed
0x00000008 Current IRQL Pool type Size of allocation Attempt to allocate pool at invalid IRQL
0x00000009 Current IRQL Pool type Address of pool Attempt to free pool at invalid IRQL
0x00000040 Starting address Start of system address space This value is always zero Attempt to free usermode address to kernel pool
0x00000041 Starting address Physical page frame Highest physical page frame Attempt to free a non-allocated nonpaged pool address
0x00000042 or 0x00000043 Address being freed This value is always zero This value is always zero Attempt to free a virtual address that was never in any pool
0x00000050 Starting address Start offset in pages from beginning of paged pool Size in bytes of paged pool Attempt to free a non-allocated paged pool address
0x00000099 Address being freed This value is always zero This value is always zero Attempt to free pool with invalid address or corruption in pool header
0x0000009A Pool type Size of allocation in bytes Allocation's pool tag Attempt to allocate must-succeed

Resolving the Problem
The following suggestions are specific to Stop 0xC2 errors. For additional troubleshooting suggestions that apply to all Stop errors, see "Stop Message Checklist" later in this appendix.

A Stop 0xC2 message might occur after installing a faulty device driver, system service, or firmware. If a Stop message lists a driver by name, disable, remove, or roll back the driver to correct the problem. If disabling or removing drivers resolves the issues, contact the manufacturer about a possible update. Using updated software is especially important for multimedia applications, antivirus scanners, DVD playback, and CD mastering tools.
A Stop 0xC2 message might also be due to failing or defective hardware. If a Stop message points to a category of devices (such as disk controllers, for example), try removing or replacing the hardware to determine if it is causing the problem.
If you encounter a Stop 0xC2 message while upgrading to Windows XP Professional, the problem might be due to an incompatible driver, system service, virus scanner, or backup. To avoid problems while upgrading, simplify your hardware configuration and remove all third-party device drivers and system services (including virus scanners) prior to running setup. After you have successfully installed Windows XP Professional, contact the hardware manufacturer to obtain compatible updates. For more information about simplifying your system for troubleshooting purposes, see " Troubleshooting Concepts and Strategies" and "Troubleshooting Startup" in this book.
For more information about Stop 0xC2 messages, see the Microsoft Knowledge Base link on the Web Resources page at http://www.microsoft.com/windows/reskits/webresources. Search using keywords winnt, 0x000000C2, and 0xC2.
0
 

Author Comment

by:judekelley
ID: 11754079
>I would not worry about the IRQ sharing - my video card (Radeon 9000) shares IRQ 16 with a USB host controller also.
>
>Your 'BAD POOL CALLER' error is listed here
>http://support.microsoft.com/default.aspx?scid=kb;EN-US;314492
>
>but I think it's a matter of a bad video driver.  Which Catalyst version are you using?  Have you tried an earlier or later >version?  Not all versions work for all setups, and I have successfully used 3.7 and 4.3.

Hi Callandor,

I have downloaded and installed Catalyst 4.3.  (I was running 4.7 and before that 4.6)  Hopefully this will help!  Unfortunately, this problem is often intermittent, so I'll need to run the machine for a while to see if the new (old) driver helps the situation.  

If that doesn't work, I am considering reinstalling my OS.

Thanks,

Jude
0
 
LVL 4

Expert Comment

by:Gaud-wo
ID: 11828751
Jude,

I hope you know you have to -uninstall- a video driver before installing a new one??

Also, new video drivers often are programmed to work with latest versions of other software - so you may want to try upgrading drivers for your chipsets (check your mainboard mfg's website - upgrade chipset & AGP drivers).

And finally, a new version of DirectX may also come in handy.

Keeping a PC up-to-date requires some more action than updating windows and a vid card!

Glenn
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:judekelley
ID: 11833485
Well, I tried version 4.3 of catalyst without success.  I also noticed a bit of slowdown on one of my games upon installing the older driver set.    

I'm pretty sure that I am uninstalling the video drivers in the proper fashion--I'm doing it by going to my hardware manager and selecting 'uninstall driver' before installing the new ones.  If there is a better way than that, I would be most interested to hear about it.  

The AGP dirver sounds like a good idea... While I have played around with chipset drivers a bit, I have not specifically gone after the AGP driver (I had thought it was included in the chipset driver).  

I think this graphics card came out a little bit after the motherboard so that may be the source of the problem.  A friend of mine built an identical system, (apart from the graphics card) and he has had zero problems.  His graphics card was the 9800 Pro and I went with the 9800 XT.. because the Pro was out of stock.  Doh!

-Jude
0
 
LVL 4

Expert Comment

by:Gaud-wo
ID: 11838493
You don't seem to be the only one:
http://forums.binarydreams.us/archive/index.php/t-1423.html
http://forums.devhardware.com/archive/t-23773
http://www.techsupportforum.com/archive/index.php/t-9184.html

No one over there found a solution.

If you want to, I can send a Technical Enquiry to ASUS with these details - or you can do so yourself on http://vip.asus.com/eservice/techserv.aspx?SLanguage=en-us . I suggest you do exact the same for the ATI card!

If you want a quick fix, I think you'd better print all this info & get back to your dealer with the card, he has acces to faster support - you can try to convince him to give you a temporary replacement AGP card, as the setup you bought doesn't seem to work properly.

Still, there aren't -that- many issues out there, and I think this is a more common setup... Makes me wonder how the other ppz fixed this...
0
 

Author Comment

by:judekelley
ID: 11853613
And here I thought I was doing myself a favor by buying an ASUS motherboard... never again!  I think I'm just going to buy another motherboard.   Any suggestions on one that will be more compatible with this graphics card?    

-Jude
0
 
LVL 69

Accepted Solution

by:
Callandor earned 500 total points
ID: 11859726
Try Abit's IC7-G, or IC7-Max3.
0
 
LVL 4

Expert Comment

by:Gaud-wo
ID: 11869191
ASUS normally is quite reliable and stable, I'm sure it's an incompatibility in drivers... If it is a hardware incompatibility, there should be more issues, and there should be a clear fix...

I really do suggest you complain to ASUS and ATI, maybe you'll get a completely new product for free if you make a big fuss (post it around on some more forums, and send them the link - they hate bad criticism by end-users, especially if you smear it over the web ^_^)

To be honest, I think this is really outrageous. You buy new, up-to-date hardware and it just doesn't function. And when you contact their support, they mostly insult you by suggesting 'installing new drivers, updating this and that' - even when you say you did that... Like all users are newbies.

Sigh...
0
 
LVL 13

Expert Comment

by:compfixer101
ID: 14114795
No comment has been added to this question in more than 21 days, so it is now classified as abandoned..
I will leave the following recommendation for this question in the Cleanup topic area:
accept callandor

Any objections should be posted here in the next 4 days. After that time, the question will be closed.

Compfixer101
EE Cleanup Volunteer
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Article by: SHIELD1
The 5 R's 1. Repair 2. Restore 3. Reinstall 4. Remote admin 5. Run away OK so I'm not the most skilled engineer around but I definitely have an abundance of experience: electronic repairs since I was 13 and PC and computer hardware repair…
Computer running slow? Taking forever to open a folder, documents, or any programs that you didn't have an issue with before? Here are a few steps to help speed it up. The programs mentioned below ALL have free versions, you can buy them if you w…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now