• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 385
  • Last Modified:

How to get gnome-font-properties dialog recognize new fonts?

Hi,

I have added some nice TrueType fonts to my Slack 9.1 syste.  For KDE/QT all I had to do is add the path to my XF86Config file and all QT-based apps picked up the new fonts.  Simple.

Gnome is the whole another story.  I expected the same when I went to "Pick a Font" after invoking gnome-font-properties, but the same few original options stayed in there.  After googling I came across project "pango", but I don't really know how it fits into the whole schema of things.  How come Gonome can't be as simple in recognizing new X fonts like KDE is?  And more importantly, what do I have to do to get it see my new fonts?  Ultimately what I'm after is being able to pick my new font from gnome-font-properties dialog so that all GTK based apps have the same nice font I have just installed.

My Slack 9.1 came with Gnome 2.4 and that's what I have.
0
zimowski
Asked:
zimowski
  • 2
1 Solution
 
gtkfreakCommented:
Check if your fonts are in the path /usr/X11R6/lib/X11/fonts/TTF path or somewhere there. If not, then copy the font files there and then restart and check if you can see the fonts.
0
 
zimowskiAuthor Commented:
I will try that when I get home.  However, I'd prefer for a cleaner solution, such as some place in the GNOME configuration where I can tell it where my fonts already are so that it can see it.

My fonts is a set of TrueType fonts for Central Europr, mainly because it contains special symbols from the polish alphabet.  Again, I know things work, and it isn't an X server issue, cause all KDE/QT apps work perfectly with it.

My fonts are installed in:

/usr/X11R5/lib/X11/fonts/polish/
  ............................................75dpi/
  ............................................100dpi/
  ............................................misc/

and the FontPath in my XF86Config says:  /usr/X11R5/lib/X11/fonts/polish/

Apparently GNOME needs more than just FontPath.  I came across /etc/gdk/ directory where one is supposed to add <dir> tag to XML-based local.conf.   I did that as well to no avail.

Also, I came across project fontilus, as I knew something must be making the "font:///" work.  I think it's fontilus so I'm wondering if that's where perhaps I need to add my new path?  Apparently in GNOME if you type the location font:/// it resolves to the directory where the few of original GNOME fonts are installed.  But I swear - after looking all over I could not find what's the real path behind "font:///" and how to add extra fonts to it.

Hope this helps more, as I would really prefer to do this cleanly.  I'd like to keep my existing location with new fonts intact, as I believe there must be an easier way to go to some GNOME config file and just tell it where the new fonts are.
0
 
gtkfreakCommented:
Check out the following link. I guess it has something to do with the theme you have installed.
http://www.linuxquestions.org/questions/archive/26/2004/02/2/143900
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now