• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 388
  • Last Modified:

How to set up mysql to get both ?-sign and å,ä,ö (swedish signs)?


I have set up my MySQL5.0 server without problems, but now when I use tables with tuples that contain ? (euro-sign) they are not shown as they should (shown as ?). I guess this is a char-set problem but I haven't been able to solve it. I currently use the latin1_swedish_ci collation. The problem is that I need to be able to show the swedish å,ä,ö (å,ä and ö) as well. Does anybody know how to solve this?

1 Solution
madwaxAuthor Commented:
note: the euro sign isn't shown here either, I guess that EE has the same problem... :(

Are you storing the content from HTML editors??? Might be the problem is with encoding and decoding...

madwaxAuthor Commented:
nope, the same thing happens if I just enter a normal sql query as INSERT INTO table(field) VALUES("?-sign")

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

madwaxAuthor Commented:
I experience the same problem with @ which is even worse... :(
I tried the normal SQL query and it worked fine
INSERT INTO `table` ( `thefield` )
VALUES ( '@å,ä,ö å,ä and ö');

It didn't complain about any errors. Is that what your having the problem with or is it with displaying the sql field?
madwaxAuthor Commented:
I can enter the value into the database, but as soon as the value is entered it changes to a ? which I figure is the unknown character (I use phpAdmin and console mysql). It is a charset problem, but I don't know how to fix it... :(
I was using phpAdmin as well and it showed up fine after it entered in the database. I think it could be a browser charset problem, so try going to "View >> Character Encoding" or "View >> Encoding" depending on what browser your using. I am using Western and it shows up fine.
Try setting the field type (encoding) to unicode.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now