Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How to set up mysql to get both ?-sign and å,ä,ö (swedish signs)?

Posted on 2004-08-09
8
Medium Priority
?
384 Views
Last Modified: 2008-01-09
Hi,

I have set up my MySQL5.0 server without problems, but now when I use tables with tuples that contain ? (euro-sign) they are not shown as they should (shown as ?). I guess this is a char-set problem but I haven't been able to solve it. I currently use the latin1_swedish_ci collation. The problem is that I need to be able to show the swedish å,ä,ö (å,ä and ö) as well. Does anybody know how to solve this?

Thanks,
//madwax
0
Comment
Question by:madwax
8 Comments
 
LVL 7

Author Comment

by:madwax
ID: 11752020
note: the euro sign isn't shown here either, I guess that EE has the same problem... :(
0
 
LVL 11

Expert Comment

by:ajaikumarr
ID: 11752101
Hai,

Are you storing the content from HTML editors??? Might be the problem is with encoding and decoding...

Bye
ajai
0
 
LVL 7

Author Comment

by:madwax
ID: 11752137
nope, the same thing happens if I just enter a normal sql query as INSERT INTO table(field) VALUES("?-sign")

0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 7

Author Comment

by:madwax
ID: 11752361
I experience the same problem with @ which is even worse... :(
0
 
LVL 3

Expert Comment

by:thecode101
ID: 11754643
I tried the normal SQL query and it worked fine
INSERT INTO `table` ( `thefield` )
VALUES ( '@å,ä,ö å,ä and ö');

It didn't complain about any errors. Is that what your having the problem with or is it with displaying the sql field?
0
 
LVL 7

Author Comment

by:madwax
ID: 11755998
I can enter the value into the database, but as soon as the value is entered it changes to a ? which I figure is the unknown character (I use phpAdmin and console mysql). It is a charset problem, but I don't know how to fix it... :(
0
 
LVL 3

Accepted Solution

by:
thecode101 earned 1200 total points
ID: 11762698
I was using phpAdmin as well and it showed up fine after it entered in the database. I think it could be a browser charset problem, so try going to "View >> Character Encoding" or "View >> Encoding" depending on what browser your using. I am using Western and it shows up fine.
0
 
LVL 3

Expert Comment

by:krazywest
ID: 11831429
Try setting the field type (encoding) to unicode.
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating and Managing Databases with phpMyAdmin in cPanel.
Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question