Need to remove Everyone access from individual mailboxes

Hi

I have taken over the administration of an Exchange server. Each mailbox can be open by everyone else. I need all mailboxes to be secure and only accessible by that user.

If I go to "Active Directory Users and Computers" and select a user then click the properties of the mailbox > Exchange Advance > mailbox rights then I see the Everyone group as having read access. I cannot remove this group as I get the following error:

"You cannot remove "everyone" because the object is inheriting permissions from its parent.  Turn off the options for inheriting permissions and try again."

Where do I go to turn off "inheriting permissions?".

Incidentally I have checked the Exchange Domain Servers group and the only members are XXXServ01 (the server name) which is in the Active Directory folder of XXXXXX.co.uk/domain controllers.

DanbrascoAsked:
Who is Participating?
 
BNettles73Connect With a Mentor Commented:
Working with Store Permissions in Microsoft Exchange 2000 and 2003
This document explains the process by which Exchange 2000 Server and Exchange Server 2003 uses permissions to control access to objects in the Exchange store (public folder databases and mailbox databases).

http://www.microsoft.com/downloads/details.aspx?FamilyId=2AE266F0-16B7-40D7-94D9-C8BE0E968A57&displaylang=en


On your workstation -
Add the ShowSecurityPage Entry to the Registry

Start Registry Editor: On the Start menu, click Run, type regedit, and then click OK.
Locate the following key in the registry:
KEY_CURRENT_USER\Software\Microsoft\Exchange\ExAdmin

To add the ShowSecurityPage DWORD value, click Edit, click New, and then click DWORD Value.
For the new value name, type: ShowSecurityPage
Double-click ShowSecurityPage, and then type 1 in Value data. Go to the next procedure.
back to the top

To modify permissions in the root of your Org -
Start System Manager: On the Start menu, point to Programs, point to Microsoft Exchange, and then click System Manager.
Right-click the organization, and then click Properties.
Click the Security tab.
Modify relevant permissions ...

Make sure you understand the implications of modifying security settings ....
0
 
DanbrascoAuthor Commented:
Is there no way to remove the everyone group from the individual mailboxes?
0
 
DanbrascoAuthor Commented:
I eventually found that the problem was due to the Authenticated users having full control
0
 
BNettles73Commented:
That's in the doc I sent you the link for isn't it?

Either way ... Congrats ... glad you got it fixed at least!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.