Solved

Can't view port 80 from outside network

Posted on 2004-08-09
8
471 Views
Last Modified: 2010-03-18
Every service that my Debian box is listening to is available except for port 80. Anyone have experience similar issue.

Debian Linux
Apache/1.3.26
PHP/4.1.2-7
Linksys WRT54G

SSH 21 & 22 Working
HTTPS 443 Working
SMTP 25 Working
POP3 110 Working
HTTP 80 Not Working

Linksys WRT54G set to DMZ for 192.168.1.118. Port forwarding set for range 20 - 10000 for 192.168.1.118. Firewall enabled.

Apache config file: NameVirtualHost 192.168.1.118:80

eth0: inet addr:192.168.1.118  Bcast:192.168.1.255  Mask:255.255.255.0

route:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

Try http://www.ocbumz.com, then try https://www.ocbumz.com, I can send and recieve emails.
0
Comment
Question by:bumz714
  • 4
  • 4
8 Comments
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11757055
make a iptables  -L

and paste the result.

maybe you have filtered the port 80 in your network.
0
 
LVL 1

Author Comment

by:bumz714
ID: 11757099
modprobe: Can't locate module ip_tables
iptables v1.2.6a: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11757222
ok. you dont have iptables in your system.

if you disable in your router the firewall. you can access to the port 80?

maybe the router/DSL have filtered.

other

when you start apache in the /var/log/message have any signal? the apache start ok?
0
 
LVL 1

Author Comment

by:bumz714
ID: 11757542
From error.log after reboot:
Apache/1.3.26 (Unix) Debian GNU/Linux PHP/4.1.2 mod_ssl/2.8.9 OpenSSL/0.9.6c mod_perl/1.26 configured -- resuming normal operations
suEXEC mechanism enabled (wrapper: /usr/lib/apache/suexec)
Accept mutex: sysvsem (Default: sysvsem)

I think it may be the Linksys router because I updated the firmware. I just wasn't sure if it was Apache because I update some Debian packages also.

What ever I find I'll keep it posted.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 14

Accepted Solution

by:
pablouruguay earned 250 total points
ID: 11758317
make a netstat -a

and see if port 80 is listen

you can see    

tcp        0      0 yourservername:http              *:*                     LISTEN

if this line appears.

you have problems with the router
0
 
LVL 1

Author Comment

by:bumz714
ID: 11758531
I got:

tcp        0      0 *:www                   *:*                     LISTEN
tcp        0      0 *:https                 *:*                     LISTEN
tcp        0      0 *:imap3                 *:*                     LISTEN
tcp        0      0 *:imap2                 *:*                     LISTEN
tcp        0      0 *:pop3                  *:*                     LISTEN
tcp        0      0 *:smtp                  *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 *:ftp                   *:*                     LISTEN


Nothing about http
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11761880
ok this mean that your server is listen httpd.

your problem now is in router i think
0
 
LVL 1

Author Comment

by:bumz714
ID: 11775512
After countless hours troubleshooting and numerous forums I have found my answer. I have include the 3 links I found for reference in case other run into the same problem.

http://www.dslreports.com/forum/remark%2C7227731~root=adelphia~start=17~mode=flat

http://www.opentechsupport.net/forums/archive/topic/5503-1.html

http://www.flux.org/pipermail/linux/2002-July/009230.html

As a summary, I have adelphia cable as my ISP I had Timewarner previously but Adelphia blocks all inbound port 80 requests, all other ports work fine. So if you want to have run a PWS don't use Adelphia.

Thanks for your help pablouruguay points will be reward since I can't retract.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
How to enable SSH in Ubuntu. 7 88
Exploits in Kali Linux 4 223
IPA - change main server? 3 89
Linux SSH Error 9 68
I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now