?
Solved

remote access PPTP VPN server on Cisco PIX 501

Posted on 2004-08-09
4
Medium Priority
?
3,762 Views
Last Modified: 2012-06-21
I used the PDM VPN wizard to set up a PPTP remote access VPN server, but the clients won't connect - they report "Error 678: There was no answer".  Is there something special that I need to do to get this to work?

Here is my configuration:

Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password *REMOVED* encrypted
passwd *REMOVED* encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 100 permit tcp any host *REMOVED* eq www
access-list 100 permit tcp any host *REMOVED* eq https
access-list inside_outbound_nat0_acl permit ip any 192.168.5.192 255.255.255.192

pager lines 24
logging on
logging buffered errors
logging trap notifications
mtu outside 1500
mtu inside 1500
ip address outside *REMOVED* 255.255.255.240
ip address inside 192.168.5.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_IP_address_pool 192.168.5.200-192.168.5.250
pdm location 192.168.5.2 255.255.255.255 inside
pdm location 192.168.5.192 255.255.255.192 outside
pdm location *REMOVED* 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) *REMOVED* 192.168.5.2 netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 *REMOVED* 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.5.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
isakmp enable outside
telnet timeout 5
ssh 64.80.156.35 255.255.255.255 outside
ssh timeout 5
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local VPN_IP_address_poo
l
vpdn group PPTP-VPDN-GROUP client configuration dns *REMOVED*
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username jkillen password *********
vpdn enable outside
vpdn enable inside
dhcpd address 192.168.5.10-192.168.5.33 inside
dhcpd dns *REMOVED*
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username jkillen password *REMOVED* encrypted privilege 15
terminal width 80
Cryptochecksum:c34793f99fe9cace3397056812821180
: end
[OK]
0
Comment
Question by:packratt_jk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 11758208
>vpdn enable inside

you don't need it on both sides, just the outside
You might need to change this for troubleshooting purposes:
>vpdn group PPTP-VPDN-GROUP ppp authentication mschap

to this:
vpdn group PPTP-VPDN-GROUP ppp authentication mschap chap pap

If it works, then it is a client configuration issue with the security authentication methods

0
 
LVL 3

Author Comment

by:packratt_jk
ID: 11764874
ok - I made those changes and it still didn't work.

I took a look at the logs and it looks like I forgot to add pptp and gre to the access-list.  I added those and tried again - I got further, but it still didn't work.

Then I thought that maybe it was something on my network here, so I tried it from outside the firewall and it worked!

So at this point it looks like the firewall (a cheap little D-Link box) doesn't play nice with PPTP - would the cisco vpn be able to work with this?

0
 
LVL 36

Expert Comment

by:grblades
ID: 11787215
lrmoore - Please could you have a look at this PIX question
http://www.experts-exchange.com/Networking/Q_21090315.html
0
 
LVL 3

Author Comment

by:packratt_jk
ID: 11794388
More news - it seems that this works ok behind the firewall provided that there is only one connection at a time.

Also, on some machines I had to disable the 'require data encryption' option to get them to connect initially, but then I could turn it back on and subsequent connections would work fine.

Anyway, it is working sufficiently now, and since lrmoore was the only one to respond and got me going in the right direction, I'm giving the points to him.

Thanks!
0

Featured Post

Need protection from advanced malware attacks?

Look no further than WatchGuard's Total Security Suite, providing defense in depth against today's most headlining attacks like Petya 2.0 and WannaCry. Keep your organization out of the news with protection from known and unknown threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses
Course of the Month13 days, 15 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question