Shared folders appear in Network Places on one machine, but not the other

Machine A and B are both running Win XP Home. Machine A is connected to the Net through an Ethernet card and cable modem. Machine B is connected to Machine A via a phone line LAN and through Machine A to the Net using ICS. Until a few days ago both machines could see and access shared folders/files in My Network Places. Now Machine A can see and access shared folders/files on Machine B, but Machine B cannot see shares on A. When a share is made on B, it appears in My Network Places on A after a short wait, but the reverse does not happen. Both machines can see each others shares when accessing the shares through the Entire Network/MS Windows Network/Work Group Name/Machine Name chain. B can print on a printer that is connected to A through the LAN. I have increased the DWord Value of the IRPStackSize from 11 to the default 15, which has eliminated the 'Not enough storage is available to process this command' error message we got initially. Net view shows the shares on both machines. Pinging both machines works. Enable Net BIOS over TCP/IP is on in both machines. LM Hosts is enabled on both. Printer and file sharing is on on both. Both machines can access the Net for browsing and e-mai retrieval. The LAN is configured with fixed IP addresses, 192.168.0.1 for A and 192.168.0.2 for B. I have searched the Knowledge Base and Googled to find the answer, but nothing to date has worked. Anybody know why shares show up automatically in My Network Places on A and not B?

Thanks.
hokehokeAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
adamdrayerConnect With a Mentor Commented:
Make sure both computer names are not longer than 10 characters
0
 
stevenlewisConnect With a Mentor Commented:
sounds like a browser issue (computer, not web browser)
http://support.microsoft.com/default.aspx?scid=kb;en-us;188305
0
 
stevenlewisCommented:
did you try unsharing and resharing the folder?
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
stevenlewisCommented:
also check the server service and make sure it is runnning
0
 
shad0_chengConnect With a Mentor Commented:
Sounds like you've tried almost everything. 1 more thing to try is search for computer A using computer B:

Click "Start" -> Search->Files
On the bottom left hand side, select computer
Type the computer name in and search
0
 
hokehokeAuthor Commented:
Many thanks to those who responded. The issue remains open. Here are some comments re the responses above.

stevenlewis: KB188305 contains a wealth of rather complicated looking diagnostics requiring an application from the Resouse Kit called Browstat. It took me a bit of searching to find this application and then I had to download and install a bunch of other applications along with it. I have yet to run it. The KB article appears to relate only to domains, although I may be wrong about that. I am doing peer to peer so what is in the article may not apply. In any event, I plan to give Browstat a try and see what it reveals. Yes, I have tried unsharing and resharing folders a number of times. The server service is running on both machines.

sha0 cheng: Search finds both, as does Net View and ping.

adamdrayer: The names are both five character long.
0
 
shad0_chengCommented:
have you try Net use on Machine B?

Start->Run->CMD
NET USE * \\Machine_A\Share_Folder <enter>

then try My Network Places again...
0
 
shad0_chengCommented:
This might have to do with the issue of master browser election, see http://www.winguides.com/registry/display.php/54/
====
A browser election is a normal network occurrence and provides a means to guarantee there is never more than one master browser present in a domain or workgroup.

Open your registry and find the key below.
To control which computer is the Domain Master Browser, create a new string value, or modify the existing value, named "IsDomainMaster" and set the value to equal either "Yes", "No" or "Auto".

To prevent an NT Workstation or Server (non-PDC) from acting as a browser, create a new string value, or modify the existing value, named "MaintainServerList" and set it "No", the other options are "Yes", "No" or "Auto".

Restart Windows for the change to take effect.

Note: These values may also be standard boolean values in the form "True/False" or "0/1".
====
might want to edit the registry of one of the XP home to prevent it acting as a browser
0
 
hokehokeAuthor Commented:
We have determined that one of the network cards has gone bad, which might have caused the problem. We are not certain of this, however, so I want to leave this question open for a bit until we sort out installing a wireless network, which we are finding to be a challenge. Thanks to all for their forbearance  (sp?).
0
 
hokehokeAuthor Commented:
I am not sure what happened to my comment about splitting the points, but evidently it did not get posted, so here is a repeat. Since one of the network cards was bad, we decided to trash the whole netword and start from scratch with a wireless setup. After spending more time than it should have taken to figure out why we could not install the driver for one of the desktop cards, we finally got it running. Even though you all did not actually come up with the answer, you tried to help me by offerring a lot of suggestions. Because I appreciate your time and effort, I decided to apportion the points among you in what I hope is a fair way.

Thank you for your assistance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.