• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1163
  • Last Modified:

module installation on win32


I'm behind a restrictive firewall, so installing modules from the console via CPAN or PPM is not an option

To make things intersting, the Perl folder is on a server share, stand-alone style, with not so much as a file association.

How can I add modules to this Perl engine share?


Specifically, I want to install Win32::API::Prototype
(http://search.cpan.org/CPAN/authors/id/D/DA/DAVEROTH/Win32-API-Prototype.tar.gz)

I have the perl module from CPAN:  Prototype.PM
no MakeFile or anything...
So what can I do?
0
Marketing_Insists
Asked:
Marketing_Insists
  • 2
  • 2
1 Solution
 
ronan_40060Commented:
Since your behind proxy server
You need to set up environment variable
Here's a link to the web page about this topic:

http://aspn.activestate.com/ASPN/docs/ActivePerl/faq/ActivePerl-faq2.html#ppm_and_proxies

good luck
ronan
0
 
vi_srikanthCommented:
I have installed a few modules by just copying to the site/lib folder. Why don't u try that. Just copy the Prototype.PM to: YourPerlPath\Site\lib\Win32\API\Prototype.PM

If API directory is not there, create it.
0
 
Marketing_InsistsAuthor Commented:
-vi_srikanth
tried creating the folder and placing it their maually, I still get the error though:

C:\>I:sys\perl\bin\perl.exe H:\scripts\perl\hide-consol.pl

C:\>Can't locate Win32/API.pm in @INC (@INC contains: I:/sys/Perl/lib I:/sys/Per
l/site/lib .) at I:/sys/Perl/site/lib/Win32/API/Prototype.pm line 14.
BEGIN failed--compilation aborted at I:/sys/Perl/site/lib/Win32/API/Prototype.pm


-ronan_40060
Tried the environmental variables:
still...

Error: No valid repositories:
Error: 500 Can't connect to ppm.ActiveState.com:80 (connect: Unknown error)


Wierd thing:
With wget, when I left my user ID and Password as a environmental variable, it
didn't work either until I built it into wgets argument.  
However, I did have to set the the HTTP_PROXY variable previous to calling wget
(I tried putting the proxy location into wgets argument, but it didn't work...odd)

c:\>set HTTP_proxy=proxy.company.com:8080
c:\>wget -E --proxy-user=MyID --proxy-passwd=PassWord http://download.adobe.com/this.exe
worked !

I think it is a problem with PPM  It's default method of passing the authentication to the proxy is incorrect and it needs argument options similar to wget if it wants to get through.
0
 
vi_srikanthCommented:
For prototype to work, u must first have Win32::API which can be downloaded from http://search.cpan.org/~acalpini/Win32-API-0.41/

If unable to install, just copy the API.pm to the Win32 folder.
0
 
Marketing_InsistsAuthor Commented:
AFter I cp the API.pm to the Win32 folder, it worked out fine

thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now