• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 461
  • Last Modified:

device Manager is empty

Sure could use some help here.  I just moved my entire computer to a new case (and power supply, of course).  Everything is working perfectly, except when I go to check all of my device in device manger it is completely empty.   What I have done so far:
(1) Checked bios to be sure automatic device detection is on
(2) Ran new hardware wizard.  Nothing new detected.
(3) Gone in to services (from start--run) and plug and play changed setting to manual, then restarted.  Nothing.  Then switched back to automatic (where it was). Nothing.
(4) Gone into safe mode and checked device manager.  Still empty.

Sure could use some suggestions here.

By the way, I'm running an Abit KG-7Lite mb.  Windows 2000 sp4.

Thanks,

Bill
0
revoconnell
Asked:
revoconnell
  • 3
  • 2
  • 2
  • +2
1 Solution
 
AicoCommented:
Have you clicked on the + sign next to Computer?

;-)
0
 
gbrayutCommented:
Never hurts to try running "sfc /scannow" to check for corrupt files.

Other then that this is usually an issue with the PnP service
0
 
revoconnellAuthor Commented:
Dear Aico, when I say it is empty, I mean, empty.  No coputer icon in the device manager.  Nothing, nada, zilch.

Dear gbrayut,

I tried this and it said that it needed my original cd.  I put it in and it said that my cd is the wrong version.  Can't figure out why: it's the same cd I used to install it. I will try a cd from work this afternoon and let you know how that goes.

Still open to suggestions,

Bill
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
shard26Commented:
Start / Run / type msconfig / OK / Services
Verify that the Hide all Microsoft Services checkbox is NOT checked.
Scroll down the list of services until you see the service named Plug
and Play and make sure it is checked.

If that didn't help...

-Right-click My Computer / left-click Manage. The Computer Management
window appears.
-Click Services and Applications / Services / Standard and scroll down
to Plug and Play.
 Double-click Plug and Play (if a warning dialog box appears, click OK).
 The Plug and Play Properties window appears. Click to change the
Startup Type to Manual,
 and then click Apply (if a warning dialog box appears, click OK).
-Under the Service Status section of the Plug and Play Properties
windows, click the
 Start button. This will start the Plug and Play service.
 Click OK on the Plug and Play Properties.

2) Check the security permissions (be careful here!):

Start / type "regedit" /
HKLM / System / CurrentControlSet / Enum /

Right click Enum -> Permissions
Set permissions for System -> Full Control.

0
 
shard26Commented:
did you try running windows update?
0
 
revoconnellAuthor Commented:
Dear Helpers,

I've been away for the weekend and have just tried eveyone's suggestion:

(1) To gbrayut: ran "sfc /scannow" and made no difference.

(2) To shard26 on 8/11.  I tried to run msconfig, but got an error message saying that the componet or a part of it was missing.

(3) To shard26 on 8/11: Tried you second set of instructions beginning with right clickon on my computer.  No help.

(4) To shard26 on 8/11: tried your third section on security permissions.  When I right click on Enum, I don't have a menu option entitled "permissions."  All I see is expand, new, find, delete, rename, copy key name.

(5) To shard26 later on 8/11: I am a pretty regular updater.  I will say, however, that my most recent crital update (I believe a security update for IE 6) will not install on my system for some reason.  Somehow I doubt this is the problem, however.

Anyone else have any suggestions???

Bill

0
 
gbrayutCommented:
Well, one more idea: see if it does the same thing when trying to access device manager from the computer management window.

Right click on My Computer and left click on manage or select computer management from the administrative tools menu. There should be a device manager section in there.

You can even try right clicking device manager from the list (or from the view menue) and select show hidden devices. If that doesn't fix it then I don't know what would :-)

Enjoy
Greg Bray
0
 
revoconnellAuthor Commented:
Dear Helpers,

Well, I got it running.  Found the following procedure on Annoyances.com and it worked like a charm:

Start-Run-regedt32.exe (note the missing "i")
Go to HKEY_LOCAL_MACHINE on Local Machine;
Burrow into the registry - SYSTEM/CurrenControlSet/Enum;
Highlight "Enum";
Click on Security-Permissions on Tool Bar;
[Note: on my system, only "Everyone" was in the list, with no permissions]
Click on "Add", Choose SYSTEM from list, click on "Add", Click on "OK";
Toggle on Allow Read & Full Control;
[I also added Administrator to the list but don't know if this matters or not or
if it may be a problem later...]
Click on "OK";
Reboot!

Thanks for your time.

Bill
0
 
ee_ai_constructCommented:
Question answered by asker or dialog valuable.
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now