Solved

Arcserve E8604 error

Posted on 2004-08-10
25
8,840 Views
Last Modified: 2012-06-27
I am unable to backup the Exchange Information Store. I get the following error

This is Arcserve 2000 and Exchange 2000

E8604 Failed to start backup. (DBNAME=dbaexchis, EC=Backup Agent Error -- (331) "Insufficient privilege. Please check user privileges".)

I have read through the manuals and also online at the following http://esupport.ca.com/premium/dtdata/e8604.asp

I have gone through the procedure outlined here. I have created the dbagent and initialised the mailbox. I have checked that the permissions are set and that the service account is set to dbagent which is a Full Exchange Administrator and the primary group is Domain Admins

It backups up using the same account at bricks level but not on the Information Store.

I have tried backing up using the dbagent account and also using the system Administrator account but both give me the same error.
0
Comment
Question by:Milkybar-kid
  • 9
  • 5
  • 3
  • +6
25 Comments
 
LVL 15

Expert Comment

by:Cyber-Dude
ID: 11761467
heh
Did you restart the Server????
;)

The link asks me for user name and password...
In generic, from what I gathered, it is something to do with the unability to read mailbox content due to the fact that the mailbox is locked/dleted...

I guess that you checked for all mailbox lockings and disability. So, in that case, I think it is something to do with an unallowed access to the exchange server from within the ArcServe though it may see the IS. I would check a few things:
1. The total Permission subject - though access with the unfited permissions may drag a difrerent error, in some cases, the AS may understand that message the same way as a disabled mailbox.
2. Check to see for the correct reference, whether it is made properly...

Good luck

Cyber
0
 
LVL 15

Expert Comment

by:Cyber-Dude
ID: 11761506
Heres how to deal with it (look at the ID)
http://www.nmm.ac.uk/collections/displayRepro.cfm?reproID=E8604&picture=0

;)

Cyber
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11761724
LOL - I need a machine gun ...

Here is the content of the CA Page

I am receiving error E8604, failed to start backup, EC=DBagent error - (331).


This error occurs when the specified account used for security on the Exchange server does not have sufficient permissions to backup MS Exchange. Verify the Exchange agent account is a member of the Domain Admins (set as the primary group), Backup Operators, and Administrators groups. The account needs the advanced user rights of Act as part of the operating system, Log on as a Service, and Log on locally. Furthermore, within the Exchange administrator program, the account needs the role of “Service Account Admin” at the Organization, Site and Configuration levels. When submitting a job, right click on the name of the server and go to “Security”. Enter the name of the Exchange agent account in the DomainName\UserName format. For more information on this and other error codes for the Exchange DB-Agent please review document #16040 -

To answer your questions
> 1. The total Permission subject - though access with the unfited permissions may drag a difrerent error, in some cases, the
> AS may understand that message the same way as a disabled mailbox.
The mailbox is not disabled. I can send and receive mail with it.

2. Check to see for the correct reference, whether it is made properly...
I don't understand this comment

When I try to setup the exchange agent login using the username / mailbox alias and password set for the dbagent account I get error 1314

I have looked through all documentation I can find on esupport but against those error codes the information seems out dated.

I have checked through all permissions in the exchange administrator and the active directory and it appears to conform to the requirements.


0
 
LVL 15

Expert Comment

by:Cyber-Dude
ID: 11761903
I need to go somewhere... I be eher later... but heres what:

Try to create a Service account and define it as part of the service account in the exchange, give it all permissions through the AD and try to set that user in the AS and try to access IS again...

Good luck

Cyber
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11761996
I have done all of that when I setup dbagent ...
0
 
LVL 3

Expert Comment

by:bgoins
ID: 11765877
This article might help:
http://www.tek-tips.com/gfaqs.cfm/pid/478/fid/4464

Good luck
B
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 11767420
Looks like you are doing everything correct, perhaps something is going on that is unaticipated.

Put the agent in debug and hopefully the logs will provide the answer.
The Exchange Agent is put into debug via a registry setting.
HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\BrightStor ARCserveBackup\DSAgent\CurrentVersion\agent\dbaexch
With Parameters double click on the Value Debug.
The DWORD editor will popup, change Data: 0 to 1.

Other acceptable data values = 2, 3, 4 (higher value generating the most detail in the log)
***NOTE***Do Not Leave Debug Enabled because the logs can grow very fast.
Result: for Directory/Information store you will find:
dbaexch.log
dbaexch.trc
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11767827
Can someone clarify the username that should be used to submit the job at "My Computer" level which I'm guessing is the place where the security is entered for the IS should be domainname\dbagent
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 11768296
The user name used to submit the job is the user you are currently logged on as and should have adminstratore permissions.

Security to backup an Exchange Server is entered by right clicking on the Exchange Server in the backup window when setting up the job.
0
 
LVL 1

Accepted Solution

by:
stooi earned 250 total points
ID: 11768792
Did you specify the "domain_name\exchange_service_account" in full at the security column for backing up the IS?



0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11770246
In the backup source window inside Arcserve I have the following

#My Computer
             #C:\
             #Exchange (M)
             #Registry
             #Microsoft Information Store
             #System State
             #Microsoft Exchange Server - Bricks Level
#Client Agents
#Preferred Shares\Machines
#Network
#Exchange Organisation

The one that I want to backup I'm assuming is the Microsoft Information Store in "My Computer" right ? - well if I right-click on there I do not get any options for entering security - I do get a security option on "My Computer" Here I have tried "Administrator" "LocalSystem" and "dbagent" as the login names. On the Bricks level if I right click it asks me for security and accorsing to the CA documentation this is where the dbagent comes in to play right ? - But bricks level works so I must have this setup OK. Bearing in mind I'm only doing a bricks level backup because the IS isn't working and it doesn't purge the logs. When I get the IS backup working I will turn off bricks level.

dovidmichel - The user you are referring to is therefore "Administrator" right ? - this will not work.
stooi - Yes I have tried domain_name\Administrator domain_name\dbagent and domain_name\LocalSystem

The logs are not very helpful so I have stepped the level up to 4 so far it gives me:
Backup Agent Error (331) "Insufficient privilege. Please check user privileges"

0
 
LVL 104

Expert Comment

by:Sembee
ID: 11772851
If you haven't already noticed, Arcserve has a dreadful reputation in the Exchange world. One Exchange MVP even puts it as "Arcserve is a great backup tool, but a very poor restore tool".

You are doing Brick Level backups. Which ever account you are using needs to have access to every mailbox specifically. In Exchange 200x the domain admin accounts are specifically denied access.
However brick level backups are a bad idea. They are slow, inefficient, a waste of tape space and totally useless in a diaster recovery scenario.

Simon.
0
Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11774061
Thanks for the comments which I agree with wholeheartedly but you have misread the thread. I know that bricks level is a bad idea. I quote from my previous comment in this post "When I get the IS backup working I will turn off bricks level"

However bricks level works - It is the Information Store level that is that is not backing up.
0
 
LVL 15

Expert Comment

by:Cyber-Dude
ID: 11774623
Back....

I guess non of this helps you...

Lets get through this:
The software message is that the IS is locked or deleted... i.e. it cannot see the IS. Did you try to access the IS manually? (If you see all configs, there might be amislead to the client)...

Hmmm....

Is there a place where such configs are taking place other than the Exec software it-self? Let me check for that... that might be interesting because, there is a good chance that you use some sort of a pre-fix to you config thus scrumbling propper connection...

Cyber
0
 
LVL 15

Expert Comment

by:Cyber-Dude
ID: 11774894
Try to backup IS using NTBackup and scheduale it to run just right after the veritas backup finishes (without the IS)...

Can you get that backed up using the MS software (just for the interest)...

Cyber
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11774957
What on earth are you talking about ?
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 11775366
Perhaps this will help.

Preparing the Exchange Server for the Backup Agent
If you wish to use the Backup Agent to back up individual mailboxes and
folders, you must first prepare the Microsoft Exchange Server for the Backup
Agent by completing the steps in this section.
The following is an overview of the steps required to prepare your Exchange
Server for backups of mailboxes and folders:
1. Create a Backup Agent Service Account on the Windows 2000 server. This
account must be created as described in the following sections.
2. Create an Exchange mailbox for the Backup Agent Service Account.
3. Assign the appropriate permissions to the mailbox.
4. Make sure that the Exchange Client is installed on the machine on which the
Backup Agent is installed.
Creating the Backup Agent Service Account and Mailbox on Windows 2000
To create the Backup Agent Service Account and Mailbox:
1. Open the Administrative Tools program group and select Active Directory
Users and Computers on the domain controller.
2. Expand the tree from the console and click Users.
2. Click Action, and then click New and User.
3. Enter a username and password. For this document, the sample username
DBAGENT is used.
4. Select the option: Password never expires.
5. Click Next.
6. Check Create an Exhange mailbox. Select the desired storage group and
database on the local server. Enter a unique alias name for the mailbox. The
alias name must not be a prefix of any other mailbox. Click Next.
7. Click Finish.
8. In the Active Directory Users and Computers, Click User account, Action,
and then Properties.
9. Click Members Of tab to ensure the user is a member of Administrators,
Domain users and Backup Operators groups.
10. Click OK to exit.
Assigning Permissions for the Service Account
To assign the appropriate permissions for the service account:
1. Open the Exchange System Manager. Right-click the Organization name and
select Delegate Control. The Exchange Administration Delegation Wizard
appears:
2. Add the service account with the Exchange Administrator role to Users and
groups.
3. Click Next, then Finish.
 
By the way did you enable debug?
0
 
LVL 3

Expert Comment

by:bgoins
ID: 11775600
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11775923
dovidmichel - thanks for the info but that is the Arcserve userguide and I have already followed those steps meticulously. I have enabled debug but the error message was basic so I have moved it to level 4 - I will report back.

bgoins - thanks but I had already found those and I don't think there was nything not already posted.

I will re-iterate the bricks-level backup for which the dbagent account is created DOES work. It is the Information Store in the "My Computer" area that is not working.

One thing that I cannot be certain of is whether I used domain_name\username for the security but I'm pretty certai that I did.

Anyway I have doubled checked against the suggestions and brought the backup schedule forward this evening so I will know pretty soon if it has worked.

Thanks for all the help guys - will keep you posted.
0
 
LVL 1

Expert Comment

by:nickymo
ID: 11779053
Hi see below,

E8604 failed to start restore (dbname=dbaexchis ec=backup agent error 331 insufficient privelege, please check user privileges)

Ensure that you are inputting a valid Administrator account that has Service Account rights in Exchange 2000. Try entering domain name\username as the security format instead of just the username


:)
0
 
LVL 1

Expert Comment

by:stooi
ID: 11783078
Hey thanks, actually we had the exact problem at one of our clients' a month ago and that was the resolution after a few days of troubleshooting.

0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11783363
It's often the case that the resolution to these problems is right there in your face and a comment like yours without the bells and whistles is enough to jog the mind. Cheers
0
 

Expert Comment

by:Sniper_eyes
ID: 11978599
Confirm that you are able to backup your IS using NTbackup to a file or to a tape to confirm if the
backup is successful.I have seen this issue to arise also due to the fact that there could be a
corruption in the exchange database.Perhaps you can confirm running ISINTEG and checking
the consistency....

If you could post the dbaexch.trc and dbaexch.log contents - would also be helpful,maybe you
missed out something from the logs...

L8r...
0
 
LVL 1

Author Comment

by:Milkybar-kid
ID: 11979628
Thanks but this is all done and dusted. You will see that there is an accepted answer.
0
 

Expert Comment

by:MF_
ID: 12073317
#My Computer
             #C:\
             #Exchange (M)
             #Registry
             #Microsoft Information Store
             #System State
             #Microsoft Exchange Server - Bricks Level
#Client Agents
#Preferred Shares\Machines
#Network
#Exchange Organisation

just a small note here, but don't backup the (M) drive, its bound to cause errors
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Hardware RAID vs OS RAID 20 102
Robocopy questions 45 129
Windows 2012 Auto Grow Volume 11 56
VMWare: Measure the disk usage of my VMs 6 72
Sometimes the best way to deal with an infected computer is to boot from external media and run your tools from there.  The reason you may wish to do this really depends on the infection.  Some malware is so recalcitrant that no matter what you do i…
Solid State Drive Performance Tips: Solid state storage technology is now a standard.  After testing and using several different brands and revisions of SSD's over the years I have put together a collection of tips,tools and suggestions that I ha…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now