Improve company productivity with a Business Account.Sign Up

x
?
Solved

SelfSSL Help

Posted on 2004-08-10
12
Medium Priority
?
456 Views
Last Modified: 2008-01-16
I recently installed SelfSSL (www.virtualwin.com/selfssl) after a few attempts I managed to install it however I have a problem.

When I first loaded my site it came up with the security warning the address was http://localhost.
Then the page said "can't show please use https://...."
I changed the address to https://localhost in the internet options and reloaded I.E
The little symbol in the corner moved as though the page was loading but nothing happens, it just keeps "loading".

Sometimes it will load the page with https:// but doesnt give the cecurity warning.

Any ideas what's causing this delay?
0
Comment
Question by:Kegan5
  • 7
  • 5
12 Comments
 
LVL 8

Expert Comment

by:adg080898
ID: 11773205
http://www.virtualwin.com/selfssl doesn't work today. Shows come catchall page. Is it correct?
0
 

Author Comment

by:Kegan5
ID: 11792374
I don't know why that's coming up,it should be working. :(
Anyhow the problem I have now is when I access my site with HTTP://localhost there is a message saying please use https as ssl is installed...so I type in https://localhost and the site keeps loading and loading but doesn't actually load? any ideas? It doesn't time out either.
0
 
LVL 8

Expert Comment

by:adg080898
ID: 11797772
Try using telnet to do the request, so you can see what the server is sending:

Click Start
Run
telnet
open localhost 443
GET https://localhost/ HTTP/1.0
[press enter again]

Note that you can't backspace when typing the "GET https..." part, if you make a typo you must start over (close telnet and restart instructions above).

The server should produce a page, probably a page complaining that your request wasn't a proper HTTPS request. What happens?
0
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

 

Author Comment

by:Kegan5
ID: 11798011
Am I supposed to wait after the line "open localhost 443" because nothing happens it's like it's still loading...and if I try to continue with the GET line it overwrites the 1st line "welcome....?
0
 

Author Comment

by:Kegan5
ID: 11798013
apologies I've just realised the link above should be www.visualwin.com/selfssl I'm really sorry!
0
 
LVL 8

Expert Comment

by:adg080898
ID: 11798345
Yes, it makes a mess on the screen.. don't worry about it. Just start typing the GET...
0
 
LVL 8

Expert Comment

by:adg080898
ID: 11798374
The point of this is to see what the server sends you when you connect to the SSL port and send a request.

Try connecting to a real ssl site and typing some garbage GET line and hit enter twice. Telnet will show you the raw data send from the host.

Try this and you'll see what I mean:

in telnet:
open www.winguides.com 443
GET https://www.winguides.com/security/password.php HTTP/1.0
[hit enter twice]

Just start typing GET immediately after hitting enter on the open command. I know, it sends "bad request" page. The point is it responds to the request.
0
 
LVL 8

Expert Comment

by:adg080898
ID: 11798386
I have seen internet explorer get all messed up when the response does not have valid headers. Sometimes, if the response has invalid or unrecognizable headers, internet explorer will just sit there. Viewing source sometimes shows garbage, sometimes nothing happens when you view source! :)

This is why I suggest checking the response it sends.
0
 

Author Comment

by:Kegan5
ID: 11798413
Ive done that telnet thing but it still wont do anything...just keeps looping
0
 
LVL 8

Expert Comment

by:adg080898
ID: 11798800
Go into a command prompt and type netstat -a.

You should see several things in a LISTENING state.

It shows a "name:port" list. Name will be your local computer name.

Is there an entry LISTENING on port 443?
0
 

Author Comment

by:Kegan5
ID: 11799500
It doesn't say port 443 but it has something about https go to the link below it's a screenshot.
http://web.1asphost.com/kegan5/cmd.JPG
0
 
LVL 8

Accepted Solution

by:
adg080898 earned 375 total points
ID: 11803274
Try https://LappyK/

Does that make a difference? It could be because the SSL is expecting to be a different name. You might have to set the internet domain for the server to "be" somewhere in selfssl config. It uses computer name by default.
0

Featured Post

Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

By following these Magento e-commerce development tips, you can increase your website's conversion and profitability. Read this post for more details.
Magento is the best technology for eCommerce start-ups as it offers the technical expertise and visual appeal to create a store that pulls sales and earns high ROI (Return on investment).
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…
The is a quite short video tutorial. In this video, I'm going to show you how to create self-host WordPress blog with free hosting service.

589 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question