Solved

Cisco router (2501) help.  Cannot resolve local or WAN host names.

Posted on 2004-08-10
19
982 Views
Last Modified: 2008-02-01
Hi. This question is in regards to my home network. I am on cable.
The diagram of my network can be viewed at http://mvpbaseball.cc/network.jpg
The diagram is of vital importance to look at first, as this question is probably going to confuse you by the time you're done (hard to word it right, so much crap)


I currently have 3 routers in my home LAN.
-basic cheapy cable router (connected to cable modem of course)
-Two Cisco 2501 routers ( I call them 2501a and 2501b).
-3 clients.

I have 3 networks so to speak:

My Cable router's external IP gets all the necessary info from my ISP.  The internal IP is set to 192.168.1.1.  My cable router has a built in switch, into where my first cisco router plugs into (2501a)

2501a's e0 IP address is 192.168.1.40.       (The e0 interface of 2501a is connected to my cable router as said.) Now the serial interface of 2501a is set to 192.168.0.5 and is connected to my second cisco router's serial interface  (router 2501b) . 2501bs serial interface has an IP of  192.168.0.6.     The e0 interface of 2501b is 192.168.2.1

Clients:

I have 2 clients in the 192.168.1.0 network. They are using the 2501a's Ip address as their gateway (which is 192.168.1.40).

I have 1 client in the 192.168.2.0 network. He is using router (2501b) 192.168.2.1 as his gateway.

All of my clients can ping WAN addresses by IP. They can also all ping each other by IP.  So the routing is working properly (thank god for RIP)



The problem:
Name resolution refuses to work at all.  None of my clients can resolve names locally. To access another computer in my LAN, I have to type the IP instead of netbios name.  Furthermore, none of my PCs can resolve host names on the WAN either. I have to enter in IPs manually when surfing the web.  I tried to ping my ISP's DNS server and it does not respond.  However, I am positive my ISPs dns server is fully functional.  Here's why:


Notes:
*If I connect a client directly to my cable router (192.168.1.1) and use the cable router as the client's gateway, everything works. You are then able to ping WAN or local computers by host name.  You are also able to ping my ISPs DNS servers.

*There are no ACLs on any of the routers.

help!

0
Comment
Question by:dissolved
  • 11
  • 8
19 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 11762420
On both routers add:

router(config)#ip forward-protocol udp 137
router(config)#ip forward-protocol udp 138
0
 

Author Comment

by:dissolved
ID: 11762563
Thank you jrmoore, I will try that. I will try that at lunch time (im at work, no access to it from here).

That should take care of local name resolution right?  What should I do about not being able to ping my DNS server from the cisco routers?
Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11763227
Your cable modem needs to know about the other networks. Do you have a static route in it for the other subnets, pointing to the 2501?
You might need to use NAT on your 2501, depending on your cable router. What make/model is the cable router?

On 2501a, do you have a default gateway:

ip route 0.0.0.0 0.0.0.0 192.168.1.1  <-- the cable router

and on 2501b, do you have a default gateway:

ip route 0.0.0.0 0.0.0.0 192.168.0.5  <-- serial 0 of 2501a

0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 

Author Comment

by:dissolved
ID: 11763576
My cable router is a Sohoware NBG800
In my cable router, I have a default route of
dest: 192.168.2.0
gateway: 192.168.1.40
mask: 255.255.255.0
metric  1

The above route is needed for the 192.168.2.0 in order for the above network to access the WAN. Before I entered the above static route, the 192.168.2.0 network could not ping the WAN.  But after I added it, all was well.

To answer your question about the static routes in the Cisco:

2501a:
has a route of   0.0.0.0 via 192.168.1.1

2501b:
has a route of 0.0.0.0 via 192.168.0.5

Both routes are R* and are not static.

Like I said, the routing is working fine. Every host can ping any network device in the network. And every host can ping the WAN (by IP address). The problem seems to be occuring when I try to query the ISP's DNS server (68.34.76.6) from a router or host behind a cisco router.

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11763637
Try using the cable router's ip as the dns server..
0
 

Author Comment

by:dissolved
ID: 11763682
Tried that. Did not work.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11763917
Can you ping 198.6.1.2 from any host behind the router?

Can you ping anything outside the local networks?

You may have to setup NAT on the Cisco so that everything appears to the cable router as a 192.168.1.x host.

0
 

Author Comment

by:dissolved
ID: 11767688
lrmoore:

I can ping every host in my network from behind any router.

I can also ping any address on the WAN (as long as I do it by IP, not host name)

The traffic is finding the 192.168.1.0 network ok right? If it wasnt, I would not be able to ping public IPs.

I can provide a sh conf or sh run if you like.
thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11767715
Go ahead and post sh run
0
 

Author Comment

by:dissolved
ID: 11767743
lmoore, thanks I showed it at the bottom

For anyone just joining this post:  I am having problems querying my ISPs DNS server from behind the Cisco routers.  Here is my network diagram again if you need to refer to it  http://mvpbaseball.cc/network.jpg

SH RUN of 2501a

routerA#sh run
Building configuration...

Current configuration : 947 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname routerA
!
no logging on
enable secret 5 $1$KAWH$siTZiZob/9BtCtLubuxav/
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip host 2501b 192.168.2.1
ip host dissolved 192.168.1.79
ip name-server 192.168.1.1
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 description Connected to LAN1 (switch)
 ip address 192.168.1.40 255.255.255.0
!
interface Serial0
 description connected to RouterB
 ip address 192.168.0.5 255.255.255.0
 encapsulation ppp
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.1.0
!
ip kerberos source-interface any
no ip classless
no ip http server
!
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 14051D05050A7C7D72
 login
!
end
---------------------------------------------------------------
SH RUN of 2501B

RouterB#sh run
Building configuration...

Current configuration : 854 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RouterB
!
logging rate-limit console 10 except errors
enable secret 5 $1$Kw7U$zhHM0md/zOC0neIBSIz2S.
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 description connected to WAP
 ip address 192.168.2.1 255.255.255.0
!
interface Serial0
 description connected to ROuterA
 ip address 192.168.0.6 255.255.255.0
 encapsulation ppp
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.2.0
!
ip kerberos source-interface any
no ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 7 083343400017534144
 login
!
end
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 11767949
You need to enable ip classless:

>no ip classless

Can you post result of 'sho ip route'
0
 

Author Comment

by:dissolved
ID: 11768720
What is ip classless?

Anyway, here is my sh ro from both routers


2501a (routerA)

routerA#sho ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

     68.0.0.0/32 is subnetted, 1 subnets
R       68.33.252.0 [120/2] via 192.168.1.1, 00:00:27, Ethernet0
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.0.0/24 is directly connected, Serial0
C       192.168.0.6/32 is directly connected, Serial0
C    192.168.1.0/24 is directly connected, Ethernet0
R    192.168.2.0/24 [120/1] via 192.168.0.6, 00:00:01, Serial0
R*   0.0.0.0/0 [120/1] via 192.168.1.1, 00:00:28, Ethernet0



---------------------------------------------------
2501b (routerB)
RouterB#sho ro

RouterB#sho ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.0.5 to network 0.0.0.0

R    68.0.0.0/8 [120/3] via 192.168.0.5, 00:00:24, Serial0
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.0.0/24 is directly connected, Serial0
C       192.168.0.5/32 is directly connected, Serial0
R    192.168.1.0/24 [120/1] via 192.168.0.5, 00:00:24, Serial0
C    192.168.2.0/24 is directly connected, Ethernet0
R*   0.0.0.0/0 [120/2] via 192.168.0.5, 00:00:24, Serial0

Thanks again
0
 

Author Comment

by:dissolved
ID: 11769079
More stuff to add:

I tried to ping my ISP's DNS server (68.34.76.5) and an interface on my router responded:

192.168.1.40 (cisco router) responded : host unreachable



Yet when I ping my cisco routers gateway, it responds
c:>ping 192.168.1.1 (cable router)
Reply from 192.168.1.1

So the traffic is being routed correctly out of my cisco router, to my cable router. Should I add a static route to my DNS server in the Cisco router?  
Something like:   config t#  ip route 68.34.76.5 maskhere 192.168.1.1
What would the actual syntax be?
Thanks
0
 

Author Comment

by:dissolved
ID: 11769082
*NOTE* The above pings were done from a client. NOT from a router
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11769392
Did you change the ip classless statement?
0
 

Author Comment

by:dissolved
ID: 11771604
I am unsure of what Ip classless means and what I should change it to?
Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11771819
Where the ip classless configuration command falls within the routing and forwarding processes is often confusing. In reality, IP classless only affects the operation of the forwarding processes in IOS; it doesn't affect the way the routing table is built. If IP classless isn't configured (using the no ip classless command), the router won't forward packets to supernets.
This is the essence of classful routing: If one part of a major network is known, but the subnet toward which the packet is destined within that major network is unknown, the packet is dropped.

To change it:

router(config)# ip classless

0
 

Author Comment

by:dissolved
ID: 11774478
Im going to try the ip classless command when I get off of work. Thank you.

0
 

Author Comment

by:dissolved
ID: 11778857
you da man lrmoore
0

Featured Post

Active Directory Webinar

We all know we need to protect and secure our privileges, but where to start? Join Experts Exchange and ManageEngine on Tuesday, April 11, 2017 10:00 AM PDT to learn how to track and secure privileged users in Active Directory.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ACL Logging Optimization 7 46
Some issue on SecurityCRT 5 33
DHCP Server 14 100
ASA 5505 not passing traffic to Netgear router 22 49
Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question