Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

gzip is not working with the mknod command

Posted on 2004-08-10
3
Medium Priority
?
639 Views
Last Modified: 2013-12-26
I am an oracle DBA and I am trying to compress my export file as the file is being created. I am trying to use the mknod command with the gzip command to compress the export file as it being created.  It appears as though I have everything setup correctly, but for some reason it does not compress the output file.  the output file is  "1 gig" in size.  Is there some sort of buffer that needs to be factored in.
/etc/mknod test.exp p
/usr/contrib/bin/gzip < test.exp > systest_exp &
nohup exp test/test1 parfile=/opt/backup/test.par
0
Comment
Question by:dedean01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 11

Expert Comment

by:griessh
ID: 11762962
Hi dedean01,

Questions:
Could you please elaborate on "does not compress the output file". What is the error? Does it create anything? Does it do anything?

A few things to check:

- Some versions of gzip can only deal with files < 2GB.
- Is there enough space on your file system (run 'df -k .')

======
Werner
0
 

Author Comment

by:dedean01
ID: 11763436
/ :df -k .

/opt/backups           (/dev/vg01/lvol3       ) : 51034568 total allocated Kb
                                                  21013008 free allocated Kb
                                                  30021560 used allocated Kb
                                                        58 % allocation used

There is plenty of space on the filesystem and it does not give me an error.  If I use the gzip command without the mknod utility then it works fine.
"/usr/contrib/bin/gzip  test.exp"

0
 
LVL 29

Accepted Solution

by:
MikeOM_DBA earned 200 total points
ID: 11765153
Quote: - Some versions of gzip can only deal with files < 2GB.

A work-around is to use cat:

/etc/mknod test.exp p
cat text.exp|/usr/contrib/bin/gzip -c > systest_exp &
nohup exp test/test1 parfile=/opt/backup/test.par
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction: Load and Save to file, Document-View interaction inside the SDI. Continuing from the second article about sudoku.   Open the project in visual studio. From the class view select CSudokuDoc and double click to open the header …
Introduction: Hints for the grid button.  Nested classes, templated collections.  Squash that darned bug! Continuing from the sixth article about sudoku.   Open the project in visual studio. First we will finish with the SUD_SETVALUE messa…
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question