Solved

Win2000 machines login and browse fine, but Win98 machines cannot browse at all.

Posted on 2004-08-10
14
690 Views
Last Modified: 2010-05-19
Hi,

I'm sitting here with a big problem. I have here a Windows 2000 server with active directory and 15 workstations connected to it. Recently (Thursday) Pastel was upgraded on the server and Pervasive SQL database was loaded on the server. This weekend though we had a power failure and once our server came up again all the Windows2000 machines can login to the server with no problem, but no Windows98 machine can login to the server. I have moved the Windows machines to a workgroup with the same name, but can still not browse the network.

Our Windows 98 machines cannot login to the server saying there is no domain server to validate the password. I have found that none of the machines including the Windows2000 machines will browse the network. I can however ping any machine by name as well as IP, from any workstation as well as the server. Strangest thing is that browsing from the server on the network is no problem.

I have LANSuite 2003 running on the server with SMTP, POP3 and a Proxy server setup on it. Disabling the LANSuite and the pervasive SQL database does not make any difference. We are running static IP's.

I hope this is enough detail to get help and hope that someone can help me with this quickly, the company is losing thousands as i type.

I have thought that it might be the master browser that is giving trouble, but wanted a second opinion before i spend another 6 hours trying to get it right and not win.

Thanks in advance

0
Comment
Question by:Nettron
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11763034
>>Win2000 machines login and browse fine, but Win98 machines cannot browse at all.

>>Our Windows 98 machines cannot login to the server saying there is no domain server to validate the password. I have
>>found that none of the machines including the Windows2000 machines will browse the network.


These are contradictory, please clarify.
0
 
LVL 2

Author Comment

by:Nettron
ID: 11763188
Ok, The Windows2000 machines can login to the server and they can access their Mapped drives no problem, but if you open your "Network Places" you cannot browse the network.

On the other hand it looks that the Windows 98 machines cannot do any of anything. They cannot login to the domain because it tells me there is no server to validate the password. When i change the 98 workstation to a workgroup with the same name, the machine can locally login, but cannot browse the network and therefore not get to the server.

Just to add somethin strange......one of the Windows2000 workstations are running a satelite tracking system for our trucks and one of the Win98 machines has a mapped drive to that machine in order to run the app. Although this Win98 machine cannot login to the server or browse the network the drive mapping is mapped and the app is working........

Let me know if i can provide more detail.
0
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11763354
http://www.comptechdoc.org/os/windows/ntwsguide/ntwsnfinding.html

Browser registry settings on the workstation are at:

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters



The value:

MaintainServerList - If value is:
No - Workstation will not be a browser
Yes - The workstation may be a browser or backup browser.
Auto - The workstation may become master, backup, or potential browser.
IsDomainMaster - Default is No. If set to Yes, only a PDC can win the election over the workstation with this setting.

Also verify that WINS is running properly on your Server.  Try typing "nbtstat -r" at a command prompt, and see if there are any entries.

0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 2

Author Comment

by:Nettron
ID: 11775031
I have set all machines to NO - for a browser and only made the Server the ISDomainMaster and the Win2000 Workstation running the satelite tracking system the backup browser......

It made no difference.....

I spend 8 hours on this problem today speaking to quite allot of people even had Microsoft on the line for more than an hour and logged an incident with them......I received a patch from them for the Windows98 Workstations, but still the problem remains....
0
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11775064
what about "nbtstat -r"?
0
 
LVL 2

Author Comment

by:Nettron
ID: 11775749
I have just now restored a clone image i made of the server last week onto a new server drive, I ran the nbtstat -r on the workstation and got the following. The workstation can logon repeatedly with no problem, I will now replace the old drive and return with the nbtstat -r that i get from the problematic machine.

Thios is what the working workstations give me....(Win98 logging onto the restored server)
Resolved by Broadcast = 3
Resolved by Name Server = 0
Registered by Broadcast = 5
Registered by Name Server = 0

Netbios Name Resolved by Broadcast

VANWETTENS <1B>
VANWET
VANWETTENS <00>

b.t.w. I have found that any machine that has not logged onto the server after the problem can do so ONCE and after a restart will not login again....



0
 
LVL 2

Author Comment

by:Nettron
ID: 11775905
Strange....I get exactly the same with nbtstat -r on the machine when it does not want to login as when it does login to the server with the restored clone drive.
0
 
LVL 15

Accepted Solution

by:
adamdrayer earned 500 total points
ID: 11776530
0
 
LVL 2

Author Comment

by:Nettron
ID: 11782011
Apparantly it's the SMB (Server Message Block) signing of Windows 98 that is causing the problem. I have received a document and patch from Microsoft for this. Although it's a bit late, I have rebuild the server last night and all is working now again with no problems, if it ever should happen again at least i know what to do now.

Thx for your input Adam and your time spent. I have accepted your answers becuase you helped get me on the right track.
0
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11782344
wow thanks!  Hey could you point me to a kb article or something so that i can understand what the problem was and how to help other people fix it in the future?  Onlt if you're not too busy
0
 
LVL 2

Author Comment

by:Nettron
ID: 11782483
Sure, no problem, here's all the topic related kb articles i have related to the problem.

230545

Q230545

Q323466

Q323455

Disable SMB signing on the DC (similar to Q822900)

Q811497

0
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11783686
So if you don't mind explaining, exactly what about your network was misconfigured and how did you go about changing it?  You rebuilt the server?  what do you mean by that?

Thanks again...  I should give you back some points for all these questions.
0
 
LVL 2

Author Comment

by:Nettron
ID: 11788916
Microsoft could not give me an exact answer at the time of my deadline. I Loaded a clone image of the drive back onto the server and restored the latest Backup. One a second drive offcourse, tested it and all is fine.

Microsoft tells me that the kb articles that I gave you is where my problem is. I have not tested it because I just could not wait. Microsoft said they would call me within an hour (before they returned with the kb articles)....2 hours later I loaded the clone image and did the restore of the backup. I did not want to do that innitially because Pastel upgrade was loaded onto the server, but I managed to do everything in less than 2 hours.
0
 
LVL 15

Expert Comment

by:adamdrayer
ID: 11789880
awesome.  thanks.
0

Featured Post

Don't miss ATEN at NAB Show April 24-27!

Visit ATEN at NAB Show to learn how our "Seamlessly Entertaining" solutions deliver fast, precise video streaming without delays for the broadcasting and media environment. ATEN will showcase its 16x16 Modular Matrix Switch (VM1600) and KVM Over IP Solution (KE6900 series).

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Greetings, Experts! First let me state that this website is top notch. I thoroughly enjoy the community that is shared here; those seeking help and those willing to sacrifice their time to help. It is fantastic. I am writing this article at th…
Resolve DNS query failed errors for Exchange
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question