Improve company productivity with a Business Account.Sign Up

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7633
  • Last Modified:

Can't establish connection trying to connect to FTP using Core from behind Linksys BEFW11S4 router

I have a client accessing an FTP from behind a Linksys router BEFW11S4. I have forwarded port 22 which is the one used in this case. They are using FTP Core lite. I have even tried to open the FTP at the address bar in IE. But neither will connect.
I get the error Can't establish connection ....

Any suggestions?
1 Solution
FTp is port 21
If port 22 is correct you can try to ping on that port ie. ping If you use IE and try to use FTP it will default to 21
Your server would also need to respond on 22.

Looking at the Core FTP Lite specs, I do not see a way to configure an alternate port though. So, the problem is still most likely the incorrect port number.
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

FTP is 20 and 21...for active ftp sessions.

If the FTP server is using "Passive FTP" you may have addtional issues.

Passive FTP sets up its intial session over 21 but then specifies an addtional dynamic port for data transmission...if this is the case you may need to setup a Trigger port to allow all traffic from/to that host (or your router may have an option to specify an FTP server)

Here is a web site that will detail the difference between Active and Passive FTP.
rembocanoeAuthor Commented:
On Core Lite when you chose SSH/SFTP it sets the default port to 22.
It appears to be connecting. I'm getting an Access denied.

Initialized AES-256 client->server encryption
Initialized AES-256 server->client encryption
Access denied
No supported authentications offered. Disconnecting
Unable to initialize SFTP: 潣汵⁤潮⁴潣湮捥t (sftp not enabled?)

I've remove the router from the equation. Still same response.

1. Can you connect to other FTP sites of the same type using the same host?
2. What ftp site seems to be the problem (If public, pls give full connection details).
3. SFTP/SSH is different to FTP, you need to know the server you wish to connect to uses. SFTP will not be able to connect to an FTP site.
4. Try telnetting to a different working server (DOS Prompt) eg:
telnet 21
you should get the prompt:
220 acg-co-01 Microsoft FTP Service (Version 5.0)
If not, it is 99.956% likely to be something at your end
Try telnetting to your problem server, see if you get any response.  Post the error messages (if any).
Take a look here:

The client can specify what port to connect to.  FTP servers use port 21 by default, BUT they can be configured to run on any other port as long as that port isnt being used by another service.  What FTP server are you using?
rembocanoeAuthor Commented:
Thanks Every one for your suggestions!!

After Many Many trial and errors. It came down to the fact that it only took lowercase as the password. (it was insisted that the password was uppercase and would not work any other way.) We wont mention WHO Said upper and WHO said lower!!

:) awesome, you have to love fixes like that! Make sure you tell the powers that be some long winded fix and mention the hours of brain draining stunts you performed! LOL
PAQed with points refunded (500)

Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now