Solved

Local .cfm pages coming up blank in browser.

Posted on 2004-08-10
9
416 Views
Last Modified: 2013-12-24
I was working in dreamweaver and tryed to preview what i was working on in browser.

When the page came up. It was all blank. And in the status bar it said "done". I checked services and Coldfusion was running (all 3 services). IIS was running. I restarted the computer. Same problem. I restared a bunch of services. Same problem.

Any .cfm pages on my machine (localhost) are not showing up all i get is a blank screen in the browser. Html pages work fine.
Even the coldfusion administrator isn't showing up. Only a blank screen.

I did install the java plugin a bout 2 days ago. But then i uninstalled it and it didn't make a difference.

Im running CF 6.1 as a standalone server. So my , localhost prefix looks like "localhost:8500" and the root folder is C:\cfusionmx\wwwroot\

This is what i get when i view the source.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
<BODY></BODY></HTML>

Any ideas what my problem is?
0
Comment
Question by:Silverwolf90
9 Comments
 
LVL 10

Expert Comment

by:Mause
ID: 11769954
Hi

Are you setting the meta tag yourself?

<META http-equiv=Content-Type content="text/html; charset=windows-1252">

try to remove it or make it

<META http-equiv=Content-Type content="text/html; charset=ISO-8859-1">
0
 

Author Comment

by:Silverwolf90
ID: 11770011
Hmm....when i check my code, its already like the second one.

However when i test it out in browser it comes up as the first one.

I just found out one more thing. I can seem to type anything after localhost:8500 and nothing comes up. Not even an error.

So the same thing happens when i type http://localhost:8500/asdfagjkl;asdf as when i type http://localhost:8500/index.cfm

I don't think it would do anything thing with my coding however because even the CF administrator is having the same problem.
0
 
LVL 21

Expert Comment

by:pinaldave
ID: 11770112
well, this happened to me once. The page I had refered was excellent help to me that time. I am pasting you the solution from that page and also the link.
When this happened to me (CFMX 6.1, Win2000, IIS 5.0), I found that the cause was having the IIS 5.0 "Default Web Site" virtual directory missing (or in some cases just turned off). Instead of an error message, I received a blank page with a basic header and empty 'body'. Adding (and enabling) the standard IIS "Default Web Site" (to C:\Inetpub\wwwroot\) corrected the problem. In my case, the blank pages were displayed for both CFM and HTML pages, but since I was so focused on my CFM application; this appeared to be a CFMX issue instead of an IIS issue.
http://www.macromedia.com/cfusion/webforums/forum/messageview.cfm?catid=2&threadid=861835
Regards,
---Pinal
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Silverwolf90
ID: 11770160
Hmmm....im not exactly sure if i did what i was supposed to do.

but what i did.

Went into IIS. I then clicked "default web site." It was started. Then i went into properties and changed the home directory to c:\cfusionmx\wwwroot\

but i still get a blank page....
0
 

Author Comment

by:Silverwolf90
ID: 11770188
oh and another thing, it seems to be just .cfm pages because .html pages seem to work fine
0
 

Author Comment

by:Silverwolf90
ID: 11777518
ok well I finally did the right thing.

I reinstalled CFMX and now everything works fine.....
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 12003105
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In our day to day coding, how many times have we come across a necessity to check whether a URL is a broken link or not? For those of you that answered countless and are using ColdFusion like myself, then this article is for you.  It will show yo…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now