• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 500
  • Last Modified:

Cannot run my exe in shtml files ?

I create an shtml file with the followings SSI commands

<!--#config cmdecho="ON" -->
<!--exec cmd="ping 127.0.0.1" -->
<!--exec cmd="temp.exe" -->
( temp.exe is an self-written exe files )

The browser returns

  Invalid SSI Tag
  The CMD option is not enabled for #EXEC calls

Have I missed something to set up ?
Please help

Barry
0
barrytwy
Asked:
barrytwy
  • 3
  • 2
1 Solution
 
Joakim_Commented:
You must use this to run EXE-files:
<!--#exec cmd="Path_to_file With_params" -->

For more information, you should probably read this article: http://www.ssi-developer.net/ssi/ssi-exec.shtml
0
 
Joakim_Commented:
I don't know much about SSI, but to me, it looks like you forgot the "#"s.
0
 
ThogekCommented:
Sounds like the system account used by the web server may need to have administrative access (or, at least, execute permissions) on the web server in order to run some commands via a exec cmd SSI.  (See Note #2 at the bottom of the page whose URL Joakim gave above.)

Keep in mind that use of this exec cmd feature can be dangerous from a security perspective, if you're not very careful as to what commands you allow, who has access to modifying your content, etc.

More at
http://support.microsoft.com/default.aspx?scid=kb;EN-US;203064
http://support.microsoft.com/default.aspx?kbid=233969
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
ThogekCommented:
Has this question been resolved?
0
 
ThogekCommented:
I doubt that Joakim's comment was the answer, as if it were simply a case of missing "#"s, then the system would not have interpretted the comment tags as SSIs, so no SSI error message would have occurred.  And the question did cite an SSI error message ("Invalid SSI Tag.  The CMD option is not enabled for #EXEC calls") which specifically suggests that EXEC-CMD SSIs have not been enabled for the Web server in question.  (See http://support.microsoft.com/kb/233969)

But, since barrytwy (the Asker) hasn't returned, we can't be sure what's going on from his perspective...
0
 
moduloCommented:
PAQed with no points refunded (of 80)

modulo
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now