Can't view any table in phpMyAdmin, MySQL shows an error of 'Got an error reading communication packets' HELP!!! :-)

Hi,

I'm running MySQL 4.0.20-log and PHP Version 5.0.0-dotdeb on Debian 3.0R2. Everything works fine untill i try and browse any table in phpMyAdmin. All i get is a blank page saying "The page cannot be displayed". When i check the MySQL logs i'm getting the following errors :

040811 10:54:19 Aborted connection 9 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:19 Aborted connection 10 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:19 Aborted connection 11 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:19 Aborted connection 12 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:26 Aborted connection 14 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:26 Aborted connection 15 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)
040811 10:54:27 Aborted connection 16 to db: 'dads' user: 'root' host: `localhost' (Got an error reading communication packets)

This means absolutely nothing to me, so why should there be errors on a new installation like this? does anyone know how to fix it, its driving me mad! ;-)
matd_Asked:
Who is Participating?
 
ee_ai_constructConnect With a Mentor Commented:
PAQed, with points refunded (170)

ee_ai_construct (replacement part #xm34)
Community Support Admin
0
 
winglis4Commented:
Have you properly setup the path to the phpMyAdmin root directory in /phpMyAdmin/config.inc.php? I have not seen the errors you list from your log, though....

Look for this section - it is right near the top of the file
/**
 * Your phpMyAdmin url
 *
 * Complete the variable below with the full url ie
 *    http://www.your_web.net/path_to_your_phpMyAdmin_directory/
 *
 * It must contain characters that are valid for a URL, and the path is
 * case sensitive on some Web servers, for example Unix-based servers.
 *
 * In most cases you can leave this variable empty, as the correct value
 * will be detected automatically. However, we recommend that you do
 * test to see that the auto-detection code works in your system. A good
 * test is to browse a table, then edit a row and save it.  There will be
 * an error message if phpMyAdmin cannot auto-detect the correct value.
 *
 * If the auto-detection code does work properly, you can set to TRUE the
 * $cfg['PmaAbsoluteUri_DisableWarning'] variable below.
 */
$cfg['PmaAbsoluteUri'] = 'http://localhost/phpMyAdmin/';
0
 
matd_Author Commented:
No, that has been set corectly. My guess this is some MySQL ro php > MySQL issue as even though it won't let me browse any tables i can still view and set privelages in the phpMyAdmin 'privelages' section.

Somthing else i noticed which i think is very odd, is that i can't type any new value in when i go to insert a record.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
psadacCommented:
i'm not sure it comes from mysql, but take a look at this  :

http://dev.mysql.com/doc/mysql/en/Communication_errors.html

with php 5 mysql extension is not enabled by default, and there's a new mysql extension called mysqli which does not work with phpmyadmin.  so you should check if the mysql extension is enabled in your phpinfo()
0
 
draconius22Commented:
Are you shure your firewall accepts connections through the 3306 port at least for your other servers which will access it?
0
 
matd_Author Commented:
Hi periwinkle,

Please close this question and refund my points. I have solved this problem myself by updating my php and mysql to the latest versions.

Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.