Solved

Adjust Auto-Complete Settings

Posted on 2004-08-11
12
2,020 Views
Last Modified: 2012-06-27
I am running Outlook 2002 and whenever it tries to auto-complete email addresses for me it uses all sources of email addresses.  Is there any way to force Outlook to search ONLY in your contacts for auto-complete email addresses?

I find it very problematic that if I mis-type an email address when I try to retype the address, which is not in my address book/contacts, it auto-completes to the one that is incorrect!  It's even more confusing when it goes by the person's name and I end up with two "John Smith's" to pick from but I can't see the email address on either of them.

So, what I want to do is force Outlook to only make suggestions from my contacts/address book.  Can this be done?

Regards, Iguanasan
0
Comment
Question by:Iguanasan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
12 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 11772166
Hi Iguanasan,
> Is there any way to force Outlook to search ONLY in your contacts for
> auto-complete email addresses?

What exactly comes when you try to autocomplete a particular contact . what all sources are you talking about ?

>> I find it very problematic that if I mis-type an email address when I try to retype the address,

if you had mistyped something and if it comes back again , just press DELETE on your keyboard and it will get removed .



SR..
0
 
LVL 4

Author Comment

by:Iguanasan
ID: 11772269
Here's a better scenario.  Someone sent me an email which was addressed to me and CC'd to someone else I know.  Let's call him "John Smith".  However, they got his email address wrong.  When I type "John" into the TO box to send an email to "John Smith" I get 2 "John Smith" entries to choose from.  One is from my contacts and is correct, the other is from the CC box of the email I received.  That address is incorrect.  The problem is it only shows "John Smith" twice so I can't tell which is the correct one and which one is bogus.

If I could force Outlook to only look at my contacts when presenting me with auto-complete options then my problem would be solved.
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 11772281
Try doing this first

How to Reset the Nickname and Automatic Completion Cache In Outlook 2003 and Outlook 2002
http://support.microsoft.com/default.aspx?scid=kb;en-us;287623&Product=out

Then make sure going to your CONTACTS folder that there are no 2 john smith's

Post back how it goes

SR
0
Create Professional Looking Email Signatures

Create "Professional HTML Email Signatures" with ease.
7 Day Money Back Guarantee if not 100% Satisfied.
Affordable - Try it out for 7 Days Totally Risk Free.
Installers provided for over 45 Email clients.
Both Windows & MAC Supported.
Highly Recommended!

 
LVL 4

Author Comment

by:Iguanasan
ID: 11772663
Only one "John Smith" and it worked perfectly.  However, the next time I get an email with "John Smith" in it then I'm going to end up with him in my new nicknames file with two entries and one will be incorrect.  Can I stop Outlook from adding items to the nicknames file unless they are also in my Contacts?  Or some similiar work around?
0
 
LVL 49

Accepted Solution

by:
sunray_2003 earned 200 total points
ID: 11772712
It is nature of outlook to create that nickname cache to be used for autocompleting email addresses so inorder to have autocompleting feature work , Outlook needs that nickname file.
If you disable autocompleting feature then outlook doesnot require nickname file.that is the only way to prevent outlook from
 not having to build that nickname file ..

SR
0
 
LVL 8

Assisted Solution

by:jessnjeff
jessnjeff earned 50 total points
ID: 11774222
I would click on the Address book icon and select Tools, Options, in the window where you can tell Outlook where to look for names, remove the unneeded address book.  Granted I am working in OUtlook 2003, but I believe you can do it in XP
0
 
LVL 4

Author Comment

by:Iguanasan
ID: 11775738
Well, jessnjeff, that sounds exactly like the option I want, however, I cannot find any such option in Outlook 2002.  I can't find an Address book icon.  I do have "Tools"..."Options"... but cannot find any windows where you can tell Outlook where to look for names.  Possibly this is a new feature to Outlook 2003.  I may have to do some reading on the MS site.

Iguanasan
0
 
LVL 8

Expert Comment

by:jessnjeff
ID: 11775766
In your main view in outlook, it is the icon that looks like an open book, alternatively, isn't it on the Tools menu?
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 11775920
>> where to look for names, remove the unneeded address book.

in outlook 2002 you can remove unwanted address book going to
tools --> email accounts --> view or change existing directories or address book
and remove the ones that are not needed

SR
0
 
LVL 8

Expert Comment

by:jessnjeff
ID: 11776022
in outlook 2002 you can remove unwanted address book going to
tools --> email accounts --> view or change existing directories or address book
and remove the ones that are not needed


isn't that what i stated above?
0
 
LVL 4

Author Comment

by:Iguanasan
ID: 11776902
Found it.  There is no "Address Book" for the Nicknames file, however.  That's the whole problem, the offending email address is not in any address books, it gets added to my nicknames file though.  Is there anyway to prevent Outlook from adding items that are not in the address book?

Iguanasan
0
 
LVL 4

Author Comment

by:Iguanasan
ID: 11792752
Thanks for the effort.  I guess there is no solution but I've awarded points for the help.

Thanks again.

Regards, Iguanasan
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question