?
Solved

Letting DHCP broadcasts through (cisco 2501)

Posted on 2004-08-11
9
Medium Priority
?
1,162 Views
Last Modified: 2008-02-01
I have 2 cisco routers at my house and two subnets  I'm using for hosts.(192.168.1.0 and 192.168.2.0)

I have a win2k DHCP server at my hosue with two scopes defined (I have 2 physical subnets so it's not a superscope right?).  One scope is for the 192.168.1.0 network, the other for the 192.168.2.0 network.

The DHCP server is on 192.168.1.0 and all the clients on that network get addresses fine.  Of course, users on the 192.168.2.0 network cannot get an IP address.   How do I configure my cisco router to let DHCP broadcasts through?  I would rather do this, then install another DHCP server in the 192.168.2.0 network.
Thanks
0
Comment
Question by:dissolved
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11777155
On the ethernet interface connected to the 192.168.2.0 subnet, use the following command:

en
conf t
interface e0 <-- use correct interface
ip helper-address 192.168.1.x  <--- use the IP address of the DHCP server
0
 

Author Comment

by:dissolved
ID: 11777400
Thank you. I will try this when I get home.
0
 

Author Comment

by:dissolved
ID: 11778407
JFrederick, here is my network:

http://mvpbaseball.cc/post.jpg

Which router should I put the command in????
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:dissolved
ID: 11778705
I did the command and it did not work. Should I be forwarding the proper udp ports on routera, to router B?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11782723
You need to use the command on 2501b's ethernet0 interface:

2501b>en
Password:
2501b#conf t
2501b(config)#interface e0
2501b(config-if)#ip helper-address 192.168.1.98   (assuming your DHCP server is this server)

DHCP broadcasts are forwarded by default with the "ip helper-address" command.
0
 

Author Comment

by:dissolved
ID: 11783349
Yes 192.168.1.98 is my DHCP server address.  Hmm, I did the ip helper-address 192.168.1.98 command on both of my cisco routers.  When I view the run, it shows up as being there.
 
Yet my clients on the 192.168.2.0 network cant pull down an IP.

The scopes on my DHCP server are
192.168.1.1-192.168.1.12
and
192.168.2.1-192.168.2.12

diagram of network here http://mvpbaseball.cc/post.jpg
Thanks
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 11783521
You only need the "ip helper-address" command on the 2501b's E0 interface.  Remove it from the others.

Are you able to log DHCP requests (Audit in Windows 2000 DHCP server) to see if the request is making it to the DHCP server?

Also try the following commands, should be enabled by default but worth a try.

2501b(config)#ip forward-protocol udp 67
2501b(config)#ip forward-protocol udp 68

If that still doesn't work, can you post your configuration of the 2501b router, removing passwords.
0
 

Author Comment

by:dissolved
ID: 11787668
Still didnt work. Here is my sh run
thanks

RouterB#sh run
Building configuration...

Current configuration : 923 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RouterB
!
logging rate-limit console 10 except errors
enable secret 5
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 description connected to WAP
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.1.98
!
interface Serial0
 description connected to ROuterA
 ip address 192.168.0.6 255.255.255.0
 encapsulation ppp
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.2.0
!
ip kerberos source-interface any
no ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.5
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password
 login
!
end
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11790105
How about a "show run" and "show route" on RouterA?  Perhaps RouterA isn't learning the route to 192.168.2.x?
Does the DHCP server know about RouterA?  Or just the default gateway, the Sohoware.  You might do best to point the server's default gateway at RouterA unless the Sohoware also speaks RIPv2.





0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question