Solved

Letting DHCP broadcasts through (cisco 2501)

Posted on 2004-08-11
9
1,156 Views
Last Modified: 2008-02-01
I have 2 cisco routers at my house and two subnets  I'm using for hosts.(192.168.1.0 and 192.168.2.0)

I have a win2k DHCP server at my hosue with two scopes defined (I have 2 physical subnets so it's not a superscope right?).  One scope is for the 192.168.1.0 network, the other for the 192.168.2.0 network.

The DHCP server is on 192.168.1.0 and all the clients on that network get addresses fine.  Of course, users on the 192.168.2.0 network cannot get an IP address.   How do I configure my cisco router to let DHCP broadcasts through?  I would rather do this, then install another DHCP server in the 192.168.2.0 network.
Thanks
0
Comment
Question by:dissolved
  • 5
  • 3
9 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11777155
On the ethernet interface connected to the 192.168.2.0 subnet, use the following command:

en
conf t
interface e0 <-- use correct interface
ip helper-address 192.168.1.x  <--- use the IP address of the DHCP server
0
 

Author Comment

by:dissolved
ID: 11777400
Thank you. I will try this when I get home.
0
 

Author Comment

by:dissolved
ID: 11778407
JFrederick, here is my network:

http://mvpbaseball.cc/post.jpg

Which router should I put the command in????
0
 

Author Comment

by:dissolved
ID: 11778705
I did the command and it did not work. Should I be forwarding the proper udp ports on routera, to router B?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 43

Expert Comment

by:JFrederick29
ID: 11782723
You need to use the command on 2501b's ethernet0 interface:

2501b>en
Password:
2501b#conf t
2501b(config)#interface e0
2501b(config-if)#ip helper-address 192.168.1.98   (assuming your DHCP server is this server)

DHCP broadcasts are forwarded by default with the "ip helper-address" command.
0
 

Author Comment

by:dissolved
ID: 11783349
Yes 192.168.1.98 is my DHCP server address.  Hmm, I did the ip helper-address 192.168.1.98 command on both of my cisco routers.  When I view the run, it shows up as being there.
 
Yet my clients on the 192.168.2.0 network cant pull down an IP.

The scopes on my DHCP server are
192.168.1.1-192.168.1.12
and
192.168.2.1-192.168.2.12

diagram of network here http://mvpbaseball.cc/post.jpg
Thanks
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 125 total points
ID: 11783521
You only need the "ip helper-address" command on the 2501b's E0 interface.  Remove it from the others.

Are you able to log DHCP requests (Audit in Windows 2000 DHCP server) to see if the request is making it to the DHCP server?

Also try the following commands, should be enabled by default but worth a try.

2501b(config)#ip forward-protocol udp 67
2501b(config)#ip forward-protocol udp 68

If that still doesn't work, can you post your configuration of the 2501b router, removing passwords.
0
 

Author Comment

by:dissolved
ID: 11787668
Still didnt work. Here is my sh run
thanks

RouterB#sh run
Building configuration...

Current configuration : 923 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname RouterB
!
logging rate-limit console 10 except errors
enable secret 5
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 description connected to WAP
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.1.98
!
interface Serial0
 description connected to ROuterA
 ip address 192.168.0.6 255.255.255.0
 encapsulation ppp
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.2.0
!
ip kerberos source-interface any
no ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.5
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password
 login
!
end
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11790105
How about a "show run" and "show route" on RouterA?  Perhaps RouterA isn't learning the route to 192.168.2.x?
Does the DHCP server know about RouterA?  Or just the default gateway, the Sohoware.  You might do best to point the server's default gateway at RouterA unless the Sohoware also speaks RIPv2.





0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now