Solved

Problem starting IIS default web site

Posted on 2004-08-11
17
584 Views
Last Modified: 2008-01-09
Windows 2003 Server - updates current
Symantec AV Server - current
Exchange 2003 Server - newly installed
Share Point Portal Services 2003 - newly installed

PROBLEM: Default web site is stopped and will not start.

Error message is: "The process cannot access the file because it is being used by another process."

Event viewer (system log) also records the following errors:

"Cannot register the URL prefix 'https://*:443/' for site '1'. The site has been deactivated.  The data field contains the error number."

AND

"Unable to bind to the underlying transport for 0.0.0.0:443. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine."

I have rebooted (of course), tried all combinations of restarting WWW service and default site.  I have stopped all sharepoint services in combination with my restart attempts, and also have stopped SAV as well.  In addition I have excluded the INETPUB directory from SAV realtime protection.

Any other ideas...?

Thanks.

0
Comment
Question by:jamest521
  • 8
  • 5
  • 3
  • +1
17 Comments
 
LVL 14

Expert Comment

by:alimu
ID: 11779892
Exchange and Sharepoint could both be using this port - if you open up computer management, services & apps and look at IIS, check if you have other websites listed there and what ports they are operating on.

running netstat -ao from the command prompt will show you listening ports and the process id's that are using them (then you can check task manager to work out which process id = which app).
0
 
LVL 8

Expert Comment

by:jodypeet
ID: 11780532
yup sounds like you've got either 2 websites trying to use the same port, or two websites trying to use the same directory.
Check all sites in IIS for ports and directories.
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 11787011
What's your IP address?

Dave Dietz
0
 
LVL 14

Expert Comment

by:alimu
ID: 11789254
Jamest521 - could you please comment and advise if you're still having issues.
thanks,
AJ.
0
 

Author Comment

by:jamest521
ID: 11790006
AJ - Thanks for the comments - much appreciated.  This server is at a customer site - I won't visit again until at least Tuesday.  I appreciate your patience and assistance and I will be trying your suggestions out as soon as I get back there...

Cheers,
James
0
 

Author Comment

by:jamest521
ID: 11831809
Checked as suggested above - nothing listening on 80 or 443 (the ports assigned to the default website). As a result of the Exchange and SPSS installs I have various subsites of the default site but none are assigned conflicting ports. The SPSS Central admin site is assigned 3661. No directory conflicts either.

Stopped the SPSS site but trying to start the default site still gives the original error message.

I'm out of ideas except for removing SPSS and seeing what happens...

James
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 11834861
Telnet to port 443 and see if you get a response.

I have seen a number of issues where a hidden process grabs 443 and that could cause the issue you are seeing.

If you will post your IP address I will be happy to check it out. (Hence my request 6 days ago.....)  

:-)

Dave Dietz
0
 

Author Comment

by:jamest521
ID: 11837099
Dave,

I will try the Telnet option.  At this point in time, the server is not visible from the outside - have not yet enabled the firewall for 1-1 NAT to this box.  Always cautious, I was not prepared to expose any service suntil I was happy with the operation of the box.

Thanks,
James
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 14

Expert Comment

by:alimu
ID: 11847072
Check your IP address on the site is correct.  I'm not sure if the error you showed in the first post was as displayed or altered for posting on EE, but 0.0.0.0 won't work.  Try using "All unassigned" at least while you're troubleshooting the issue.
0
 

Author Comment

by:jamest521
ID: 11847280
The error messages were as displayed... I will be troubleshooting some more tomorrow...
0
 

Author Comment

by:jamest521
ID: 11903505
Well, having reached dead-end with the variou ssuggestions above I removed (or should say tried to remove) SPSS -it failed during the uninstall.  Stopped and disabled all the associated services anyway and then proceeded to remove Exchange and IIS.

Reinstalled IIS and then Exchange. IIS worked fine, default web site started, Outlook Web Access worked.  Did nothing further to the server and when I arrived this morning the default web site had stoped and is now giving the same error message as before.

I know you guys must be getting bored with this one but any ideas...?

Thanks,
James
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 11906898
What results did you get when trying to telnet to port 443?

Dave Dietz
0
 

Author Comment

by:jamest521
ID: 11908136
Dave,

I get a connection but no other prompts.

Host is 216.204.155.21  - ports 25, 80, 443, and 3389 are open.

Regards,
James
0
 
LVL 34

Accepted Solution

by:
Dave_Dietz earned 500 total points
ID: 11909336
Should it come up with HP Power Manager?

Thisis the output I get from Wfetch:

started....
WWWConnect::Connect("216.204.155.21","443")\n
source port: 3387\r\n
REQUEST: **************\nGET / HTTP/1.1\r\n
Host: 216.204.155.21\r\n
Accept: */*\r\n
\r\n
RESPONSE: **************\n
HTTP/1.0 302 Redirect\r\n
Server: GoAhead-Webs\r\n
Date: Thu Aug 26 22:01:34 2004\r\n
Pragma: no-cache\r\n
Cache-Control: no-cache\r\n
Content-Type: text/html\r\n
Location: https://216.204.155.21/index.asp\r\n
\r\n
<html><head></head><body>\r\n
\t\tThis document has moved to a new <a href="https://216.204.155.21/index.asp">location</a>.\r\n
\t\tPlease update your documents to reflect the new location.\r\n
\t\t</body></html>\r\n
\r\n
finished.

Seems to indicate that the server listening on 443 is GoAhead-Webs, not IIS.  This would cause a problem for IIS binding to that port....  :-)

Dave Dietz
0
 

Author Comment

by:jamest521
ID: 11912743
Yes, the server is running HP Power manager and it does have an SSL mode for the management web site. I will follow this lead today and let you know. Thanks for the investigation - hopefully you have nailed it.  

Cheers,
James
0
 

Author Comment

by:jamest521
ID: 11913768
Dave,

That solved the problem. Thanks!!!

Cheer,
James
0
 
LVL 34

Expert Comment

by:Dave_Dietz
ID: 11914183
Glad to be of assistance.....  :-)

Dave Dietz
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

Numerous times I have been asked this questions that what is it that makes my machine log on so slow, there have been cases where computers took 23 minute exactly after taking password and getting to the desktop. Interesting thing was the fact th…
Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now