Solved

Delegates not receiving meeting requests and reminders problem

Posted on 2004-08-11
16
966 Views
Last Modified: 2012-08-14
Not sure if this should go under Outlook, but this was the result of a Exchange 2000 mailbox restore

Exchange 2000 Post Sp3
Windows 2000 Sp4

After installing Groupshield 6 months ago our Exchange server has become anything but stable. A few weeks ago the server crashed and after restarting some of the users emails had blank body's of the message.

I used exmerge and removed all users Inbox and Sent Items because this is where it seemed to happen the most. I then restored only the Inbox and Sent Items from a brick level backup I had.

After the restore was complete, most, if not all,  reminders had stopped working for users. For most people running a /cleanfreebusy and /cleanreminders fixed the problem. But what I am getting calls about now is that people whom are delegates for mailboxes no longer receive meeting requests as they once had.

I have tried just about everything I can think of, /cleanfreebusy /cleanreminders. I have removed them as delegates and then readded them. There is a check mark next to delegates receive copied of meeting requests sent to me. Everything is as it was. But no dice.

Anyone know what is going on here?
0
Comment
Question by:mmurfmis
  • 9
  • 7
16 Comments
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
I don't use Groupshield but I did have this problem a while back and think I fixed it by removing the delegates > then launching Outlook with the /resetfolders switch ... then added them back ...  I still had a few which I ended up just blowing out the mailbox ...

btw ... Have you checked the consistency of your database lately?
0
 

Author Comment

by:mmurfmis
Comment Utility
I ended up fixing this today. All I had to do was open the permissions for the delegate click ok and apply and it was fine. I completing wasn't testing this correctly. For some reason had though that if I created a new meeting request within the mailbbox that it would automatically send to the delegates. This is a resource calendar which when added to the meeting request as resource it sent to the delegates fine.

But funny you ask about the consistency, because since I installed GS back in January this server has crashed about 3-4 times. And when I say crash, I mean I had to restore the entire store once this last time I had to restore most of the mail and the other times it did an automatic soft recovery by playing back the logs.

So anyhow according to the veritas brick level backup logs, there is some items in the store that are corrupted. Also the database has almost doubled since the brick level restore so I have a planned downtime tomorrow night for an offline defrag. I am a little nervous about this one because of all the problems I had with this Groupshield and the corruption.

Do you think the offline defrag will go smoothly? My information store backups run fine. And if the defrag will not complete because of corruption, should I try to fix it with the eseutil?
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
How many mailboxes do you have? If you have under 100 or so and extra disk space ... I'd consider ExMerging the entire database and then bring up a new database ... then import the data after you recreate the mailboxes ... It's been a while but it seems like you can use the .ini file in Exmerge to filter corrupt items ...

I'd think about reinstalling GroupShield at the same time ... and make sure you get a solid backup after the new store is up.

No matter what you do ... make sure you have a backup before using eseutil ... have you run eseutil will defrag and compress ... you should use ISINTEG to fix database errors ... I'd check for errors before doing any offline defrag
0
 

Author Comment

by:mmurfmis
Comment Utility
I have about 900 mailboxes with a current database size of 35gig. This is why this becomes such a problem. The store is so large that anything I have to do takes so much time. I need to reduce the amount of downtime.

Now I would want to reinstall GS, but I have been working with Mcafee support on these issues among other problems with the software, and I have asked them if I should reinstall and they said no. Its a problem with the software not the installation. They have sent me numerous hotfixes, and they have walked me though many different command line config changes among many other change.  I have spent hours on the phone with me. And everything they have had me do has made something else within the software not work correctly. So I am really relucant to do anything with that software but uninstall when the higher ups finnally listen to me about going back to Antigen.

The problem with GS 6 is with their rpcserv.exe process which servers which who see alot of traffic these processes hog all the cpu time to the point where the sever eventully does not know what to do and just dies. It seems to work ok if you don't enable file or content filtering. So I had to install another one of their products called Webshield for SMTP one a relay which is a old, almost unsupported product with limited capabilities because they want you to use their appliance hardware for Webshield.

Put it this way as soon as we have money in the budget, this software is gone. We have had nothing but problems with Mcafee products. We only had Mcafee running on the desktops, but because of budget problems we went with Mcafee on the Exchange server. I used to run Sybari Antigen for years, I can say this is hands down the best VS for Exchange I could scan transport and store and I could do file and content without a single problem. It had 5 different scanning engines from variuos different companies. Mcafee is late on producing their dats all the time which means new virues get through all the time which never happened with Antigen. Their support is great and would respond to my emails within minutes most of the time.

Alright back to the defrag, should I use eseutil to check for errors? I have never used the isinteg and I thought it ws only to be used a an absolute last resort?

Because I thought the eseutil defrag would check for errors? But if it finds one and stops, is the store hosed?

What would you suggest my steps to doing this?
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility

Antigen 8.0 is definitely the only way to go ... with 9k mailboxes I've never had one virus in the box ... btw .. make sure you disable the Reverse DNS feature in Options if you go with Sybari ... it will make it seem like you have GC/DSAccess issues on your servers if ran ....

Ahh for some reason I was thinking you had already ran eseutil ... You are right however, it is the last resort ... I would try /d or maybe even /p ... I don't do much disaster recovery these days ... generally when my databases start crapping out I'll just offload the users and wipe the database ... that being said -

btw ... if Groupshield is anything like Antigen ... you might want to unhook to software from your database before performing any maintenance ... probably need to check with GS

According to an MVP in the PSS - Regarding Isinteg:

Run Isinteg in -fix -test alltests mode.

Isinteg is the only repair utility that understands the Exchange database as an Exchange database. That statement probably deserves some explaining.

ESE is a generic database engine that can be used by different applications, with Exchange happening to be one of them. Active Directory is another. Eseutil looks at the database as just another ESE database, and sees it's contents as a bunch of tables and indexes. It doesn't know or care whether this table holds a mail folder or that table has attachments in it. It just fixes up the tables so they are valid ESE tables once again. Eseutil doesn't understand that this database holds folders and messages--it just has tables and records.

Isinteg understands the relationships between those tables and records that turn them into folders and messages. If Eseutil had to delete a record that was a message, Isinteg knows how to decrement the count of messages for every folder that had a copy of that message. If you don't run Isinteg, clients will likely see strange things--like message counts that are off, messages that appear in the Inbox but can't be read, and so on.

When you run Eseutil, you can move database files to temporary locations to make repairs. But to run Isinteg, you must put the database back in the location from which it is normally mounted. The reason for this is that Isinteg actually mounts the database in order to read it through the Information Store process, while Eseutil reads databases as raw files.

At the end of an Isinteg fix run, you will likely see hundreds to thousands of warnings. This is normal. Isinteg was originally created as an internal test utility and its output is quite verbose, deliberately so. The thing you need to worry about is not warnings, but errors. At the end of a successful Isinteg run, there should be zero errors reported. If there is even one error, you should run Isinteg again.

If successive runs of Isinteg do not decrease the number of errors reported, and you cannot get the error count down to zero, then you should not rely on this database in production. You should move mailboxes from it or otherwise salvage data, and then discard it. It's relatively infrequent for Isinteg to not be able to get the error count down to zero, however.
0
 

Author Comment

by:mmurfmis
Comment Utility
Are you referring to disabling reverse DNS on SMTP? I know I have that enabled. What problems will this cause?

I have run eseutil before, but now since all these problems. And the other problem I have now is that I do not have 110% of the diskspace to run it, so I have to map a drive and run the temp file to another server.
So what exact switches should I use to run it to temp database as you say? I am think your saying run this to temp but do not run the switch that copies it back? so I would still have the original db?
0
 
LVL 12

Accepted Solution

by:
BNettles73 earned 500 total points
Comment Utility
No ... if you switch back to Sybari Antigen ... they have a Reverse DNS setting in the General Options now ... if you enable that feature it will drag mail performance down like you wouldn't believe ... I was troubleshooting what I thought to be a GC/DSAccess issue for two weeks before I realized the Antigen 8.0 upgrade included a new feature ...

Yes, if you run it to the temp and don't switch back ... you'll have your original database in case anything goes wrong ... disk space is always an issue though ... I'm not sure how running it over the network (or even if you can) would work ... then again I've never done that so hard to say


Here is a loaded up Eseutil repair command line:

Eseutil /P c:\exchsrvr\mdbdata\DB1.EDB /Sd:\exchsrvr\mdbdata\DB1.STM /Te:\TEMPREPAIR.EDB

This command line will repair DB1.EDB located on C: along with its matching .STM file located on D: and will put the temporary file on the E: drive.

If your streaming database file (.STM) is not matched to the database file (.EDB) or it has a problem that is blocking repair, you can repair without it by adding the /createstm switch to the repair command line. This will destroy the .STM file and repair only the data in the .EDB file. What do you lose if you lose the .STM file?

It depends on what kind of clients attach to your Exchange server. If everybody uses Outlook (MAPI protocol), then there will be very little user data in the .STM file. You may lose some in transit messages that haven't been delivered yet. If clients connect via POP3 or IMAP then most of their stuff will be in the .STM file, and its loss will be catastrophic to them. If clients use Outlook Web Access, messages will be in the .EDB file, but attachments sent will be in the .STM file.

Repair can take a while--hours. When it finishes, it will leave you with a very detailed log file of what it did called <database>.integ.raw.


If you are concerned about the process ... you may want stick with the standard offline defrag ....  whatever you do ... make sure you have a good backup
0
 

Author Comment

by:mmurfmis
Comment Utility
Alright, thank you, this definatly helps. I will let you know how it goes on Monday.

0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
Good luck!
0
 

Author Comment

by:mmurfmis
Comment Utility
Bnettles73, I ran the defrag and it was sucessful, but it onlt reduced the size of the database to 24gig. I wasnt appy with that because I know it should be less. And each time I rebooted it would try to run a soft recover which did not seem right. So I tried running the defrag again this time it gave me LV errors. I also ran an integrity check and it told be the database was corrupted.

So I went for the eseutil /p it took about 40mins but it said it repaired it. I looked through the log and it had a ton of SLV errors on unused space. I ran a backup again and now I am running the defrag again.

Should I run isinteg? Or since the eseutil /p was successful am I ok?
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility
If the database mounted with no errors you should be ok ...  fyi ... the database rarely will compact all of the whitespace ... more or less cleans it up
0
 

Author Comment

by:mmurfmis
Comment Utility
Thats a good thing. So in what sitution would you run isinteg after the eseutil /p?

The defrag is still running. Should be done soon. What is strange is the first time I ran the defrag it completed ok. Why do you think the second time it found errors?
0
 

Author Comment

by:mmurfmis
Comment Utility
And also, why do you think the fist time I ran the defrag, it would run a soft recovery each time the server was restarted?
0
 

Author Comment

by:mmurfmis
Comment Utility
I am concerned by one of the things you say about isinteg and eseutil. Are my users going to see things like message counts are off and messages cant be read because I ran eseutil and not isinteg?

"Isinteg understands the relationships between those tables and records that turn them into folders and messages. If Eseutil had to delete a record that was a message, Isinteg knows how to decrement the count of messages for every folder that had a copy of that message. If you don't run Isinteg, clients will likely see strange things--like message counts that are off, messages that appear in the Inbox but can't be read, and so on."
0
 
LVL 12

Expert Comment

by:BNettles73
Comment Utility

You would want to run isinteg after eseutil /p if there were still issues or errors ...


"Are my users going to see things like message counts are off and messages cant be read because I ran eseutil and not isinteg?"

It is possible that the issue might occur, but I've rarely seen this unless the database had serious corruption ... then again, this is why we always make sure there is a solid backup before running these utilities ....
0
 

Author Comment

by:mmurfmis
Comment Utility
Well things seem to have went well for the most part. I still have the same corruption errors with the Veritas brick level backup on certain mail files. There is about 73 of them, so I have just been removing them one by one and then restoring if needed. I am guessing that the isinteg would have fixed this type of corruption.

WARNING: "\\EXCH2K\Microsoft Exchange Mailboxes\Bekdash, Rola [rbeckdas]&#61478;Top of Information Store&#61478;Calendar&#61478;&#140;&#12336;&#12336;&#12336;&#12336;&#12340;&#14133;&#25910;&#25443;&#12593;&#25650;&#12856;&#13364;&#13153;&#25958;&#25143;&#25401;&#25906;&#14391;&#25137;&#25912;&#14128;&#12336;&#14182;&#25145;&#25186;&#14177;&#12646;&#13618;&#13156;&#12593;&#26209;&#12338;&#12336;&#12387;&#25648;&#12336;&#13413;&#12345;&#12336;&#12336;&#13360;&#12855;&#12390;&#12601;&#12336;&#12336;&#14435;&#12646;&#13925;&#13361;&#12390;&#12599;&#12642;&#25140;&#12601;&#14393;&#25401;&#25957;&#25906;&#12341;&#24886;&#25445;&#12336;&#12336;&#12592;&#25701;&#26162;&#25136;&#12336;&#12336;Sight to Insight: The Power of The Visual in Teaching, Learning, and Fostering Creativity" is a corrupt file.
This file cannot verify.
Database or database element is corrupt
WARNING: "\\EXCH2K\Microsoft Exchange Mailboxes\Belin, Jacki [jbelin]&#61478;Top of Information Store&#61478;Calendar&#61478;&#140;&#12336;&#12336;&#12336;&#12336;&#26214;&#13156;&#25393;&#13111;&#12598;&#25648;&#13156;&#12593;&#12641;&#26210;&#12336;&#12342;&#14384;&#14649;&#26212;&#24929;&#14128;&#12336;&#25185;&#14689;&#25189;&#13104;&#13922;&#26160;&#12900;&#12593;&#12641;&#25401;&#12336;&#12342;&#14384;&#14649;&#26212;&#24929;&#12336;&#12336;&#12336;&#13625;&#13880;&#13109;&#12336;&#12336;&#14435;&#12646;&#13925;&#13361;&#12390;&#12599;&#12642;&#25140;&#12601;&#14393;&#25401;&#25957;&#25906;&#12341;&#24886;&#25445;&#12336;&#12336;&#12848;&#25188;&#14437;&#13924;&#12336;&#12336;Fourteenth Community of Scholars Colloquium" is a corrupt file.
0

Featured Post

Why do Marketing keep bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

Join & Write a Comment

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now